Vista print spooler problem


G

Guest

A customer brought her Lenovo laptop w/VHP in because the print spooler
crashes whenever she clicks on Add Printer. She had clicked it because her
printer had disappeared from the system.

The event log shows event ID 1033, "the print spooler cannot start because
the printerBusEnumerator could not start. Error code 0x80070006. This can
occur because of system instability or a lack of system resources."

I can restart the spooler service after this error, but no printers appear
in the printer window. She previously had an HP OJ 7110 and the Microsoft xps
writer in the folder.

If I try to go into printer server properties, this also causes the spooler
to crash, with the same error code.

I followed the instructions from here...
http://members.shaw.ca/bsanders/CleanPrinterDrivers.htm

.... but they didn't help.

Anyone know of a fix for this?
 
Ad

Advertisements

J

jimjamsellis

A customer brought her Lenovo laptop w/VHP in because the print spooler
crashes whenever she clicks on Add Printer. She had clicked it because her
printer had disappeared from the system.

The event log shows event ID 1033, "the print spooler cannot start because
the printerBusEnumerator could not start. Error code 0x80070006. This can
occur because of system instability or a lack of system resources."

I can restart the spooler service after this error, but no printers appear
in the printer window. She previously had an HP OJ 7110 and the Microsoft xps
writer in the folder.

If I try to go into printer server properties, this also causes the spooler
to crash, with the same error code.

I followed the instructions from here...http://members.shaw.ca/bsanders/CleanPrinterDrivers.htm

... but they didn't help.

Anyone know of a fix for this?
Sorry to be a pain, this error just happened to me but I've managed
to
fix it - do you still need the instructions?
 
Ad

Advertisements

J

jimjamsellis

seem to be two links: heres another one for you:http://groups.google.com/group/microsoft.public.windows.vista.print_f...







- Show quoted text -
I've found this problem was caused by a registry issue concerning the
PrinterBusEnumerator entry in the System\CurrentControlSet\Enum\UMB
\UMB\1&841921d&0&PrinterBusEnemerator.

Either this entry is corrupt or missing or the required drivers are
not installed. As this is not a plug and play device the drivers are
not installed on a restart or through device manager by clicking
update hardware.

To correct this issue:

Start, [RIGHT CLICK] Computer, Properties, Device Manager
[CONTINUE],

From Menu bar, choose VIEW, Show Hidden devices.Then Devices by
connection.
Scroll to System Devices, and then UMBus Enumerator. Check that there
are two others. Do not delete.

If there are three:

Right click on the bottom one. Choose properties. Under details tab
choose under the property combo box DEVICE CLASS GUID.
Confirm GUID matches that under the DRIVER entry in the registry as
above.
Right click and uninstall (you will reinstall in a second)

If the GUID does not match, choose the other two until you find the
correct one.


Choose ACTION, ADD LEGACY HARDWARE
Choose NEXT
Choose INSTALL THE HARDWARE THAT I MANUALLY SELECT.. (ADVANCED)
Choose SYSTEM DEVICES, then MICROSOFT and UMBUS Enumerator

Restart, a system install will begin on restart of various associated
drivers.
When complete, restart again and check service is running.

Help this helps,

jimjamsellis
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads

Vista Print Spooler 3
Print Spooler - Vista 8
Vista spooler problem 13
vista print spooler crash 2
Vista Print Spooler dies 2
Vista print spooler not working. 2
Vista 32 bit Print spooler problem? 0
print spooler 1

Top