How I fixed my Vista Print Spooler Problems


P

perrylea

I have been a long time user of Windows XP SP2. I had recently
putchased Vista Ultimate with the intent to upgrade my XP system.

The principal problem was all attempts to add a printer resulted in
errors stemming from the Print Spooler Service.

Before I begin let me preface my environment:

Intel 2.8 GHz machine with 2 GB RAM and ATI 1300 video. XP SP2 as I
mentioned.
I have used over the years the following imaging devices:

a. HP Color LaserJet 4650
b. HP 8150 AIO Injet/Scanner/Fax
c. HP 9100 Digital sender

I should note that the digital sender has long since been removed.
The 8150 is seldom used. Both of these devices had left a long
residue of drivers and services on my XP box. The Laserjet only used
a PCL6 driver.


------ The Vista Experience ---------
Now begins my 14 hours of debug joy. The Vista install went fairly
smoothly. The Windows Compatibility check noted some issues with
Symmantec AntiVirus, ATI veido, Sigmatel Audio, Windows MGR 5.1, and
the Common Client. Nothing seemed out of hte ordinary so I went
with an upgrade install of Vista Ultimate.

The installation took about 3 hours.

When complete I verified that video, networking, my critical
applications, and device worked. Most did, except for the DVD drive.
There is a BLOG dedicated to that issue.

The main problem was trying to add a printer.



All attempts to add a printer resulted in a pop up showing:
"windows can't open add printer. the local print spooler is not
running"

If I manually restarted the Print Spooler service and quickly add a
printer in the Control Panel dialogue I got a different error:
"0x000006be error"


So began the Google searches for help.

1. I attempted to restart the spooler services as noted on many blogs:
http://www.vistax64.com/vista-print...ror-0x000006be-print-spooler-add-printer.html

1. I attempted to manually clean all my drivers and registry changes
as noted here:
http://members.shaw.ca/bsanders/CleanPrinterDrivers.htm
This did not help

2. I traversed HP's site and found this tidbit:
http://h10025.www1.hp.com/ewfrf/wc/...9719&cc=us&dlc=en&lc=en&jumpid=reg_R1002_USEN

No luck yet.

3. I traversed MS support and found this KB:
http://support.microsoft.com/kb/324757
I did go to C:/windows/system32/spool/

I deleted all drivers - residue from the XP builds.

The PRINTERS directory was empty (obviously no prointers were every
installed)

I deleted all printprocs.


Many blogs indicated this successfully worked for different users.

However, this did not resolve the problem.


4. I reinstalled Vista
No luck there either


5. I tried installing a Vista CD installation of the Laserjet 4700
thinking a full Cd isntall might work :

No luck

6. I tried downloading the PrintFlush-1.3 utility to clean the Spooler
settings and queues.
No luck

7. I downloaded the Print Spooler Fix wizard. While this didn't work
it did clue me into some registry settings that were dangling. I
deleted them.
Still no luck

8. Finally I went to C:/windows/system32 and added columns to the
directory listing to indicate company names. I deleted all HP drivers
I could find. I have to say the HP AIO 8150 left a shotgun of driver
residue.


----------------------------------------- The fix
--------------------------------
Now begins some deeper debugging and resolution.

As you see I have stripped my registry settings, drivers, monitors,
and whatnot. You can assume I have no print drivers at this point.

1. I went to Device Manager and reviewed the logs. Under Event Views -
Windows Logs -> Application. I noticed failures related to the
spooler as:

"The print spooler cannot start because the PrinterBusEnumerator could
not start. Error code 0x80070006. This can occur because of system
instability or a lack of system resources."

2. I searched Google and found a relationship between
PrinterBusEnumerator and the UMBus (User Mode Bus).

3. I went to Device Manager again and clicked on View -> Show Hidden
Devices. Selected System Devices. And Uninstalled both the UMBus
Enumerator as well as teh UMBus Root Bus Enumerator.

4. Rebooted.

5. Went to Control Panel. Selected Add Hardware.

6. Selected Install the Hardware Manually.

7. Clicked on the first selection: "Show All Devices"

8. Added back bot the Microsoft UMBus Enumerator and the UMBus Root
Bus Enumerator.

9. Rebooted.

10. Went to add printer. And could then add back my Color Laserjet
4600.

11. Printed a test page and application document as a test.


Hope that might help someone in the future.
 
Ad

Advertisements

M

MrsManolo

Many thanks for a detailed clear explanation. I am trying to solve "Spooler
Subsystem App problems reinstalling Lexmark". Can you look at my post and
suggest any ideas? I have done up to your step 3. Am thinking of completely
going back to factory setup of Vista computer but this will be painful and
timeconsuming and I'm scared it might not solve the problem. How did you do
the Event Views? How did you find the PrintFlush utility and Print Spooler
Fix Wizard?
 
Ad

Advertisements

M

Media Guy

Thank you for your excellent post. I have been fighting with this printer
installation problem for two days. I am a very experienced PC user but this
new Vista thing is making me crazy. Your fix worked and has certainly saved
me more frustration!
Thanks Again!
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top