Spooler not working correctly


P

Portland Pete

A few days ago, my Brother 2070 laser printer would not print.
Documents sent to the printer showed up in the Printer app as
"Document sent to printer --deleting", but the printer would not
fire. Thinking that the printer was not working, I bought a new
Brother 2240, which after installation exhibited the same behavior.
The printer app and printer properties seemed to be working OK in that
it correctly displayed the status of the printer (e.g. "ready"), but
documents would not actually be transmitted to the printer. The
printer self-test worked fine. In Control Panel, the Printer app
shows the printer as installed and working; I set the property to
"print directly to printer" rather than to the spooler. Printing was
successful.
I turned the Print Spooler off in Administrative Services, and the
printer status stopped working. Restarting the spooler restored the
printer status dialog, but still no joy with the actual printing.
While I can now print, I'd like to get the spooler back working, short
of reinstalling my whole Windows. In researching this problem, many
posts dealing with print spooler problems reference files that do not
appear on my system at all, like printspool.exe (I'm running 64-bit
Home Premium, with 8 GB ram).
I'm pretty sure the drivers are OK, because the printer works
perfectly as long as the spooler is bypassed.
Looking forward to suggestions....
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top