mapped drive problems



i have written the following into a shortcut for the program to open from the
mapped drive

in shortcut properties
c:\premier9\myobp.exe m:\Clearwtr.myo where c:\ is the workstation's hard
drive, and m:\Clearwtr.myo is the name of the data file and the letter name
of the mapped drive.
Start in: c:\Premier9

I also placed a script in users start folder:
net use M: \\computername \data /y

But when i open the programs shortcut it does not open the mapped drive and
I need to search for it.

And the logon script does not create the mapped drive. I am needing to add
this in explorer myself.

the mapped drive opens otherwise on the users PC without any problem.


I think you have your Net Use command slightly off.
net use M: \\computername\sharename
(no spaces in the path - only one space after M:)
I assume the /y part is for persistent connections? If so you must use;
net use M: \\computername\sharename /persistent:yes
(there is one space after sharename)
You should test your command from a command prompt and see if it works
before you add it to a script. That way you know it's behavior. If you typed
it right you'll get
"The command completed successfully."
And you can then type M: at a prompt and it will change to your mapped
drive. Run a dir and make sure you are where you want your mapped drive to be.


yes I pasted that sample with incorrect space but in the script it is correct
on the machines. I've gone back over this script in start up - all users
folder and can't seem to figure out why it isn't loading the map drive at


what about the /y part? that would cause it to fail also. When you type your
command(s) at a command prompt does it say "The command completed
successfully" for each line in your script?

instead of in a startup group you can try group policy. Try Computer
Configuration/Windows Settings/Scripts/Startup
User Configuration/Windows Settings/Scripts/Logon

also, do you have a server? your script might work better there too.


what i have is net use M: \\server\share /persistant:yes

I have not tried running the script from the command line and will test that
when i visit again.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question