Keyboard Regional Settings Not Saved


G

Guest

Hi all

We have just set up some new XP Pro SP2 machines on our network. As an
administrator, we set the input locale/regional settings/keyboard etc as UK
English. However, when a non-administrator logs in, the keyboard reverts to
US English. This is intensely annoying, especially as the end-users are
severely restricted by group policy in what they can open/use/change, so they
cannot edit the regional settings while logged in themselves.

We have deleted all non-administrator user profiles from the machines, set
and reset the regional settings as an administrator, copied that profile and
recreated the default user profile by renaming the copied administrator
profile to be the new default user. We have checked and cannot see where
these US English settings are coming from - I even looked at the OOBE
settings but no joy there either. I also spent an hour going through the
registry to see if there was anything there.

Does anyone have any ideas? This is not a show-stopper but very annoying for
our call-centre agents who rely on accurate typing on a British keyboard!!!
 
Ad

Advertisements

E

Elmo

Dobbie said:
Hi all

We have just set up some new XP Pro SP2 machines on our network. As an
administrator, we set the input locale/regional settings/keyboard etc as UK
English. However, when a non-administrator logs in, the keyboard reverts to
US English. This is intensely annoying, especially as the end-users are
severely restricted by group policy in what they can open/use/change, so they
cannot edit the regional settings while logged in themselves.

We have deleted all non-administrator user profiles from the machines, set
and reset the regional settings as an administrator, copied that profile and
recreated the default user profile by renaming the copied administrator
profile to be the new default user. We have checked and cannot see where
these US English settings are coming from - I even looked at the OOBE
settings but no joy there either. I also spent an hour going through the
registry to see if there was anything there.

Does anyone have any ideas? This is not a show-stopper but very annoying for
our call-centre agents who rely on accurate typing on a British keyboard!!!

This may be a stretch:

http://www.kellys-korner-xp.com/xp_tweaks.htm
Line 30. Windows XP Doesn't Save User Settings
 
M

M.I.5¾

Dobbie said:
Hi all

We have just set up some new XP Pro SP2 machines on our network. As an
administrator, we set the input locale/regional settings/keyboard etc as
UK
English. However, when a non-administrator logs in, the keyboard reverts
to
US English. This is intensely annoying, especially as the end-users are
severely restricted by group policy in what they can open/use/change, so
they
cannot edit the regional settings while logged in themselves.

We have deleted all non-administrator user profiles from the machines, set
and reset the regional settings as an administrator, copied that profile
and
recreated the default user profile by renaming the copied administrator
profile to be the new default user. We have checked and cannot see where
these US English settings are coming from - I even looked at the OOBE
settings but no joy there either. I also spent an hour going through the
registry to see if there was anything there.

Does anyone have any ideas? This is not a show-stopper but very annoying
for
our call-centre agents who rely on accurate typing on a British
keyboard!!!

I've not come across this before, but my two pen'orth is to temporarily
change the user accout to administrator status; change the keyboard to UK
and then change the account back to limited.

If you are lucky someone will come along with a better solution.
 
G

Guest

Hey Joe .... it worked! Thank you very much for your registry key tip. In
case anyone else gets the same problem, the walkthrough on a networked PC is:

1. Log in as local administrator
2. Delete ALL profiles EXCEPT the local and domain administrator, Default
User and All Users (may have to show hidden files). Reboot if an ntuser file
in use error appears, and then proceed with the deletions
3. Log in as domain administrator (or an administrative user other than
local administrator)
4. Go into the control panel and change ALL regional/locale/keyboard
features to the selected country, and apply to the current and default user
profile
5. Reboot PC
6. Log in as local administrator - copy the profile logged in under as in
step 3
7. Rename the Default User profile (.old or something), rename the copied
profile from step 6 to Default User
8. Log in under the same profile as in step 3
9. Run the savesettings.reg file from the URL
http://www.kellys-korner-xp.com/xp_tweaks.htm (Line 30. Windows XP Doesn't
Save User Settings) as suggested by 'Elmo'
10. Reboot PC
11. Log in as a non-administrative user and test by use!

Thanks again!!!
 
Ad

Advertisements

E

Elmo

Dobbie said:
Hey Joe .... it worked! Thank you very much for your registry key tip. In
case anyone else gets the same problem, the walkthrough on a networked PC is:

1. Log in as local administrator
2. Delete ALL profiles EXCEPT the local and domain administrator, Default
User and All Users (may have to show hidden files). Reboot if an ntuser file
in use error appears, and then proceed with the deletions
3. Log in as domain administrator (or an administrative user other than
local administrator)
4. Go into the control panel and change ALL regional/locale/keyboard
features to the selected country, and apply to the current and default user
profile
5. Reboot PC
6. Log in as local administrator - copy the profile logged in under as in
step 3
7. Rename the Default User profile (.old or something), rename the copied
profile from step 6 to Default User
8. Log in under the same profile as in step 3
9. Run the savesettings.reg file from the URL
http://www.kellys-korner-xp.com/xp_tweaks.htm (Line 30. Windows XP Doesn't
Save User Settings) as suggested by 'Elmo'
10. Reboot PC
11. Log in as a non-administrative user and test by use!

Thanks again!!!

And thanks to Kelly for such a quality source of tweaks and other help.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top