Internet Explorer doesn't prompt me to be the default browser


L

lisaricho

Hi,

I've been trying for ages to get Internet Explorer to be the default
browser again, and finally found a solution which I thought I'd share
with everyone.

My problem started when I set Firefox to be my default browser to try
and fix an icon display problem (that's a whole other issue). I then
opened internet explorer, expecting to get a message box saying
"internet explorer is not currently your default browser, would you
like to make it your default browser?" - but this message never
appeared.

So first I checked Tools > Internet Options > Programs and made sure
that the checkbox "Internet explorer should check to see whether it is
the default browser" was ticked, and it was. I tried unticking it,
ticking it again, closing my browser and reopening, restarting my
computer, none of this made any difference.

I then tried the solution from "Ramesh's site"
(http://windowsxp.mvps.org/ie/nopromptdefault.htm) which involves
editing the registry and apparently works for most people, but this
didn't work for me either.

So then I thought, what about if I reset the web settings? Sounds like
a pain, but I was almost at the point of re-installing internet
explorer, I was so fed up. And guess what, it worked!! Here's the step
by step instructions:
1. Open internet explorer (make sure only one window of IE is open)
2. Select Tools > Internet Options > Programs
3. Click the "Reset Web Settings..." button
4. It will ask you to reset your home page - You don't have say yes
5. Close Internet Explorer
6. Try opening an internet shortcut - IE will magically be your default
browser again.

It turns out this button doesn't even reset all your internet explorer
defaults, I think it just resets options on the "Programs" tab, so a
very simple solution!

Hope this helps other people as frustrated as me by this problem.

Lisa
 
Ad

Advertisements

R

Ramesh, MS-MVP

Lisa,

For Windows XP SP1 and higher, see:
http://www.winxptutor.com/iedefault.htm

For Windows XP, you can use this .REG file which sets IE as the default:
http://windowsxp.mvps.org/reg/IE_Default_Browser.reg


--
Regards,

Ramesh Srinivasan, Microsoft MVP [Windows XP Shell/User]
Windows® XP Troubleshooting http://www.winhelponline.com


Hi,

I've been trying for ages to get Internet Explorer to be the default
browser again, and finally found a solution which I thought I'd share
with everyone.

My problem started when I set Firefox to be my default browser to try
and fix an icon display problem (that's a whole other issue). I then
opened internet explorer, expecting to get a message box saying
"internet explorer is not currently your default browser, would you
like to make it your default browser?" - but this message never
appeared.

So first I checked Tools > Internet Options > Programs and made sure
that the checkbox "Internet explorer should check to see whether it is
the default browser" was ticked, and it was. I tried unticking it,
ticking it again, closing my browser and reopening, restarting my
computer, none of this made any difference.

I then tried the solution from "Ramesh's site"
(http://windowsxp.mvps.org/ie/nopromptdefault.htm) which involves
editing the registry and apparently works for most people, but this
didn't work for me either.

So then I thought, what about if I reset the web settings? Sounds like
a pain, but I was almost at the point of re-installing internet
explorer, I was so fed up. And guess what, it worked!! Here's the step
by step instructions:
1. Open internet explorer (make sure only one window of IE is open)
2. Select Tools > Internet Options > Programs
3. Click the "Reset Web Settings..." button
4. It will ask you to reset your home page - You don't have say yes
5. Close Internet Explorer
6. Try opening an internet shortcut - IE will magically be your default
browser again.

It turns out this button doesn't even reset all your internet explorer
defaults, I think it just resets options on the "Programs" tab, so a
very simple solution!

Hope this helps other people as frustrated as me by this problem.

Lisa
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top