How to Show Nicknames Only in AutoCompleted E-mail Addresses


J

Jim

I have Outlook 2003 and Windows XP. When I type part of an address into a
new message, I get a selection of autocompleted nicknames as I type. If I
select from that list, I sometimes get the nickname + e-mail address. For
example, if I address a message to Dave Jones, I get "Dave Jones
([email protected])" in the address line, instead of just the
nickname. I have always entered contact information in the "Display as:"
field with the nickname only. I do not want people's e-mail addresses to be
listed in the address field.

I can occasionally force Outlook to use the nickname only, if I delete the
contact and then make a new contact with the same information. Once I send
a new e-mail message to that recipient, the next message using autocomplete
typically shows the nickname only. However, that fix doesn't hold for long,
and the e-mail address starts popping up in autocomplete selections again.

I browsed to the Nickname and AutoComplete cache and renamed it from
Outlook.NK2 to Outlook.old. That did rebuild the cache; but, the
autocomplete problem returned. Can you provide a fix for this issue? If
not, can you provide a better description of it, so I can search for
solutions on the Internet?

Jim
 
Ad

Advertisements

D

Diane Poremsky [MVP]

It's not a problem that needs to be fixed. The nickname cache has the
display name and address of people you've sent to. When you reply to a
message the address on the message is added to the autocomplete cache. One
option is to disable suggest names and only use autoresolve so it only uses
display names in your contacts. But even so, when you hit reply, you'll
likely see both the name and address from the original email, not the
display name from your contacts folder.

Why don't you want the addresses shown? What you see in outlook as you
compose may not be what the recipient sees in their mail client.


--
Diane Poremsky [MVP - Outlook]

Outlook & Exchange Solutions Center: http://www.slipstick.com/

Outlook Tips by email:
mailto:[email protected]

EMO - a weekly newsletter about Outlook and Exchange:
mailto:[email protected]

Poll: What version of Outlook do you use?
http://forums.slipstick.com/showthread.php?t=27072
 
J

Jim

Diane, thanks for your reply. However,if I send a message to many
recipients by selecting from the To: drop-down list, they show as "Dave
Jones, Jim Jones, John Smith, Allen Roberts ...". If I use autocomplete to
select them, they show as "Dave Jones ([email protected]), Jim Jones
([email protected]), John Smith ([email protected]), Allen Roberts
([email protected])". That just takes up more room, and looks a
mess. If they show the way I prefer after selecting from the drop-down
list, why can't I force that view with autocomplete? By the way, if I
disable "suggest names" from the Advanced features, there's no autocomplete
suggestions available. That's not an option.

Jim

Diane Poremsky said:
It's not a problem that needs to be fixed. The nickname cache has the
display name and address of people you've sent to. When you reply to a
message the address on the message is added to the autocomplete cache.
One option is to disable suggest names and only use autoresolve so it only
uses display names in your contacts. But even so, when you hit reply,
you'll likely see both the name and address from the original email, not
the display name from your contacts folder.

Why don't you want the addresses shown? What you see in outlook as you
compose may not be what the recipient sees in their mail client.


--
Diane Poremsky [MVP - Outlook]

Outlook & Exchange Solutions Center: http://www.slipstick.com/

Outlook Tips by email:
mailto:[email protected]

EMO - a weekly newsletter about Outlook and Exchange:
mailto:[email protected]

Poll: What version of Outlook do you use?
http://forums.slipstick.com/showthread.php?t=27072


Jim said:
I have Outlook 2003 and Windows XP. When I type part of an address into
a new message, I get a selection of autocompleted nicknames as I type.
If I select from that list, I sometimes get the nickname + e-mail
address. For example, if I address a message to Dave Jones, I get "Dave
Jones ([email protected])" in the address line, instead of just
the nickname. I have always entered contact information in the "Display
as:" field with the nickname only. I do not want people's e-mail
addresses to be listed in the address field.

I can occasionally force Outlook to use the nickname only, if I delete
the contact and then make a new contact with the same information. Once
I send a new e-mail message to that recipient, the next message using
autocomplete typically shows the nickname only. However, that fix
doesn't hold for long, and the e-mail address starts popping up in
autocomplete selections again.

I browsed to the Nickname and AutoComplete cache and renamed it from
Outlook.NK2 to Outlook.old. That did rebuild the cache; but, the
autocomplete problem returned. Can you provide a fix for this issue? If
not, can you provide a better description of it, so I can search for
solutions on the Internet?

Jim
 
D

Diane Poremsky [MVP]

The difference is that you are getting the names from two different lists -
the To button uses Contacts (and other physical address lists in your
profile), autocomplete uses only the nickname cache. If the name does not
exist in the cache, then outlook autoresolves to the contacts.

Autocomplete includes the name (when available) and address so you can more
easily identify the entry you are selecting from the cache is, in fact, the
one you want to use. If you have 2 entries for Dave Jones in autocomplete,
you can more easily identify the one you want to use.

--
Diane Poremsky [MVP - Outlook]

Outlook & Exchange Solutions Center: http://www.slipstick.com/

Outlook Tips by email:
mailto:[email protected]

EMO - a weekly newsletter about Outlook and Exchange:
mailto:[email protected]

Poll: What version of Outlook do you use?
http://forums.slipstick.com/showthread.php?t=27072


Jim said:
Diane, thanks for your reply. However,if I send a message to many
recipients by selecting from the To: drop-down list, they show as "Dave
Jones, Jim Jones, John Smith, Allen Roberts ...". If I use autocomplete
to select them, they show as "Dave Jones ([email protected]), Jim Jones
([email protected]), John Smith ([email protected]), Allen Roberts
([email protected])". That just takes up more room, and looks a
mess. If they show the way I prefer after selecting from the drop-down
list, why can't I force that view with autocomplete? By the way, if I
disable "suggest names" from the Advanced features, there's no
autocomplete suggestions available. That's not an option.

Jim

Diane Poremsky said:
It's not a problem that needs to be fixed. The nickname cache has the
display name and address of people you've sent to. When you reply to a
message the address on the message is added to the autocomplete cache.
One option is to disable suggest names and only use autoresolve so it
only uses display names in your contacts. But even so, when you hit
reply, you'll likely see both the name and address from the original
email, not the display name from your contacts folder.

Why don't you want the addresses shown? What you see in outlook as you
compose may not be what the recipient sees in their mail client.


--
Diane Poremsky [MVP - Outlook]

Outlook & Exchange Solutions Center: http://www.slipstick.com/

Outlook Tips by email:
mailto:[email protected]

EMO - a weekly newsletter about Outlook and Exchange:
mailto:[email protected]

Poll: What version of Outlook do you use?
http://forums.slipstick.com/showthread.php?t=27072


Jim said:
I have Outlook 2003 and Windows XP. When I type part of an address into
a new message, I get a selection of autocompleted nicknames as I type.
If I select from that list, I sometimes get the nickname + e-mail
address. For example, if I address a message to Dave Jones, I get "Dave
Jones ([email protected])" in the address line, instead of just
the nickname. I have always entered contact information in the "Display
as:" field with the nickname only. I do not want people's e-mail
addresses to be listed in the address field.

I can occasionally force Outlook to use the nickname only, if I delete
the contact and then make a new contact with the same information. Once
I send a new e-mail message to that recipient, the next message using
autocomplete typically shows the nickname only. However, that fix
doesn't hold for long, and the e-mail address starts popping up in
autocomplete selections again.

I browsed to the Nickname and AutoComplete cache and renamed it from
Outlook.NK2 to Outlook.old. That did rebuild the cache; but, the
autocomplete problem returned. Can you provide a fix for this issue?
If not, can you provide a better description of it, so I can search for
solutions on the Internet?

Jim
 
J

Jim

So is there a way to make it do what I wish?
Jim

Diane Poremsky said:
The difference is that you are getting the names from two different
lists - the To button uses Contacts (and other physical address lists in
your profile), autocomplete uses only the nickname cache. If the name does
not exist in the cache, then outlook autoresolves to the contacts.

Autocomplete includes the name (when available) and address so you can
more easily identify the entry you are selecting from the cache is, in
fact, the one you want to use. If you have 2 entries for Dave Jones in
autocomplete, you can more easily identify the one you want to use.

--
Diane Poremsky [MVP - Outlook]

Outlook & Exchange Solutions Center: http://www.slipstick.com/

Outlook Tips by email:
mailto:[email protected]

EMO - a weekly newsletter about Outlook and Exchange:
mailto:[email protected]

Poll: What version of Outlook do you use?
http://forums.slipstick.com/showthread.php?t=27072


Jim said:
Diane, thanks for your reply. However,if I send a message to many
recipients by selecting from the To: drop-down list, they show as "Dave
Jones, Jim Jones, John Smith, Allen Roberts ...". If I use autocomplete
to select them, they show as "Dave Jones ([email protected]), Jim Jones
([email protected]), John Smith ([email protected]), Allen Roberts
([email protected])". That just takes up more room, and looks
a mess. If they show the way I prefer after selecting from the drop-down
list, why can't I force that view with autocomplete? By the way, if I
disable "suggest names" from the Advanced features, there's no
autocomplete suggestions available. That's not an option.

Jim

Diane Poremsky said:
It's not a problem that needs to be fixed. The nickname cache has the
display name and address of people you've sent to. When you reply to a
message the address on the message is added to the autocomplete cache.
One option is to disable suggest names and only use autoresolve so it
only uses display names in your contacts. But even so, when you hit
reply, you'll likely see both the name and address from the original
email, not the display name from your contacts folder.

Why don't you want the addresses shown? What you see in outlook as you
compose may not be what the recipient sees in their mail client.


--
Diane Poremsky [MVP - Outlook]

Outlook & Exchange Solutions Center: http://www.slipstick.com/

Outlook Tips by email:
mailto:[email protected]

EMO - a weekly newsletter about Outlook and Exchange:
mailto:[email protected]

Poll: What version of Outlook do you use?
http://forums.slipstick.com/showthread.php?t=27072


I have Outlook 2003 and Windows XP. When I type part of an address
into a new message, I get a selection of autocompleted nicknames as I
type. If I select from that list, I sometimes get the nickname + e-mail
address. For example, if I address a message to Dave Jones, I get
"Dave Jones ([email protected])" in the address line, instead of
just the nickname. I have always entered contact information in the
"Display as:" field with the nickname only. I do not want people's
e-mail addresses to be listed in the address field.

I can occasionally force Outlook to use the nickname only, if I delete
the contact and then make a new contact with the same information.
Once I send a new e-mail message to that recipient, the next message
using autocomplete typically shows the nickname only. However, that
fix doesn't hold for long, and the e-mail address starts popping up in
autocomplete selections again.

I browsed to the Nickname and AutoComplete cache and renamed it from
Outlook.NK2 to Outlook.old. That did rebuild the cache; but, the
autocomplete problem returned. Can you provide a fix for this issue?
If not, can you provide a better description of it, so I can search for
solutions on the Internet?

Jim
 
D

Diane Poremsky [MVP]

Sure - stop using the autocomplete cache. If you use the To button always,
it should use the display names you have entered in the contacts.

--
Diane Poremsky [MVP - Outlook]

Outlook & Exchange Solutions Center: http://www.slipstick.com/

Outlook Tips by email:
mailto:[email protected]

EMO - a weekly newsletter about Outlook and Exchange:
mailto:[email protected]

Poll: What version of Outlook do you use?
http://forums.slipstick.com/showthread.php?t=27072


Jim said:
So is there a way to make it do what I wish?
Jim

Diane Poremsky said:
The difference is that you are getting the names from two different
lists - the To button uses Contacts (and other physical address lists in
your profile), autocomplete uses only the nickname cache. If the name
does not exist in the cache, then outlook autoresolves to the contacts.

Autocomplete includes the name (when available) and address so you can
more easily identify the entry you are selecting from the cache is, in
fact, the one you want to use. If you have 2 entries for Dave Jones in
autocomplete, you can more easily identify the one you want to use.

--
Diane Poremsky [MVP - Outlook]

Outlook & Exchange Solutions Center: http://www.slipstick.com/

Outlook Tips by email:
mailto:[email protected]

EMO - a weekly newsletter about Outlook and Exchange:
mailto:[email protected]

Poll: What version of Outlook do you use?
http://forums.slipstick.com/showthread.php?t=27072


Jim said:
Diane, thanks for your reply. However,if I send a message to many
recipients by selecting from the To: drop-down list, they show as "Dave
Jones, Jim Jones, John Smith, Allen Roberts ...". If I use autocomplete
to select them, they show as "Dave Jones ([email protected]), Jim
Jones ([email protected]), John Smith ([email protected]), Allen
Roberts ([email protected])". That just takes up more room,
and looks a mess. If they show the way I prefer after selecting from
the drop-down list, why can't I force that view with autocomplete? By
the way, if I disable "suggest names" from the Advanced features,
there's no autocomplete suggestions available. That's not an option.

Jim

It's not a problem that needs to be fixed. The nickname cache has the
display name and address of people you've sent to. When you reply to a
message the address on the message is added to the autocomplete cache.
One option is to disable suggest names and only use autoresolve so it
only uses display names in your contacts. But even so, when you hit
reply, you'll likely see both the name and address from the original
email, not the display name from your contacts folder.

Why don't you want the addresses shown? What you see in outlook as you
compose may not be what the recipient sees in their mail client.


--
Diane Poremsky [MVP - Outlook]

Outlook & Exchange Solutions Center: http://www.slipstick.com/

Outlook Tips by email:
mailto:[email protected]

EMO - a weekly newsletter about Outlook and Exchange:
mailto:[email protected]

Poll: What version of Outlook do you use?
http://forums.slipstick.com/showthread.php?t=27072


I have Outlook 2003 and Windows XP. When I type part of an address
into a new message, I get a selection of autocompleted nicknames as I
type. If I select from that list, I sometimes get the nickname +
e-mail address. For example, if I address a message to Dave Jones, I
get "Dave Jones ([email protected])" in the address line,
instead of just the nickname. I have always entered contact
information in the "Display as:" field with the nickname only. I do
not want people's e-mail addresses to be listed in the address field.

I can occasionally force Outlook to use the nickname only, if I delete
the contact and then make a new contact with the same information.
Once I send a new e-mail message to that recipient, the next message
using autocomplete typically shows the nickname only. However, that
fix doesn't hold for long, and the e-mail address starts popping up in
autocomplete selections again.

I browsed to the Nickname and AutoComplete cache and renamed it from
Outlook.NK2 to Outlook.old. That did rebuild the cache; but, the
autocomplete problem returned. Can you provide a fix for this issue?
If not, can you provide a better description of it, so I can search
for solutions on the Internet?

Jim
 
Ad

Advertisements

V

VanguardLH

Jim said:
I have Outlook 2003 and Windows XP. When I type part of an address into a
new message, I get a selection of autocompleted nicknames as I type. If I
select from that list, I sometimes get the nickname + e-mail address. For
example, if I address a message to Dave Jones, I get "Dave Jones
([email protected])" in the address line, instead of just the
nickname. I have always entered contact information in the "Display as:"
field with the nickname only. I do not want people's e-mail addresses to be
listed in the address field.

I can occasionally force Outlook to use the nickname only, if I delete the
contact and then make a new contact with the same information. Once I send
a new e-mail message to that recipient, the next message using autocomplete
typically shows the nickname only. However, that fix doesn't hold for long,
and the e-mail address starts popping up in autocomplete selections again.

I browsed to the Nickname and AutoComplete cache and renamed it from
Outlook.NK2 to Outlook.old. That did rebuild the cache; but, the
autocomplete problem returned. Can you provide a fix for this issue? If
not, can you provide a better description of it, so I can search for
solutions on the Internet?

Jim

Why do you care how the To/Cc/Bcc fields look like regarding whether just a
name or name+address is shown? You don't get to dictate how it will appear
at the recipient's end, anyway. That YOU see just the name doesn't dictate
that the recipient will also see only the name. The recipient may still see
name+address in the To/Cc field shown in THEIR e-mail client.
 
R

Russ Valentine

She never said there was no way to do what you wish, just that there was no
reason. What did you think this would achieve? You may be confused about
something here.
--
Russ Valentine
Jim said:
So is there a way to make it do what I wish?
Jim

Diane Poremsky said:
The difference is that you are getting the names from two different
lists - the To button uses Contacts (and other physical address lists in
your profile), autocomplete uses only the nickname cache. If the name
does not exist in the cache, then outlook autoresolves to the contacts.

Autocomplete includes the name (when available) and address so you can
more easily identify the entry you are selecting from the cache is, in
fact, the one you want to use. If you have 2 entries for Dave Jones in
autocomplete, you can more easily identify the one you want to use.

--
Diane Poremsky [MVP - Outlook]

Outlook & Exchange Solutions Center: http://www.slipstick.com/

Outlook Tips by email:
mailto:[email protected]

EMO - a weekly newsletter about Outlook and Exchange:
mailto:[email protected]

Poll: What version of Outlook do you use?
http://forums.slipstick.com/showthread.php?t=27072


Jim said:
Diane, thanks for your reply. However,if I send a message to many
recipients by selecting from the To: drop-down list, they show as "Dave
Jones, Jim Jones, John Smith, Allen Roberts ...". If I use autocomplete
to select them, they show as "Dave Jones ([email protected]), Jim
Jones ([email protected]), John Smith ([email protected]), Allen
Roberts ([email protected])". That just takes up more room,
and looks a mess. If they show the way I prefer after selecting from
the drop-down list, why can't I force that view with autocomplete? By
the way, if I disable "suggest names" from the Advanced features,
there's no autocomplete suggestions available. That's not an option.

Jim

It's not a problem that needs to be fixed. The nickname cache has the
display name and address of people you've sent to. When you reply to a
message the address on the message is added to the autocomplete cache.
One option is to disable suggest names and only use autoresolve so it
only uses display names in your contacts. But even so, when you hit
reply, you'll likely see both the name and address from the original
email, not the display name from your contacts folder.

Why don't you want the addresses shown? What you see in outlook as you
compose may not be what the recipient sees in their mail client.


--
Diane Poremsky [MVP - Outlook]

Outlook & Exchange Solutions Center: http://www.slipstick.com/

Outlook Tips by email:
mailto:[email protected]

EMO - a weekly newsletter about Outlook and Exchange:
mailto:[email protected]

Poll: What version of Outlook do you use?
http://forums.slipstick.com/showthread.php?t=27072


I have Outlook 2003 and Windows XP. When I type part of an address
into a new message, I get a selection of autocompleted nicknames as I
type. If I select from that list, I sometimes get the nickname +
e-mail address. For example, if I address a message to Dave Jones, I
get "Dave Jones ([email protected])" in the address line,
instead of just the nickname. I have always entered contact
information in the "Display as:" field with the nickname only. I do
not want people's e-mail addresses to be listed in the address field.

I can occasionally force Outlook to use the nickname only, if I delete
the contact and then make a new contact with the same information.
Once I send a new e-mail message to that recipient, the next message
using autocomplete typically shows the nickname only. However, that
fix doesn't hold for long, and the e-mail address starts popping up in
autocomplete selections again.

I browsed to the Nickname and AutoComplete cache and renamed it from
Outlook.NK2 to Outlook.old. That did rebuild the cache; but, the
autocomplete problem returned. Can you provide a fix for this issue?
If not, can you provide a better description of it, so I can search
for solutions on the Internet?

Jim
 
J

Jim

The address line to multiple recipients is cluttered when the e-mail address
is included. I am sure it is possible to show only names, and not names +
addresses, since some of my autocomplete addresses are in the names-only
format. And all of my addresses show as names-only in Windows Live Mail.
Why are you so sure that this feature is desirable? It's possible that I
haven't described what's happening in suitable detail. But if I knew
exactly how to explain it, I could probably search for the solution myself -
sigh. I guess I'll have to post to the Windows Live group, or some other
resource.

Thanks for your comments,
Jim

Russ Valentine said:
She never said there was no way to do what you wish, just that there was
no reason. What did you think this would achieve? You may be confused
about something here.
--
Russ Valentine
Jim said:
So is there a way to make it do what I wish?
Jim

Diane Poremsky said:
The difference is that you are getting the names from two different
lists - the To button uses Contacts (and other physical address lists in
your profile), autocomplete uses only the nickname cache. If the name
does not exist in the cache, then outlook autoresolves to the contacts.

Autocomplete includes the name (when available) and address so you can
more easily identify the entry you are selecting from the cache is, in
fact, the one you want to use. If you have 2 entries for Dave Jones in
autocomplete, you can more easily identify the one you want to use.

--
Diane Poremsky [MVP - Outlook]

Outlook & Exchange Solutions Center: http://www.slipstick.com/

Outlook Tips by email:
mailto:[email protected]

EMO - a weekly newsletter about Outlook and Exchange:
mailto:[email protected]

Poll: What version of Outlook do you use?
http://forums.slipstick.com/showthread.php?t=27072


Diane, thanks for your reply. However,if I send a message to many
recipients by selecting from the To: drop-down list, they show as "Dave
Jones, Jim Jones, John Smith, Allen Roberts ...". If I use
autocomplete to select them, they show as "Dave Jones
([email protected]), Jim Jones ([email protected]), John Smith
([email protected]), Allen Roberts ([email protected])".
That just takes up more room, and looks a mess. If they show the way I
prefer after selecting from the drop-down list, why can't I force that
view with autocomplete? By the way, if I disable "suggest names" from
the Advanced features, there's no autocomplete suggestions available.
That's not an option.

Jim

It's not a problem that needs to be fixed. The nickname cache has the
display name and address of people you've sent to. When you reply to a
message the address on the message is added to the autocomplete cache.
One option is to disable suggest names and only use autoresolve so it
only uses display names in your contacts. But even so, when you hit
reply, you'll likely see both the name and address from the original
email, not the display name from your contacts folder.

Why don't you want the addresses shown? What you see in outlook as you
compose may not be what the recipient sees in their mail client.


--
Diane Poremsky [MVP - Outlook]

Outlook & Exchange Solutions Center: http://www.slipstick.com/

Outlook Tips by email:
mailto:[email protected]

EMO - a weekly newsletter about Outlook and Exchange:
mailto:[email protected]

Poll: What version of Outlook do you use?
http://forums.slipstick.com/showthread.php?t=27072


I have Outlook 2003 and Windows XP. When I type part of an address
into a new message, I get a selection of autocompleted nicknames as I
type. If I select from that list, I sometimes get the nickname +
e-mail address. For example, if I address a message to Dave Jones, I
get "Dave Jones ([email protected])" in the address line,
instead of just the nickname. I have always entered contact
information in the "Display as:" field with the nickname only. I do
not want people's e-mail addresses to be listed in the address field.

I can occasionally force Outlook to use the nickname only, if I
delete the contact and then make a new contact with the same
information. Once I send a new e-mail message to that recipient, the
next message using autocomplete typically shows the nickname only.
However, that fix doesn't hold for long, and the e-mail address
starts popping up in autocomplete selections again.

I browsed to the Nickname and AutoComplete cache and renamed it from
Outlook.NK2 to Outlook.old. That did rebuild the cache; but, the
autocomplete problem returned. Can you provide a fix for this issue?
If not, can you provide a better description of it, so I can search
for solutions on the Internet?

Jim
 
D

Diane Poremsky [MVP]

I'm pretty sure he knows what you mean - but that doesn't change the fact
that the only way to avoid it is to use the To button and get the names from
the address book.

The reason for the autocomplete list working like this is so you can see
what address the message is being sent to. That was a big complaint for
years (before the autocomplete list existed) - people had no idea what the
underlying address was and they needed to take several additional steps to
see the actual address.

Yes, it makes it cluttered, but at least you can see the address and can't
blame outlook if you send it to the wrong Dave Jones. As for Mail or Outlook
Express working differently - they are totally different programs written by
different groups, intended for different audiences. Businesses might have
10 Dave Jones in their contacts or autocomplete and seeing the addresses is
more important.


--
Diane Poremsky [MVP - Outlook]

Outlook & Exchange Solutions Center: http://www.slipstick.com/

Outlook Tips by email:
mailto:[email protected]

EMO - a weekly newsletter about Outlook and Exchange:
mailto:[email protected]

Poll: What version of Outlook do you use?
http://forums.slipstick.com/showthread.php?t=27072


Jim said:
The address line to multiple recipients is cluttered when the e-mail
address is included. I am sure it is possible to show only names, and not
names + addresses, since some of my autocomplete addresses are in the
names-only format. And all of my addresses show as names-only in Windows
Live Mail. Why are you so sure that this feature is desirable? It's
possible that I haven't described what's happening in suitable detail.
But if I knew exactly how to explain it, I could probably search for the
solution myself - sigh. I guess I'll have to post to the Windows Live
group, or some other resource.

Thanks for your comments,
Jim

Russ Valentine said:
She never said there was no way to do what you wish, just that there was
no reason. What did you think this would achieve? You may be confused
about something here.
--
Russ Valentine
Jim said:
So is there a way to make it do what I wish?
Jim

The difference is that you are getting the names from two different
lists - the To button uses Contacts (and other physical address lists
in your profile), autocomplete uses only the nickname cache. If the
name does not exist in the cache, then outlook autoresolves to the
contacts.

Autocomplete includes the name (when available) and address so you can
more easily identify the entry you are selecting from the cache is, in
fact, the one you want to use. If you have 2 entries for Dave Jones in
autocomplete, you can more easily identify the one you want to use.

--
Diane Poremsky [MVP - Outlook]

Outlook & Exchange Solutions Center: http://www.slipstick.com/

Outlook Tips by email:
mailto:[email protected]

EMO - a weekly newsletter about Outlook and Exchange:
mailto:[email protected]

Poll: What version of Outlook do you use?
http://forums.slipstick.com/showthread.php?t=27072


Diane, thanks for your reply. However,if I send a message to many
recipients by selecting from the To: drop-down list, they show as
"Dave Jones, Jim Jones, John Smith, Allen Roberts ...". If I use
autocomplete to select them, they show as "Dave Jones
([email protected]), Jim Jones ([email protected]), John Smith
([email protected]), Allen Roberts ([email protected])".
That just takes up more room, and looks a mess. If they show the way
I prefer after selecting from the drop-down list, why can't I force
that view with autocomplete? By the way, if I disable "suggest names"
from the Advanced features, there's no autocomplete suggestions
available. That's not an option.

Jim

It's not a problem that needs to be fixed. The nickname cache has the
display name and address of people you've sent to. When you reply to
a message the address on the message is added to the autocomplete
cache. One option is to disable suggest names and only use
autoresolve so it only uses display names in your contacts. But even
so, when you hit reply, you'll likely see both the name and address
from the original email, not the display name from your contacts
folder.

Why don't you want the addresses shown? What you see in outlook as
you compose may not be what the recipient sees in their mail client.


--
Diane Poremsky [MVP - Outlook]

Outlook & Exchange Solutions Center: http://www.slipstick.com/

Outlook Tips by email:
mailto:dailytips-subscribe-requ[email protected]

EMO - a weekly newsletter about Outlook and Exchange:
mailto:[email protected]

Poll: What version of Outlook do you use?
http://forums.slipstick.com/showthread.php?t=27072


I have Outlook 2003 and Windows XP. When I type part of an address
into a new message, I get a selection of autocompleted nicknames as
I type. If I select from that list, I sometimes get the nickname +
e-mail address. For example, if I address a message to Dave Jones,
I get "Dave Jones ([email protected])" in the address line,
instead of just the nickname. I have always entered contact
information in the "Display as:" field with the nickname only. I do
not want people's e-mail addresses to be listed in the address
field.

I can occasionally force Outlook to use the nickname only, if I
delete the contact and then make a new contact with the same
information. Once I send a new e-mail message to that recipient, the
next message using autocomplete typically shows the nickname only.
However, that fix doesn't hold for long, and the e-mail address
starts popping up in autocomplete selections again.

I browsed to the Nickname and AutoComplete cache and renamed it from
Outlook.NK2 to Outlook.old. That did rebuild the cache; but, the
autocomplete problem returned. Can you provide a fix for this
issue? If not, can you provide a better description of it, so I can
search for solutions on the Internet?

Jim
 
D

Diane Poremsky [MVP]

There is no tweak. There are two different address lists in Outlook -
Contacts and the nickname cache.

What you see when you type in letters and names pop up is the nickname
cache. It uses display names and addresses and there is not a reg hack to
change it. It is a simple list. Rendering it as display names and
underlying addresses within the list is not possible.

When you click the To button, you use the Contacts folder. These entries use
the display name as entered in the contact. There is a lot of code behind
contacts and outlook can use display names with underlying addresses.

--
Diane Poremsky [MVP - Outlook]

Outlook & Exchange Solutions Center: http://www.slipstick.com/

Outlook Tips by email:
mailto:[email protected]

EMO - a weekly newsletter about Outlook and Exchange:
mailto:[email protected]

Poll: What version of Outlook do you use?
http://forums.slipstick.com/showthread.php?t=27072


Jim said:
I'm sure you think I'm a bit thick. However, if Outlook sometimes lets me
have names-only in the To: field, then there must be a way to achieve that
result every time. I also don't understand your comments about preventing
confusion. As you can see from the snip below, when I type a "b" into the
address line, it shows all of the options for people named Bill. When I
select one from that list, there's no chance that my mail will be
misaddressed. I appreciate the time you spent on explanations, but guess
I'll see if there's a registry tweak available.


Jim


Diane Poremsky said:
I'm pretty sure he knows what you mean - but that doesn't change the fact
that the only way to avoid it is to use the To button and get the names
from
the address book.

The reason for the autocomplete list working like this is so you can see
what address the message is being sent to. That was a big complaint for
years (before the autocomplete list existed) - people had no idea what
the
underlying address was and they needed to take several additional steps
to
see the actual address.

Yes, it makes it cluttered, but at least you can see the address and
can't
blame outlook if you send it to the wrong Dave Jones. As for Mail or
Outlook
Express working differently - they are totally different programs written
by
different groups, intended for different audiences. Businesses might
have
10 Dave Jones in their contacts or autocomplete and seeing the addresses
is
more important.


--
Diane Poremsky [MVP - Outlook]

Outlook & Exchange Solutions Center: http://www.slipstick.com/

Outlook Tips by email:
mailto:[email protected]

EMO - a weekly newsletter about Outlook and Exchange:
mailto:[email protected]

Poll: What version of Outlook do you use?
http://forums.slipstick.com/showthread.php?t=27072


Jim said:
The address line to multiple recipients is cluttered when the e-mail
address is included. I am sure it is possible to show only names, and
not
names + addresses, since some of my autocomplete addresses are in the
names-only format. And all of my addresses show as names-only in
Windows
Live Mail. Why are you so sure that this feature is desirable? It's
possible that I haven't described what's happening in suitable detail.
But if I knew exactly how to explain it, I could probably search for the
solution myself - sigh. I guess I'll have to post to the Windows Live
group, or some other resource.

Thanks for your comments,
Jim

She never said there was no way to do what you wish, just that there
was
no reason. What did you think this would achieve? You may be confused
about something here.
--
Russ Valentine
So is there a way to make it do what I wish?
Jim

The difference is that you are getting the names from two different
lists - the To button uses Contacts (and other physical address lists
in your profile), autocomplete uses only the nickname cache. If the
name does not exist in the cache, then outlook autoresolves to the
contacts.

Autocomplete includes the name (when available) and address so you
can
more easily identify the entry you are selecting from the cache is,
in
fact, the one you want to use. If you have 2 entries for Dave Jones
in
autocomplete, you can more easily identify the one you want to use.

--
Diane Poremsky [MVP - Outlook]

Outlook & Exchange Solutions Center: http://www.slipstick.com/

Outlook Tips by email:
mailto:[email protected]

EMO - a weekly newsletter about Outlook and Exchange:
mailto:[email protected]

Poll: What version of Outlook do you use?
http://forums.slipstick.com/showthread.php?t=27072


Diane, thanks for your reply. However,if I send a message to many
recipients by selecting from the To: drop-down list, they show as
"Dave Jones, Jim Jones, John Smith, Allen Roberts ...". If I use
autocomplete to select them, they show as "Dave Jones
([email protected]), Jim Jones ([email protected]), John Smith
([email protected]), Allen Roberts
([email protected])".
That just takes up more room, and looks a mess. If they show the
way
I prefer after selecting from the drop-down list, why can't I force
that view with autocomplete? By the way, if I disable "suggest
names"
from the Advanced features, there's no autocomplete suggestions
available. That's not an option.

Jim

It's not a problem that needs to be fixed. The nickname cache has
the
display name and address of people you've sent to. When you reply
to
a message the address on the message is added to the autocomplete
cache. One option is to disable suggest names and only use
autoresolve so it only uses display names in your contacts. But
even
so, when you hit reply, you'll likely see both the name and address
from the original email, not the display name from your contacts
folder.

Why don't you want the addresses shown? What you see in outlook as
you compose may not be what the recipient sees in their mail
client.


--
Diane Poremsky [MVP - Outlook]

Outlook & Exchange Solutions Center: http://www.slipstick.com/

Outlook Tips by email:
mailto:[email protected]

EMO - a weekly newsletter about Outlook and Exchange:
mailto:[email protected]

Poll: What version of Outlook do you use?
http://forums.slipstick.com/showthread.php?t=27072


I have Outlook 2003 and Windows XP. When I type part of an
address
into a new message, I get a selection of autocompleted nicknames
as
I type. If I select from that list, I sometimes get the nickname +
e-mail address. For example, if I address a message to Dave
Jones,
I get "Dave Jones ([email protected])" in the address line,
instead of just the nickname. I have always entered contact
information in the "Display as:" field with the nickname only. I
do
not want people's e-mail addresses to be listed in the address
field.

I can occasionally force Outlook to use the nickname only, if I
delete the contact and then make a new contact with the same
information. Once I send a new e-mail message to that recipient,
the
next message using autocomplete typically shows the nickname only.
However, that fix doesn't hold for long, and the e-mail address
starts popping up in autocomplete selections again.

I browsed to the Nickname and AutoComplete cache and renamed it
from
Outlook.NK2 to Outlook.old. That did rebuild the cache; but, the
autocomplete problem returned. Can you provide a fix for this
issue? If not, can you provide a better description of it, so I
can
search for solutions on the Internet?

Jim
 
Ad

Advertisements

B

Brian Tillman [MVP - Outlook]

The address line to multiple recipients is cluttered when the e-mail address
is included. I am sure it is possible to show only names, and not names +
addresses, since some of my autocomplete addresses are in the names-only
format.

That's because the autocompletion cache will contain whatever was entered into
the To field and marked as resolved. If you used an entry whose Display As
did not contain the mail address, then the entry in To won't contain it when
you use it from the autocompletion cache. If you used one that contrained an
e-mail address because, say, you replied to a message where the sender
included his mail address in the display, then the autocompletion cache will
reflect that and it will appear when you choose it from the cache. If you
never want to see the e-mail address, then you'll need to disable the
autocompletion and use only entries from the Contacts folder that don't
contain the address in the Display As. The autocompletion cache contents is
unmodifiable without third party tools and its behavior is unmodifiable,
period.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top