How to set default program to open .jpg files


V

VanguardLH

Ed said:
After the latest Windows security update, Nero PhotoSnap (the previous
default) can't open .jpg files. The Windows viewer can open these files
(using "open with.."), but I can't figure out how to make it the default
when I click on a .jpg file. I've looked in my 970 pp reference book on
Windows XP and asking the Help utility. I clearly don't know how to ask the
right question.

I'd appreciate any advice on:

What went wrong with Nero Photosnap, and

How to make the Windows viewer the default.

Photosnap was the previous default [handler for .jpg files].
Windows viewer cannot open these files [when double-clicked].
So WHICH one do you really want to be the default handler?

Hold Shift key and right-click on a .jpg file. Use the "Open With"
context menu. Choose Program. Browse to the Photosnap executable as
the program to open the file. If Windows viewer is what you want to
use, it should already be in the list of available handlers (under
Choose Program list).

If you want that selection to stick in the Choose Program list then
check the box to remember your selection.
 
Ad

Advertisements

E

Ed in Seattle

After the latest Windows security update, Nero PhotoSnap (the previous
default) can't open .jpg files. The Windows viewer can open these files
(using "open with.."), but I can't figure out how to make it the default
when I click on a .jpg file. I've looked in my 970 pp reference book on
Windows XP and asking the Help utility. I clearly don't know how to ask the
right question.

I'd appreciate any advice on:

What went wrong with Nero Photosnap, and

How to make the Windows viewer the default.

Thanks,

Ed Presson
 
E

Ed in Seattle

VanguardLH said:
Ed said:
After the latest Windows security update, Nero PhotoSnap (the previous
default) can't open .jpg files. The Windows viewer can open these files
(using "open with.."), but I can't figure out how to make it the default
when I click on a .jpg file. I've looked in my 970 pp reference book on
Windows XP and asking the Help utility. I clearly don't know how to ask
the
right question.

I'd appreciate any advice on:

What went wrong with Nero Photosnap, and

How to make the Windows viewer the default.

Photosnap was the previous default [handler for .jpg files].
Windows viewer cannot open these files [when double-clicked].
So WHICH one do you really want to be the default handler?

Hold Shift key and right-click on a .jpg file. Use the "Open With"
context menu. Choose Program. Browse to the Photosnap executable as
the program to open the file. If Windows viewer is what you want to
use, it should already be in the list of available handlers (under
Choose Program list).

If you want that selection to stick in the Choose Program list then
check the box to remember your selection.

Sorry I was not clear on WHICH program I wanted to use. I would slightly
prefer the Nero PhotoSnap viewer; but it refused to work after I browsed and
selected the photosnapviewer.exe.

I then followed your directions to set the Windows viewer as the default
viewer. Thanks for the help.

I am curious: what purpose is served holding down the shift key when I
right click on a JPEG file? I did not notice any difference between that
and just right-clicking on the file.

I now have a working solution; thanks again for your help.

Ed Presson
 
V

VanguardLH

Ed said:
VanguardLH said:
Ed said:
After the latest Windows security update, Nero PhotoSnap (the previous
default) can't open .jpg files. The Windows viewer can open these files
(using "open with.."), but I can't figure out how to make it the default
when I click on a .jpg file. I've looked in my 970 pp reference book on
Windows XP and asking the Help utility. I clearly don't know how to ask
the
right question.

I'd appreciate any advice on:

What went wrong with Nero Photosnap, and

How to make the Windows viewer the default.

Photosnap was the previous default [handler for .jpg files].
Windows viewer cannot open these files [when double-clicked].
So WHICH one do you really want to be the default handler?

Hold Shift key and right-click on a .jpg file. Use the "Open With"
context menu. Choose Program. Browse to the Photosnap executable as
the program to open the file. If Windows viewer is what you want to
use, it should already be in the list of available handlers (under
Choose Program list).

If you want that selection to stick in the Choose Program list then
check the box to remember your selection.

Sorry I was not clear on WHICH program I wanted to use. I would slightly
prefer the Nero PhotoSnap viewer; but it refused to work after I browsed and
selected the photosnapviewer.exe.

I then followed your directions to set the Windows viewer as the default
viewer. Thanks for the help.

I am curious: what purpose is served holding down the shift key when I
right click on a JPEG file? I did not notice any difference between that
and just right-clicking on the file.

I now have a working solution; thanks again for your help.

Ed Presson

Sometimes the Open With context menu isn't there without using Shift.
I'm not sure it is still required under Windows 2K/XP/Vista. It just
may be a holdover habit from my old Windows 9x days.
 
J

ju.c

Here is a reg file to restore Nero Photosnap Viewer settings for jpg and jpeg files:
(It is for Nero 8)

1. Copy below and paste into Notepad.

----------copy inside only----------
REGEDIT4

[HKEY_CLASSES_ROOT\.jpeg]
@="NeroPhotoSnapViewer.Files8.jpeg"
"PerceivedType"="image"
"Content Type"="image/jpeg"
[HKEY_CLASSES_ROOT\.jpeg\OpenWithList]
[HKEY_CLASSES_ROOT\.jpeg\OpenWithList\PhotoSnapViewer.exe]

[HKEY_CLASSES_ROOT\.jpg]
@="NeroPhotoSnapViewer.Files8.jpg"
"PerceivedType"="image"
"Content Type"="image/jpeg"
[HKEY_CLASSES_ROOT\.jpg\OpenWithList]
[HKEY_CLASSES_ROOT\.jpg\OpenWithList\PhotoSnapViewer.exe]

[HKEY_CLASSES_ROOT\NeroPhotoSnapViewer.Files8.jpeg]
@="JPEG Image"
"FriendlyTypeName"="JPEG Image"
[HKEY_CLASSES_ROOT\NeroPhotoSnapViewer.Files8.jpeg\DefaultIcon]
@="C:\\Program Files\\Nero\\Nero8\\Nero PhotoSnap\\PhotoSnapViewer.exe,1"
[HKEY_CLASSES_ROOT\NeroPhotoSnapViewer.Files8.jpeg\shell]
@="open"
[HKEY_CLASSES_ROOT\NeroPhotoSnapViewer.Files8.jpeg\shell\open]
@="&Open"
"FriendlyAppName"="Nero PhotoSnap Viewer"
[HKEY_CLASSES_ROOT\NeroPhotoSnapViewer.Files8.jpeg\shell\open\command]
@=""C:\\Program Files\\Nero\\Nero8\\Nero PhotoSnap\\PhotoSnapViewer.exe\" \"%1\""

[HKEY_CLASSES_ROOT\NeroPhotoSnapViewer.Files8.jpg]
@="JPEG Image"
"FriendlyTypeName"="JPEG Image"
[HKEY_CLASSES_ROOT\NeroPhotoSnapViewer.Files8.jpg\DefaultIcon]
@="C:\\Program Files\\Nero\\Nero8\\Nero PhotoSnap\\PhotoSnapViewer.exe,1"
[HKEY_CLASSES_ROOT\NeroPhotoSnapViewer.Files8.jpg\shell]
@="open"
[HKEY_CLASSES_ROOT\NeroPhotoSnapViewer.Files8.jpg\shell\open]
@="&Open"
"FriendlyAppName"="Nero PhotoSnap Viewer"
[HKEY_CLASSES_ROOT\NeroPhotoSnapViewer.Files8.jpg\shell\open\command]
@=""C:\\Program Files\\Nero\\Nero8\\Nero PhotoSnap\\PhotoSnapViewer.exe\" \"%1\""

----------copy inside only----------

2. Save-as Nero_JPG.reg (or any name + .reg)

3. Double-click or right-click and merge into the registry.


ju.c
 
Ad

Advertisements

L

Lim

Hi,

May I know how to configure the registry so all the users connecting to a
Terminal server will use the IE6 as the default program to view .jpg files?

Thanks in advance.

Regards,
Lim

ju.c said:
Here is a reg file to restore Nero Photosnap Viewer settings for jpg and jpeg files:
(It is for Nero 8)

1. Copy below and paste into Notepad.

----------copy inside only----------
REGEDIT4

[HKEY_CLASSES_ROOT\.jpeg]
@="NeroPhotoSnapViewer.Files8.jpeg"
"PerceivedType"="image"
"Content Type"="image/jpeg"
[HKEY_CLASSES_ROOT\.jpeg\OpenWithList]
[HKEY_CLASSES_ROOT\.jpeg\OpenWithList\PhotoSnapViewer.exe]

[HKEY_CLASSES_ROOT\.jpg]
@="NeroPhotoSnapViewer.Files8.jpg"
"PerceivedType"="image"
"Content Type"="image/jpeg"
[HKEY_CLASSES_ROOT\.jpg\OpenWithList]
[HKEY_CLASSES_ROOT\.jpg\OpenWithList\PhotoSnapViewer.exe]

[HKEY_CLASSES_ROOT\NeroPhotoSnapViewer.Files8.jpeg]
@="JPEG Image"
"FriendlyTypeName"="JPEG Image"
[HKEY_CLASSES_ROOT\NeroPhotoSnapViewer.Files8.jpeg\DefaultIcon]
@="C:\\Program Files\\Nero\\Nero8\\Nero PhotoSnap\\PhotoSnapViewer.exe,1"
[HKEY_CLASSES_ROOT\NeroPhotoSnapViewer.Files8.jpeg\shell]
@="open"
[HKEY_CLASSES_ROOT\NeroPhotoSnapViewer.Files8.jpeg\shell\open]
@="&Open"
"FriendlyAppName"="Nero PhotoSnap Viewer"
[HKEY_CLASSES_ROOT\NeroPhotoSnapViewer.Files8.jpeg\shell\open\command]
@=""C:\\Program Files\\Nero\\Nero8\\Nero PhotoSnap\\PhotoSnapViewer.exe\" \"%1\""

[HKEY_CLASSES_ROOT\NeroPhotoSnapViewer.Files8.jpg]
@="JPEG Image"
"FriendlyTypeName"="JPEG Image"
[HKEY_CLASSES_ROOT\NeroPhotoSnapViewer.Files8.jpg\DefaultIcon]
@="C:\\Program Files\\Nero\\Nero8\\Nero PhotoSnap\\PhotoSnapViewer.exe,1"
[HKEY_CLASSES_ROOT\NeroPhotoSnapViewer.Files8.jpg\shell]
@="open"
[HKEY_CLASSES_ROOT\NeroPhotoSnapViewer.Files8.jpg\shell\open]
@="&Open"
"FriendlyAppName"="Nero PhotoSnap Viewer"
[HKEY_CLASSES_ROOT\NeroPhotoSnapViewer.Files8.jpg\shell\open\command]
@=""C:\\Program Files\\Nero\\Nero8\\Nero PhotoSnap\\PhotoSnapViewer.exe\" \"%1\""

----------copy inside only----------

2. Save-as Nero_JPG.reg (or any name + .reg)

3. Double-click or right-click and merge into the registry.


ju.c


Ed in Seattle said:
After the latest Windows security update, Nero PhotoSnap (the previous
default) can't open .jpg files. The Windows viewer can open these files
(using "open with.."), but I can't figure out how to make it the default
when I click on a .jpg file. I've looked in my 970 pp reference book on
Windows XP and asking the Help utility. I clearly don't know how to ask the
right question.

I'd appreciate any advice on:

What went wrong with Nero Photosnap, and

How to make the Windows viewer the default.

Thanks,

Ed Presson
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top