How to Prevent 1 Nic from registering in DNS


G

Guest

Hi,
I have a server with dual NIC cards installed each with a unique IP address.
The second NIC is used for ftp access to the server only and I do not want
it to register in DNS. I removed the checkbox but a few hours later it
registered itself in DNS again. Is there another way to prevent it from
registering in DNS? The server is Windows 2003 and the domain is Windows
2000.

Thanks
 
Ad

Advertisements

H

Herb Martin

Steve Halvorson said:
Hi,
I have a server with dual NIC cards installed each with a unique IP
address.
The second NIC is used for ftp access to the server only and I do not want
it to register in DNS. I removed the checkbox but a few hours later it
registered itself in DNS again. Is there another way to prevent it from
registering in DNS? The server is Windows 2003 and the domain is Windows
2000.

Are both of these NICs on the same "subnet/segment"?

That generally doesn't work real well for Windows machines
and seldom provides much of the hoped for benefits.

If so, what is the purpose of the second NIC?

If you really wish to avail yourself of two NICs they should
either be on separate subnet/segments (technically: broadcast
domains) OR they should be "teamed" with special teaming
NIC drivers you obtain with special NICs for that purpose.

Teaming NICs function as one "virtual or teamed NIC" to the
OS.
 
J

Jason Tan

Dear Steve,

Thanks for posting!

To disable DNS updates for a particular interface, follow these steps:

1. Click Start, click Run, type regedit, and then click OK.
2. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\
Tcpip\Parameters\Interfaces\deviceID

Note deviceID is the device ID of the network adaptor for the interface.
3. On the Edit menu, point to New, and then click DWORD Value.
4. Type DisableDynamicUpdate, and then press ENTER two times.
5. In the Edit DWORD Value dialog box, type 1 in the Value data box, and
then click OK.
6. Quit Registry Editor.

For more detailed information please refer to the following article:

246804 How to enable or disable DNS updates in Windows 2000 and in Windows
Server 2003
http://support.microsoft.com/default.aspx?scid=kb;EN-US;246804

Hope the information helps.

Best Regards,

Jason Tan

Microsoft Online Partner Support
Get Secure! - www.microsoft.com/security

=====================================================

When responding to posts, please "Reply to Group" via your newsreader so
that others may learn and benefit from your issue.

=====================================================
This posting is provided "AS IS" with no warranties, and confers no rights.




--------------------
| Thread-Topic: How to Prevent 1 Nic from registering in DNS
| thread-index: AcYYl5oNXUK/P62vTiSLntIYAgKXyQ==
| X-WBNR-Posting-Host: 65.121.14.151
| From: =?Utf-8?B?U3RldmUgSGFsdm9yc29u?= <[email protected]>
| Subject: How to Prevent 1 Nic from registering in DNS
| Date: Fri, 13 Jan 2006 15:18:03 -0800
| Lines: 12
| Message-ID: <[email protected]>
| MIME-Version: 1.0
| Content-Type: text/plain;
| charset="Utf-8"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: Microsoft CDO for Windows 2000
| Content-Class: urn:content-classes:message
| Importance: normal
| Priority: normal
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| Newsgroups: microsoft.public.win2000.dns
| NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFTNGXA03.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl microsoft.public.win2000.dns:51967
| X-Tomcat-NG: microsoft.public.win2000.dns
|
| Hi,
| I have a server with dual NIC cards installed each with a unique IP
address.
| The second NIC is used for ftp access to the server only and I do not
want
| it to register in DNS. I removed the checkbox but a few hours later it
| registered itself in DNS again. Is there another way to prevent it from
| registering in DNS? The server is Windows 2003 and the domain is Windows
| 2000.
|
| Thanks
| --
| Steve Halvorson
| Preferred Credit, Inc
|
 
G

Guest

Thanks for the post Herb. This is a special case. I need the nic to direct
ftp traffic destined for our web hosting company directly to the firewall
around our content filtering solution. Unfortunately, the content filter
slows the ftp traffic enough to cause problems - even if ftp scanning is
turned off. I also do not want to post this server in the dmz. Therefore
this nic has the default gateway configured on it direct to the firewall.
The other nic has no default gateway, but services only internal traffic. So
far this has resolved the problem of slowing the ftp traffic, but created a
new issue in that nic 2 like to register itself in DNS.
--
Steve Halvorson
Preferred Credit, Inc


Herb Martin said:
Steve Halvorson said:
Hi,
I have a server with dual NIC cards installed each with a unique IP
address.
The second NIC is used for ftp access to the server only and I do not want
it to register in DNS. I removed the checkbox but a few hours later it
registered itself in DNS again. Is there another way to prevent it from
registering in DNS? The server is Windows 2003 and the domain is Windows
2000.

Are both of these NICs on the same "subnet/segment"?

That generally doesn't work real well for Windows machines
and seldom provides much of the hoped for benefits.

If so, what is the purpose of the second NIC?

If you really wish to avail yourself of two NICs they should
either be on separate subnet/segments (technically: broadcast
domains) OR they should be "teamed" with special teaming
NIC drivers you obtain with special NICs for that purpose.

Teaming NICs function as one "virtual or teamed NIC" to the
OS.

--
Herb Martin, MCSE, MVP
Accelerated MCSE
http://www.LearnQuick.Com
[phone number on web site]
 
G

Guest

Thanks Jason,

I'll make the change. Out of curiosity... what does the "Register this
connection in DNS" setting do?
 
H

Herb Martin

Steve Halvorson said:
Thanks for the post Herb. This is a special case. I need the nic to
direct
ftp traffic destined for our web hosting company directly to the firewall
around our content filtering solution.

NICs do not "direct traffic" -- your routing table does.
Unfortunately, the content filter
slows the ftp traffic enough to cause problems - even if ftp scanning is
turned off. I also do not want to post this server in the dmz. Therefore
this nic has the default gateway configured on it direct to the firewall.

If you check you will see you only have one ACTIVE 'default
gateway' at a time.

Extra default gateways are NOT used as long as the first is
available.

You could just as easily put multiple default gateway ENTRIES
on a single NIC (and multiple IPs too) with the same (ineffective)
result.
The other nic has no default gateway, but services only internal traffic.
So
far this has resolved the problem of slowing the ftp traffic, but created
a
new issue in that nic 2 like to register itself in DNS.

Having two NICs here does not help -- you would get
the same results with a single NIC and similar configuration.
 
Ad

Advertisements

G

Guest

In general you are correct except that we have a special topology that allows
me to get away with this. We have dual firewall connected to 2 different ISP
T1s. On the internal side these redundant firewalls are connected to a hub
so that requests going to the firewalls are loadbalanced across the
firewalls. The content filter is not the default gateway, but instead sits
between the network switch and the hub connected to the firewalls. I simply
deleted the default gateway from nic 1. Nic 2 connects directly to the hub
thereby bypassing the content filter and uses the Virtual adapter of the
loadbalanced firewalls. It really doesn't matter if both nic cards use the
default gateway as long as traffic comming into nic 2 leaves by way of nic 2
direct to the hub - which it appears to be doing. I could have reworked the
firewalls to put nic 2 on a different subnet and connected to the DMZ port,
but these files are time sensative so I was looking for a quick way to get
the content filter out of the way.

I hope that clarifies the situation a bit more. At any rate, modifying the
registry appears to have fixed the issue.
--
Steve Halvorson
Preferred Credit, Inc


Herb Martin said:
Steve Halvorson said:
Thanks for the post Herb. This is a special case. I need the nic to
direct
ftp traffic destined for our web hosting company directly to the firewall
around our content filtering solution.

NICs do not "direct traffic" -- your routing table does.
Unfortunately, the content filter
slows the ftp traffic enough to cause problems - even if ftp scanning is
turned off. I also do not want to post this server in the dmz. Therefore
this nic has the default gateway configured on it direct to the firewall.

If you check you will see you only have one ACTIVE 'default
gateway' at a time.

Extra default gateways are NOT used as long as the first is
available.

You could just as easily put multiple default gateway ENTRIES
on a single NIC (and multiple IPs too) with the same (ineffective)
result.
The other nic has no default gateway, but services only internal traffic.
So
far this has resolved the problem of slowing the ftp traffic, but created
a
new issue in that nic 2 like to register itself in DNS.

Having two NICs here does not help -- you would get
the same results with a single NIC and similar configuration.

--
Herb Martin, MCSE, MVP
Accelerated MCSE
http://www.LearnQuick.Com
[phone number on web site]
 
Ad

Advertisements

J

Jason Tan

Hi Steve,

I am glad to hear that the problem has been fixed. If you have any other
questions or concerns, please do not hesitate to contact us. It is always
our pleasure to be of assistance.

Have a nice day!

Best Regards,

Jason Tan

Microsoft Online Partner Support
Get Secure! - www.microsoft.com/security

=====================================================

When responding to posts, please "Reply to Group" via your newsreader so
that others may learn and benefit from your issue.

=====================================================
This posting is provided "AS IS" with no warranties, and confers no rights.



--------------------
| Thread-Topic: How to Prevent 1 Nic from registering in DNS
| thread-index: AcYa7qJMr8a2kPIhRsWKZ5k2NQR2zw==
| X-WBNR-Posting-Host: 63.79.36.233
| From: =?Utf-8?B?U3RldmUgSGFsdm9yc29u?= <[email protected]>
| References: <[email protected]>
<8#[email protected]>
| Subject: RE: How to Prevent 1 Nic from registering in DNS
| Date: Mon, 16 Jan 2006 14:46:05 -0800
| Lines: 93
| Message-ID: <[email protected]>
| MIME-Version: 1.0
| Content-Type: text/plain;
| charset="Utf-8"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: Microsoft CDO for Windows 2000
| Content-Class: urn:content-classes:message
| Importance: normal
| Priority: normal
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| Newsgroups: microsoft.public.win2000.dns
| NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGXA03.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl microsoft.public.win2000.dns:51980
| X-Tomcat-NG: microsoft.public.win2000.dns
|
| Fixed - Thanks
| --
| Steve Halvorson
| Preferred Credit, Inc
|
|
| "Jason Tan (MSFT)" wrote:
|
| > Dear Steve,
| >
| > Thanks for posting!
| >
| > To disable DNS updates for a particular interface, follow these steps:
| >
| > 1. Click Start, click Run, type regedit, and then click OK.
| > 2. Locate and then click the following registry subkey:
| > HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\
| > Tcpip\Parameters\Interfaces\deviceID
| >
| > Note deviceID is the device ID of the network adaptor for the
interface.
| > 3. On the Edit menu, point to New, and then click DWORD Value.
| > 4. Type DisableDynamicUpdate, and then press ENTER two times.
| > 5. In the Edit DWORD Value dialog box, type 1 in the Value data box,
and
| > then click OK.
| > 6. Quit Registry Editor.
| >
| > For more detailed information please refer to the following article:
| >
| > 246804 How to enable or disable DNS updates in Windows 2000 and in
Windows
| > Server 2003
| > http://support.microsoft.com/default.aspx?scid=kb;EN-US;246804
| >
| > Hope the information helps.
| >
| > Best Regards,
| >
| > Jason Tan
| >
| > Microsoft Online Partner Support
| > Get Secure! - www.microsoft.com/security
| >
| > =====================================================
| >
| > When responding to posts, please "Reply to Group" via your newsreader
so
| > that others may learn and benefit from your issue.
| >
| > =====================================================
| > This posting is provided "AS IS" with no warranties, and confers no
rights.
| >
| >
| >
| >
| > --------------------
| > | Thread-Topic: How to Prevent 1 Nic from registering in DNS
| > | thread-index: AcYYl5oNXUK/P62vTiSLntIYAgKXyQ==
| > | X-WBNR-Posting-Host: 65.121.14.151
| > | From: =?Utf-8?B?U3RldmUgSGFsdm9yc29u?= <[email protected]>
| > | Subject: How to Prevent 1 Nic from registering in DNS
| > | Date: Fri, 13 Jan 2006 15:18:03 -0800
| > | Lines: 12
| > | Message-ID: <[email protected]>
| > | MIME-Version: 1.0
| > | Content-Type: text/plain;
| > | charset="Utf-8"
| > | Content-Transfer-Encoding: 7bit
| > | X-Newsreader: Microsoft CDO for Windows 2000
| > | Content-Class: urn:content-classes:message
| > | Importance: normal
| > | Priority: normal
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| > | Newsgroups: microsoft.public.win2000.dns
| > | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| > | Path:
TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFTNGXA03.phx.gbl
| > | Xref: TK2MSFTNGXA02.phx.gbl microsoft.public.win2000.dns:51967
| > | X-Tomcat-NG: microsoft.public.win2000.dns
| > |
| > | Hi,
| > | I have a server with dual NIC cards installed each with a unique IP
| > address.
| > | The second NIC is used for ftp access to the server only and I do
not
| > want
| > | it to register in DNS. I removed the checkbox but a few hours later
it
| > | registered itself in DNS again. Is there another way to prevent it
from
| > | registering in DNS? The server is Windows 2003 and the domain is
Windows
| > | 2000.
| > |
| > | Thanks
| > | --
| > | Steve Halvorson
| > | Preferred Credit, Inc
| > |
| >
| >
|
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top