How to disable Windows Auto Update


Pixels Peter

It seems that every time there is a new update for Windows, my computer
gives me this svchost.exe error and disables a lot of the functions on my
Does anyone know how to disable the auto update or the fix to this error?
The error msg that I am getting is:

svchost.exe - Application Error
The instruction at "0x745f2780" referenced memory at "0x00000000". The
memory could not be "read".
Click on OK to terminate the program
Click on CANCEL to debug the program

When I click OK the computer just freezes and I have to do a cold boot. When
I click CANCEL, some of the functions like sound is gone. Any idea? Thanks.


PA Bear

Best determine and remove the hijackware that's causing the problem.

Checking for/Help with Hijackware

When all else fails, HijackThis v1.99.1
( is the preferred tool to use.
It will help you to both identify and remove any hijackware/spyware. **Post
your log to,,, or other appropriate
forums for expert analysis, not here.**

If the procedures look too complex - and there is no shame in admitting this
isn't your cup of tea - take the machine to a local, reputable and
independent (i.e., not BigBoxStoreUSA) computer repair shop.

Pixels Peter

Thanks for your reply but I am almost 100% sure it is not any spyware or
hijackware. Can you tell me how to disable the auto windows update notice?



Thank you and Merci! The patch definitely seemed to work for me. I also
uninstalled several patches - namely KB917344, KB917953 AND KB914389
(very suspect patch).

Roman S a écrit :

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question