Device Driver: Two Instances, Yellow Exclamation Point


P

petergoode

Though I am not new to PC's and XP, I have an issue for which I could please
use some help, as I don't want to screw up my system.

I am running XP Pro SP3 on a Dell Vostro 220s, and coincidentally noted that
in device manager, under display adapters, I find two instances of Intel
G45/G43 Express Chipset, with yellow exclamation marks before both. Double
clicking leads to the "windows cannot load the device driver for this
hardware. The driver may be corrupted or missing (code 39)" error message.

Everything nevertheless seems to work.

As such, would it be advisable to fix this, or leave it alone? I am not an
expert on video drivers, and am reluctant to uninstall both instances (would
that leave me with a blank screen?), or is that indeed what I am supposed to
do, and then try to reinstall?

Thanks so much for any advice.

Peter
 
Ad

Advertisements

A

Andy Chang

You should reinstall the driver of display adapter, since it doesn't work
correctly. I am afraid you have no choice.
 
P

petergoode

Thanks for taking time to try to help on this.

Not sure exactly what mechanism resulted in resolution of the yellow
warnings, but I uninstalled the driver under one of the two listings,
rebooted...it still shows two listings, but no yellow warnings, and indicates
the device is working properly. I think I will leave it as is, though I am
sure a purist would argue that there should be only one listing for the video
driver.

Peter
 
M

M.I.5¾

Andy Chang said:
You should reinstall the driver of display adapter, since it doesn't work
correctly. I am afraid you have no choice.

You didn't read the post because the OP says clearly that it does work.

Personally, I would leave it alone. I have 6 instances of a failed
bluetooth device in my desktop PC (and no known missing bluetooth devices to
match). Deleting any of them simply prompts a failed attempt to reinstall
at boot time. If it ain't broke don't fix it.
 
Ad

Advertisements

M

M.I.5¾

petergoode said:
Thanks for taking time to try to help on this.

Not sure exactly what mechanism resulted in resolution of the yellow
warnings, but I uninstalled the driver under one of the two listings,
rebooted...it still shows two listings, but no yellow warnings, and
indicates
the device is working properly. I think I will leave it as is, though I
am
sure a purist would argue that there should be only one listing for the
video
driver.

If it is a dual head graphics card, then this can show up as two instances.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top