Configuring My Documents redirection to network drive..........


G

Guest

Hi.........I'm configuring WTS with rootdrv and roaming profile....... how...

Whats the best way to configure the My Documents to save to the network
drive ie. via GPO or something else.......also what should I do abt the
legacy rootdrv as well....

Momo
 
Ad

Advertisements

V

Vera Noest [MVP]

Use a GPO.
User configuration - Windows settings - Folder redirection - My
Documents.
Easiest is to redirect My Documents to the users home folder
 
G

Guest

Vera,

If I do that then how should I do the roaming user profile. I want TS users
to use roaming profile, I've also configured to rootdrv for legacy support.

But when I tried setting the roaming profile in AD Users when the users
logon they end up seeing an "X" network drive icon on the rootdrv and all
they see inside when they look in the rootdrv is x:\windows\system with a few
files inside nothing resembling the rootdrv and profile (by default GPO
disables a:\ b: c:\). But if I look on the remote network drive where the
profile is stored everything is there..........

The setup seems a bit weird.......do I need to do anything with the
rootdrv.cmd ie. edit the file etc............

Thanks in advance........

Zeno
 
G

Guest

What I've done is setup a GPO to redirect My Documents to the users network
homedrive ie. \\as2hkdgap00\users\%username%

In AD Users setup a profile path for roaming profile ie.
\\as2hkdgap00\profiles\NBKIUX8

In AD Users set the users terminal server home drive to
\\as2hkdgap00\users\%username% with drive letter W.

In the Rootdrv2 set the drive letter to W:.

Therefore making the rootdrv letter is the same as the terminal server home
drive.

Is this setup correct? Any advice would be appreciated...........
 
V

Vera Noest [MVP]

No, this is *not* how it should be implemented. You need to use
another letter for the RootDrive. From
195950 - How and why ROOTDRIVE is used on Windows Terminal Server
http://support.microsoft.com/?kbid=195950

<quote>
Any drive letter may be chosen, but it is important that it not be
the drive letter specified in User Manager for either the Home
Directory or Terminal Server Home Directory
</quote>
 
V

Vera Noest [MVP]

already answered in your second thread in this newsgroup.
I think you need to reread the KB 195950 article.

The RootDrive is not something that you can "see", it is just a
variable pointing to %HOMEDRIVE%%HOMEPATH%, i.e. the users home
directory.

Tip: open a command window on your client workstation and within a
TS session, and type "set | more" (without the quotes). Have a
close look at the variables that are defined in the session. This
will soon give you a feeling for what points where.
 
Ad

Advertisements

G

Guest

Vera,

I really appreciate your replies to the questions however I've read KB195950
yet still a bit confused. I haven't had much experience with WTS so I'm
sortof trying this and that to get it to work properly.... sorry :)

I've changed the settings for rootdrv to W:,

I have also set a path in AD for the users roaming profile and another for
Y: network home drive which is different to the rootdrv. I have also setup a
GPO My Documents redirection to y: network home drive.

But when I do this what I ends up happening is:
A. rootdrv w: can be seen wth My Documents and a Windows\system directory,
however there's an "x" with network drive written(W:) (looks like one of
those disconnected network drives)
B. Y: drive network home drive appears however this also shows My Documents
and Windows\system

If I'm setting everything correctly how come the rootdrv w: appears like
this and whats the purpose of he windows\system directory........

Am I doing something wrong...........if this is not the case can you please
advise whats the proper setting do I need to make some changes to the
usrlogon.cmd file or something else............


Many many many thanks

Zeno
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top