Can't install .NET Framework 3.5 (error 1603)

Discussion in 'Microsoft Dot NET Framework' started by Vladimir, Dec 1, 2007.

  1. Vladimir

    Vladimir Guest

    The .NET Framework 3.5 installation fails for me. Right after the
    "Downloading components" stage, it sits for a few seconds on "Setup
    has finished downloading components, you can now disconnect from the
    Internet" and then it starts to roll back. I'm using XP SP2. A glance
    in the log files shows that it seems related to MSI error code 1603.

    Things I have tried:

    - reinstalling SP2
    - uninstalling and reinstalling every .NET Framework version before
    3.5 with all service packs

    Per Aaron Stebner's WebLog, I tried to enable verbose MSI logging, but
    even so the logs didn't really enlighten me.

    Here are all the files from my temp folder generated during setup:

    http://thecybershadow.net/dump/c5719a60148f4ae60a5fa4e3887b3baf/logs.zip

    Hopefully someone with some time and experience in the field can give
    me a few hints or things to try.
    Thanks!
     
    Vladimir, Dec 1, 2007
    #1
    1. Advertisements

  2. Vladimir

    PvdG42 Guest

    "Vladimir" <> wrote in message
    news:...
    > The .NET Framework 3.5 installation fails for me. Right after the
    > "Downloading components" stage, it sits for a few seconds on "Setup
    > has finished downloading components, you can now disconnect from the
    > Internet" and then it starts to roll back. I'm using XP SP2. A glance
    > in the log files shows that it seems related to MSI error code 1603.
    >
    > Things I have tried:
    >
    > - reinstalling SP2
    > - uninstalling and reinstalling every .NET Framework version before
    > 3.5 with all service packs
    >
    > Per Aaron Stebner's WebLog, I tried to enable verbose MSI logging, but
    > even so the logs didn't really enlighten me.
    >
    > Here are all the files from my temp folder generated during setup:
    >
    > http://thecybershadow.net/dump/c5719a60148f4ae60a5fa4e3887b3baf/logs.zip
    >
    > Hopefully someone with some time and experience in the field can give
    > me a few hints or things to try.
    > Thanks!



    You might try this as an alternative:

    Go here:

    http://www.microsoft.com/downloads/...B531-508D977D32A6&displaylang=en#Instructions

    Scroll down to Instructions and click on the link to download the
    redistributable package instead of the bootstrapper, then try the install
    from your local hard drive.
     
    PvdG42, Dec 1, 2007
    #2
    1. Advertisements

  3. Vladimir

    Vladimir Guest

    On Dec 1, 7:18 pm, "PvdG42" <> wrote:
    > You might try this as an alternative:
    >
    > Go here:
    >
    > http://www.microsoft.com/downloads/details.aspx?FamilyId=333325FD-AE5...
    >
    > Scroll down to Instructions and click on the link to download the
    > redistributable package instead of the bootstrapper, then try the install
    > from your local hard drive.


    That didn't help, unfortunately. It seems to be the same error. I can
    post the logs at your request.
     
    Vladimir, Dec 1, 2007
    #3
  4. Vladimir

    Guest

    uninstall .net framework 3.5 and reinstall it from the following link
    and it shud work. even i encountered the same problem and now it works
    fine
    http://www.microsoft.com/downloads/...FD-AE52-4E35-B531-508D977D32A6&displaylang=en

    On Dec 2 2007, 12:05 am, Vladimir <> wrote:
    > On Dec 1, 7:18 pm, "PvdG42" <> wrote:
    >
    > > You might try this as an alternative:

    >
    > > Go here:

    >
    > >http://www.microsoft.com/downloads/details.aspx?FamilyId=333325FD-AE5....

    >
    > > Scroll down to Instructions and click on the link to download the
    > > redistributable package instead of the bootstrapper, then try the install
    > > from your local hard drive.

    >
    > That didn't help, unfortunately. It seems to be the same error. I can
    > post the logs at your request.
     
    , Jan 4, 2008
    #4
  5. Vladimir

    Guest

    Unfortunately, the problem that I, and most of the people complaining
    about this problem have, is exactly what we've reported. .Net
    Framework 3.5 "failed to install", meaning that there is no .Net
    framework 3.5 to uninstall and try reinstalling. It won't install "at
    all" in the first place. That is the whole problem from beginning to
    end.


    On Jan 4, 1:53 am, wrote:
    > uninstall .net framework 3.5 and reinstall it from the following link
    > and it shud work. even i encountered the same problem and now it works
    > finehttp://www.microsoft.com/downloads/details.aspx?FamilyId=333325FD-AE5...
     
    , Feb 8, 2008
    #5
  6. Vladimir

    Guest

    Try the following:
    1. Open Registry Editor (regedit in command prompt)
    2. Navigate to the key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet
    \Services\Eventlog\Security\ServiceModel 3.0.0.0
    3. Right click ServiceModel 3.0.0.0 select Permissions
    4. Click Advanced
    5. Under Permissions tabs, Select Inherit from parent the permission
    entries that apply to child objects. Include these with entries
    explicitly defined here.
    6. Click Apply, Click OK, Click Ok and Close Registry Editor.
     
    , Feb 26, 2008
    #6
  7. Vladimir

    Guest

    > Framework 3.5 "failed to install", meaning that there is no .Net
    > framework 3.5 to uninstall and try reinstalling.  It won't install "at
    > all" in the first place.  That is the whole problem from beginning to
    > end.


    The 1603 error is very generic and is simply a fatal error. There are
    lots of blog entries on how to find the root cause. The underlying
    cause is typically in one of the other log files. Those log files are
    written to a temporary directory (try Start/Run and typing %temp%).
    Aaron Stebner's blog goes into some detail
    http://blogs.msdn.com/astebner/archive/2005/08/01/446328.aspx

    In my case, I found a 2761 error about a global mutex buried in one of
    those log files. It looked like it was related to RGB Rast
    installation, but as it turned out, I could not install any .msi files
    (MSIEXEC was corrupted in some way). That lead me to a post that
    fixed it for me: http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=316101&SiteID=1
    (look for a post by tomazek).
     
    , Mar 25, 2008
    #7
  8. Vladimir

    Marc Gravell Guest

    We had huge problems with 3.5 install; with help from MS, it turns out that
    you sometimes need to install it as a local admin on the machine. A domain
    admin isn't enough!
    So try making yourself a local admin (i.e. in the local "administrators"
    group for the machine) before installing.

    Marc
     
    Marc Gravell, Apr 3, 2008
    #8
  9. Vladimir

    Devi Muni Guest

    My OS is running on Windows XP Embedded Version 2002 SP2 and I am facing
    the same problem. I am unable to install .NET Framework 3.5 and am faced
    with Error 1603. I have tried all the steps and solutions stated here
    but its not helping me. Hope someone can help me out with this problem!
    Thanks!

    *** Sent via Developersdex http://www.developersdex.com ***
     
    Devi Muni, Apr 21, 2008
    #9
  10. Vladimir

    Guest

    ok based on previous post i read
    i looked at the logs in the %temp% and found:

    Windows Presentation Foundation: ***ERRORLOG EVENT***

    so im reading and reading - not unistalling and re-installing ,,, been
    down that road to many times.


    Then a poster in another forum said: If you have Spybot Search and
    Destroy installed and the Tea-Timer activated...switch off the tea-
    timer and try again.
    http://www.pcadvisor.co.uk/forums/index.cfm?action=showthread&threadid=314275&forumid=1&sr=21

    so i thought - used to have a very hard time installing things with
    certain anti-virus programs.

    I turned mine off.
    installed perfectly.

    thanks for all the brainstorming everyone did, led me to my salvation.
     
    , Apr 30, 2008
    #10
  11. Vladimir

    Andy Ho Guest

    Andy Ho, Sep 10, 2008
    #11
  12. Vladimir

    murdochsys

    Joined:
    Mar 22, 2009
    Likes Received:
    0
    fix found

    After a week of searching for a fix and was just about to re-format I found a fix.

    I found that the file spupdsvc.exe in \windows\system32 was corrupted. I found a backup of this in \windows\softwaredistribution\download.....
    So I copied that over the one in system32 and now I was able to install XPSEPSC.exe then dotnet3.5

    Hope this helps someone cause I nearly tore my hair out
    Sean
     
    murdochsys, Mar 22, 2009
    #12
  13. Vladimir

    arunthomasarun

    Joined:
    Nov 6, 2009
    Likes Received:
    0
    arunthomasarun, Nov 6, 2009
    #13
  14. Vladimir

    arunthomasarun

    Joined:
    Nov 6, 2009
    Likes Received:
    0
    arunthomasarun, Nov 23, 2009
    #14
    1. Advertisements

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
  1. Jim

    error 1603: mscorwks.dll error

    Jim, Mar 16, 2004, in forum: Microsoft Dot NET Framework
    Replies:
    0
    Views:
    338
  2. Guest

    Difference between .NET Framework and .NET Compact Framework

    Guest, Mar 24, 2004, in forum: Microsoft Dot NET Framework
    Replies:
    1
    Views:
    1,232
    Gabriele G. Ponti
    Mar 24, 2004
  3. Guest

    Difference between .Net Framework and .Net Framework SDK

    Guest, Sep 14, 2004, in forum: Microsoft Dot NET Framework
    Replies:
    1
    Views:
    2,824
    Raghavendra T V
    Sep 14, 2004
  4. Ivan Debono

    Error 1603 when installing .NET Framework 1.1

    Ivan Debono, Aug 16, 2005, in forum: Microsoft Dot NET Framework
    Replies:
    0
    Views:
    517
    Ivan Debono
    Aug 16, 2005
  5. Guest
    Replies:
    2
    Views:
    1,355
    Guest
    Jan 24, 2007
  6. Lee

    Error Code 1603 - Windows Communication Foundation

    Lee, Dec 9, 2007, in forum: Microsoft Dot NET Framework
    Replies:
    0
    Views:
    390
  7. Replies:
    0
    Views:
    488
  8. iFruitTart

    [.Net Framework 3.5] Error code 1603 Solution

    iFruitTart, Feb 15, 2009, in forum: Microsoft Dot NET Framework
    Replies:
    0
    Views:
    3,719
    iFruitTart
    Feb 15, 2009
Loading...