Can not open .xls files via Windows Explorer

  • Thread starter paulmitchell507
  • Start date



If I attempt to open a .xls with Excel 2003 via Windows Explorer,
Excel opens, but the sheet is never displayed, I receive a windows
error message stating the correct file lactation, but that the
specific file can not be found.

If I then repeat the same process, double click the .xls in Windows
Explorer, Excel will open the file. If I have already opened Excel I
can use the file>open menu to select any .xls and it will open.

I suspect the problem may be with windows explorer, but users of Excel
may have experienced this problem.
Vista SP1 and Microsoft Office 2003.




The limit to the filename (including path) that can be opened is around 128
characters. When the filename is between 120 and 128 you get different error
messages depending if you are opening the the file from window explorer or
from inside excel.

You can either more the file to a different locattion or what I do is add a
new mapped drive in the window explorer with a shorter path. Add a new
mapped drive ( like X:) and instead of mapping it to the root folder on the
network drive map X: to the folder where your file is located,or any folder
that would give you less than 120 characters in you path.

You can add the mapped dirve in the window explorer by going to menu

First find the present mapping for the dirve you arre using by going to menu
Tools - disconnect NetWork Drive

Then write down the Network path for the drive being used like for S:

Then go to menu

Tools - Map Network Drive
Explorer will automaticlly choose a drive that is not mapped
Enter in to folder box the path you wrote down. then press Browse and find
the folder where you file is located.


Also make sure that there are no special characters in the path or filename
which will conflict with html code. Characters like [email protected]#&% are acceptable in
filenames but cannot be used in links.



Dave Peterson

Sometimes one of these works when you're having trouble with double clicking on
the file in windows explorer:

Tools|Options|General|Ignore other applications (uncheck it)
(xl2003 menus)

--- or ---

Close Excel and
Windows Start Button|Run
excel /unregserver
Windows Start Button|Run
excel /regserver

The /unregserver & /regserver stuff resets some of the windows registry to
excel's factory defaults.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question