Template on Server 2008


W

widman

I've put an Excel template (.xlt)(Excel 2003 sp3) in a public folder on a
server that is running server 2008.

I put shortcuts to it on several windows machines and some open it as a
worksheet adding a 1 to the end of the name, as it normally would as a local
file, but some machines open it as a template.
Windows XP as xls in Excel 2003
Windows XP as xls en Excel 2007
Windows Vista 32, one as xls and one as xlt en Excel 2003
Windows Vista 64 as xlt en Excel 2003

Obviously I need them to open as xls. How?
 
Ad

Advertisements

S

Steve Dunn

Sounds like the file associations on those machines have lost their default
selection for .xlt files. Try using a program like: FileTypesMan. All
you'll need to do is find .xlt in the list of filetypes, select it,
double-click New in the bottom pane, and make sure Default Action is
selected.

Unfortunately, you'll need to do this on each machine that is having
problems.

http://download.cnet.com/FileTypesMan/3000-2094_4-10806311.html

HTH
Steve D.
 
W

widman

On the right track, but on the XP machine I check to open with Excel instead
of a converter that it has as default, and check to always open with Excel,
but it does not change.

On the Vista 64 machine, it opens with the converter and when I browse I
can't find Excel. Seraching it only finds the shortcut in
C:\ProgramData\Microsoft\StartMenu, and I can't find that with the browse or
microsoft office.
 
S

Steve Dunn

When file associations are first set up, the context menu (which opens when
you right-click on a file) can have several items, in the case of an Excel
template the top two are usually Open and New. Although they both use Excel
to open the file, the difference is that Open will open it as an editable
template, and New will open it as a new file based on the template. This is
the problem you originally described, and can be solved by making sure that
New is the default action.

However, if you have introduced a converter, you have probably destroyed the
original associations and you need to re-instate them. This can be in
addition to the converter. For Open try:

"C:\Program Files\Microsoft Office\Office12\EXCEL.EXE" /e

and for New try:

"C:\Program Files\Microsoft Office\Office12\EXCEL.EXE" /e /n

You will have to change Office12 (for Excel 2007) to reflect the installed
version, I think Excel 2003 is in Office11.

Then decide which you want as the default action.

HTH
Steve D.
 
W

widman

The converter is "Microsoft Open XML Converter". No matter how many times I
tell it to open xlt files with Excel, even when it shows that Excel will open
it, the file opens as xlt through this microsoft program.
 
Ad

Advertisements

S

Steve Dunn

When you right-click on the file in Windows Explorer, do you get the "New"
option? You may have to be resigned to always using that, rather than
double-clicking.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top