Black Screen with Remote Desktop...



I have two different Win 2000 Servers. With Machine #1, no one seems
to have a problem using remote desktop to access it. However with
machine #2, I have one WinXP Pro machine that when ANYONE tries to use
remote desktop all they get is a black screen!

I have not had any problem using 4 or 5 other WInXP machines trying to
access both Win2000 Servers.

I did a little googling, but nothing seems to apply.

This is strickly LAN traffic, there is NO VPN involved, and we have a
gigabit network, so there is no conjestion.

I have no problem pining both servers from all machines. I have tried
different screen resolutioins, all to no avail.

In this case, both the client and server machines are using Intel Pro
1000 GT NICs, with latest drivers....



I tried THIS:


I believe I got it to work. This article (Q159211) was invaluable:;EN-US;q159211

Under HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters, I added
registry entries:

- MTU with value of 1400 (as derived per the article with "ping -f -l
- EnablePMTUBHDetect with a value of 1

The first value didn't do anything, but adding the second one made it
Perhaps the second one on its own is sufficient, but it was late and I
didn't determine whether it was the combination of both or only the

At this point, it works, but I don't know if I'd call this a
"solution". I
still don't know why my machine is acting differently from the other
machines here. It's definitely a "workaround" or perhaps simply a
But it does work, so I'm satisfied.

Hope that helps someone else with this problem.


I added a registry entry


Looks like it actually worked! :)

Blue Max

We are having the same problem with Windows Vista Ultimate 32-bit. About
one minute after we establish a connection, the screen goes black. We can
close and re-establish the connection for about another minute, but this
would obviously drive anyone crazy. Yet, establishing a remote connection
from a completely different computer to both the original host and the
original client (now functioning as a host) both work fine. As you
indicated, the MTU solution is a work-around versus a true resolution. We
have several reservations about how this work-around setting will affect
other opertions. It is also very difficult to determine what setting will
be proper for our specific configuration. It is a technical change that a
normal user should not have to resort to in order to fix the problem. This
feature, under most normal circumstance (in our case, a very common
configuration), should work flawlessly! Please let us know if you hear of a
better fix and we will do the same.




Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question