"Your IMAP server closed the connection."


K

Kent Moore

Hi:



I am using Outlook 2007 on Windows XP SP2 Home and I am getting the
following pop up message fairly frequently. It is annoying because when I
get the message it comes to the foreground and interrupts whatever work I am
doing.



"Your IMAP server closed the connection. This can occur if you leave the
connection idle for too long."



I don't have any other e-mail programs open. I know you can receive this
message when other e-mail programs are open. I talked to my ISP and they
said there is nothing they can do but that they have the same problem when
using Outlook 2007. I never received this message with 2003 unless I had
another e-mail program open. The only thing that is better with 2007 is
that the same message does not pile up like it did with 2003 where you could
get dozens of the same message and would have to close them all.



I have also changed "server timeouts" to 10 minutes and this does not help.
I wish Outlook would have an option to allow this message to be turned off.



Thanks for any suggestions. Kent
 
Ad

Advertisements

D

DevilsPGD

In message <OIqlvx8oHHA.1220@TK2MSFTNGP03.phx.gbl> "Kent Moore"
I have also changed "server timeouts" to 10 minutes and this does not help.
I wish Outlook would have an option to allow this message to be turned off.
You have identified the crux of the problem -- The IMAP protocol
specifically allows the server to drop the connection, and suggests that
clients handle it gracefully rather then whining to the user.

Outlook doesn't.

Microsoft was informed of this as far back as the 90s, and has decided
to opt for user-unfriendliness.

All that being said, if your IMAP server leaves connections for at least
30 minutes (the IMAP spec's suggested minimum idle time) then you
shouldn't see this issue much unless you have some networking gear that
kills idle connections (many cheapo SOHO NAT boxes do, unfortunately)
 
J

Jason Dunn

"Your IMAP server closed the connection. This can occur if you leave the
connection idle for too long."
I'm using Outlook 2007 and Vista, with six IMAP accounts on a dedicated
server I run, and I can leave Outlook open for days and never seen this
message. There's something that Outlook doesn't like about your IMAP server,
or your IMAP server is configured to kill connections somehow. I'd look to
the server and see if there's a way to change it...

Jason Dunn
www.digitalmediathoughts.com
 
K

Kent Moore

Thanks Jason. Yes you are correct in that it has something to do with my
school's server. I think it is an older type but they will not upgrade so I
am stuck with it. I did ask them if there was anything they could do and so
far they said no but they are researching it and will let me know if they
find anything. They just started testing Outlook 2007. Kent
 
G

Guest

I was going crazy from all the IMAP server connection errors in 2007. But,
even though the connections were timing out, (or whatever) I noticed the mail
was still appearing in my IMAP folders.

I was about to switch back to Outlook 2003, when I got this idea. My IMAP
accounts are in a separate send/receive group than my pop3 accounts. Since
mail appears in the IMAP accounts even when the connection was lost, I
disabled "Schedule an automatic send/receive every X minutes" for that
send/receive group, and all the problems went away.

There's no need for Outlook to constantly retrieve mail from the IMAP
accounts since its a 'live' connection. The mail appears when it arrives with
no need for Outlook to do automatic send/receives.

Give it a try...
 
K

Kent Moore

Hi compdoc:



You may have hit on something big here for me and others. I did have it set

to send/receive every minute because I like getting messages ASAP. I turned

that off and so far so good. I didn't realize messages would still come in

if it didn't automatically send/receive. That part is working well and I am

getting messages. Now I will wait to see if I still get any of the pop ups.

If this works consistently, this fix should be published because I know the

pop up is a major problem for many people. Thanks for your help! Kent
 
Ad

Advertisements

K

Kent Moore

With Compdoc's idea everything is working for me so far. I just have to
remember to keep my IMAP folder "live" and open because if I am on another
folder, I won't receive my messages immediately. Thank again, Kent
 
G

Guest

I generally click Send/Receive once when I first open Outlook, and that seems
to get it going. You can also just click on the IMAP inbox once or twice as
well.

After that, there doesnt seem to be a need to keep the account highlighted
or anything to keep it live.
 
K

Kent Moore

Thanks. I'll give that a try. I have also been experimenting with longer
send/receive times such as 10 minutes and so far so good but time will tell.
Kent
 
R

Rich Gierman

No. No. No. Don't muck with the timeout. Leave the polling for mail delivery alone. It isn't any of those things. I drove myself nuts dinking with those. If you read AOL's page on IMAP and AOL mail, the solution is right there.

http://about.aol.com/faq/openmailaccess#OL0203

Go into the advanced properties for the account. Go to the Outgoing Server tab.

PLACE A CHECKMARK IN THE BOX THAT SAYS "My outgoing server (SMTP) requires authentication". Then back out gracefully. THAT INSTANTLY FIXES THE PROBLEM! No restart, no close Outlook and re-open it.

In fact, after I did that, I was immediately able to move incoming e-mails from the inbox to any of my saved mail folders (which was where most of the problems were occurring). However, it took forever for it to happen.

As soon as I went back into advanced properties and moved that stupid slider from 10 minutes back down to its lowest setting - 10 seconds - my response time for moving an email to a folder or even opening a new email dropped to almost instantly!

I was having the problem on a completely fresh install of XP SP3, so I figured it either had to be some unannounced change by AOL on their mail servers - and we all know that never happens, right? - or it had to be a configuration option. In spite of the fact that it just started a couple of months ago and I hadn't changed anything in a year or two.

Anyway, problem REALLY solved!

Rich
 
F

Frank Cope

Ad

Advertisements

D

DivaVocals

That's because compdoc was ABSOLUTELY dead on!!! Turning off the automatic send receive settings for all of my IMAP accounts stopped this annoying little error IMMEDIATELY.. and his reasons why are SPOT on.. IMAP accounts by their nature are LIVE connections.. no need to keep pinging the daggone server..

I just followed his suggestions 30 minutes ago, and not only is my PC FINALLY (after a year of this nonsense) QUIET, it actually seems to be running better, and Outlook is not FREEZING all the daggone time (Outlook had a "shelf life" of 30 minutes on my PC before I had to often shut it down and restart it.. this was more annoying than the stupid error messages)

If you have multiple e-mail accounts enabled and have both POP3 and IMAP protocols, segregating the POP3 ones for the automatic send and receive settings while turning it off for the IMAP accounts will stop these annoying little messages..

Too bad AOL fails to include this information in their setup IMAP setup instructions.. (Which I have memorized as I have been using AOL --with either POP3 or IMAP protocols-- with Outlook and other mail clients LONG before AOL FINALLY shared with the public how to do this..)
 
Ad

Advertisements

N

neil.bingham

Hi:



I am using Outlook 2007 on Windows XP SP2 Home and I am getting the
following pop up message fairly frequently. It is annoying because when I
get the message it comes to the foreground and interrupts whatever work Iam
doing.



"Your IMAP server closed the connection. This can occur if you leave the
connection idle for too long."



I don't have any other e-mail programs open. I know you can receive this
message when other e-mail programs are open. I talked to my ISP and they
said there is nothing they can do but that they have the same problem when
using Outlook 2007. I never received this message with 2003 unless I had
another e-mail program open. The only thing that is better with 2007 is
that the same message does not pile up like it did with 2003 where you could
get dozens of the same message and would have to close them all.



I have also changed "server timeouts" to 10 minutes and this does not help.
I wish Outlook would have an option to allow this message to be turned off.



Thanks for any suggestions. Kent
Have had this daft prob since Jan resulting from change of email password -outlook is a pain in the butt as this prob does not happen if I use BT yahoo mail instead. Having tried many online 'solutions' - none of which worked, I had the idea to go to control panel - programs and ask it to repair MS Office 2010 - took a lot of minutes -BUT my prob has gone! - worth a tryanyone - costs nowt but about 10-15mins of your time - and unlikely to land you with further probs - wish I had tried it before - but there is no guarantee that will solve your probs - but worth a try Pity MS has no solution!
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top