XP Remote Desktop to Server 2003 via SSH tunnel failing (W2K OK)


B

bob.smithson

I have a problem which has been driving me insane.

For a long time with no problems, I have been using Remote Desktop to
connect to my machine at work (Windows Server 2003) from my old
Windows 2000 box at home. I have been using SSH to tunnel the
connection.

Recently I built myself a new machine and installed XP Pro SP2 on it.
Using exactly the same method as on the W2K machine, and some
variations that have been suggested by articles I have found on the
web, I have had absolutely no success in connecting.

Here is an outline of what works on W2K:

o Use Putty to connect to gateway Unix machine:
SSH to machine with tunnel with source port 3389 and destination
127.0.01:77777
where 77777 is an essentially arbitrary port in some range.
o In the terminal I then ssh to another Unix machine, let's call it
fred, on the internal work network:
ssh -l bob fred -L 77777:myserver:3389
Here bob is my Unix login name, and myserver is my Server 2003
machine that I want to remote into.
This command logs me into fred setting up the tunnel from my W2K
machine to the Server 2003 host.
o I then run the Remote Desktop client on my W2K box, specifying
127.0.0.1 in the "Computer" setting on the initial dialog.
o This connects fine and I can login to the remote desktop.

With Windows XP, if I do exactly the same thing, I get the error:

"The client could not connect. You are already connected to the
console of the computer. A new console session cannot be established."

A bit of research revealed that this is a common problem, and the
solution is to use 127.0.0.2 instead of 127.0.0.1.

This initially appears to work but it is actually connects to Remote
Desktop on my XP client box!

So I disable RD on my client, try again and I get:

"The client could not connect to the remote computer.

Remote connections might not be enabled or the computer might be too
busy..."

Now I don't know whether this is referring to a connection on my work
host or my XP client.

I have also tried different source ports 3390, 3391, and have tried
suffixing the 127.0.0.2 with the port in the initial remote desktop
client login dialog (i.e. 127.0.0.2:3389 etc, or whatever source port
I am trying).

I have also tried disabling my firewall to no avail.

I would really like to solve this as I would like to decomission my
old W2K machine. At the moment, as I only have one keyboard, monitor
etc and no KVM switch, and the XP box is now my principal machine at
home, I am going through the ridiculous process of VNCing into the old
machine in order to remote desktop from there to work!

Any suggestions gratefully received, including any ideas for how I
might investigate what could be going wrong.

Thanks
~~
Bob
 
Ad

Advertisements

S

Sooner Al [MVP]

Bob,

With XP SP2 you need to apply this patch to fix this loopback issue...

http://support.microsoft.com/default.aspx?scid=kb;en-us;884020

Good luck...

--

Al Jarvi (MS-MVP Windows - Desktop User Experience)

Please post *ALL* questions and replies to the news group for the
mutual benefit of all of us...
The MS-MVP Program - http://mvp.support.microsoft.com
This posting is provided "AS IS" with no warranties, and confers no
rights...
How to ask a question
http://support.microsoft.com/KB/555375
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top