why usb port mouse not working now


G

Guest

Using xp prof, all my usb deviceswere working prior to pc hang and I decided
to clean the hdd with antivirus. The hdd was slaved and a spyware etc were
deleted. I put back the hdd into my pc but instead of using the usb mouse I
use the ps2 mouse, (with all the other usb ports/devices not connected).

When I boot up, the pc detected a new mouse and was able to load/find the
driver and it works well ( ps2 mouse). After installating the latest
antivirus, update the definitions etc and the pc works fine with the ps2.

Then I decided to use the usb mouse, but the pc cannot to detect it and
neither are all the usb ports (where I originally have other devices such as
usb printer etc).

I then go to the bios and notice that ""plug and play aware o/s from - "yes"
which I change to "no" and ""pci ide bus master from - "disable' to
'enabled'. This doesnt help also as the usb mouse still does not work, but
the ps2 mouse will work.

I then change the ""plug n play aware o/s"" from 'no' to 'yes' (that is its
original aetting as I first see it) and the ""pci ide bus master"" remain as
'enabled", still the usb mouse doe not work but the ps2 will works when
connected.
Can somehelp help as to why the usb mouse does not work now and (also does
not work on all the 3 other usb ports). TIA
 
Ad

Advertisements

P

paulmd

quitono said:
Using xp prof, all my usb deviceswere working prior to pc hang and I decided
to clean the hdd with antivirus. The hdd was slaved and a spyware etc were
deleted. I put back the hdd into my pc but instead of using the usb mouse I
use the ps2 mouse, (with all the other usb ports/devices not connected).

When I boot up, the pc detected a new mouse and was able to load/find the
driver and it works well ( ps2 mouse). After installating the latest
antivirus, update the definitions etc and the pc works fine with the ps2.

Then I decided to use the usb mouse, but the pc cannot to detect it and
neither are all the usb ports (where I originally have other devices such as
usb printer etc).

I then go to the bios and notice that ""plug and play aware o/s from - "yes"
which I change to "no" and ""pci ide bus master from - "disable' to
'enabled'. This doesnt help also as the usb mouse still does not work, but
the ps2 mouse will work.

I then change the ""plug n play aware o/s"" from 'no' to 'yes' (that is its
original aetting as I first see it) and the ""pci ide bus master"" remain as
'enabled", still the usb mouse doe not work but the ps2 will works when
connected.
Can somehelp help as to why the usb mouse does not work now and (also does
not work on all the 3 other usb ports). TIA

Plug n play OS should be "yes" with XP.

You may have USB2, which sometimes requires drivers.

To check this, go into the device manager:

windows logo key + pause

select "hardware"
click on the "device manager" button

look for any question marks, exclamition points or Xes.
 
G

Guest

Set the pnp aware os to 'yes' and there is no ? or ! in the device manager,
and the usb port still does not work. The usb mouse is just an ordinary mouse
from pbell. Is there any thing I can do to the xp?
 
Ad

Advertisements

P

paulmd

quitono said:
Set the pnp aware os to 'yes' and there is no ? or ! in the device manager,
and the usb port still does not work. The usb mouse is just an ordinary mouse
from pbell. Is there any thing I can do to the xp?

try new mouse, perhaps.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top