Want to surpress "Sent on behalf of"


R

Rich Roller

SCENARIO:

Kerri has 2 mailboxes for 2 different companies: (e-mail address removed) &
(e-mail address removed). She wants separate mailboxes but she wants to use them at
the same time. She has an Outlook 2003 profile for [email protected] and accesses
[email protected] from within there, utilizing the automatic account setting "open
these additional mailboxes". Permissions are shared between the 2
mailboxes, so that reading & filing works great this way, but...

PROBLEM:

When she goes to send as [email protected] by putting that in the From: field, the
resulting sender always shows as "[email protected] on behalf of [email protected]". Plus
the message ends up in the SentItems of [email protected] eventhough it's being sent
From: [email protected]

QUESTIONS:

Q1: Is there any way to supress the "ON BEHALF OF" so that the sender would
actually appear as the mailbox she chooses, in the From: field, i.e.
[email protected]? I thought I recall some sort of client-side registry hack for
this.

Q2: Is there no way to prevent these messages from going into the SentItems
of the profile's primary mailbox, but rather to the SentItems of the mailbox
in the From: field? I think the answer to this is "no"... Outlook seems
hard-wired for this... but I figured I'd ask, just in case.

NOTE:

Obviously if she logs out of Outlook as [email protected] and logs back into a
separate profile that has [email protected] as primary then everything works as
desired. But she will absolutely not want to go through this logoff/logon
hassle hundreds of times a day... who can blame her!

TIA,

Rich
 
Ad

Advertisements

S

Sue Mosher [MVP-Outlook]

If these are two different mailboxes, grant the main account Send As permission over the secondary account.

--
Sue Mosher, Outlook MVP
Author of Configuring Microsoft Outlook 2003

and Microsoft Outlook Programming - Jumpstart for
Administrators, Power Users, and Developers
 
R

Rich Roller

Yes, they are 2 sep mailboxes.

I think the way it's set up already is: Secondary mailbox grants Send As
permission to the Primary. Is that what you mean, or the other way around
which is sort of counter-intuitive?

Also, all this permissions setting was done within Outlook. I saw another
post somewhere that seemed to say that to eliminate the "sent on behalf of"
you need to set the "Send As" permissions in Active Directory of Exchange
Server... ring any bells?

Thanks again (and as always!) Sue.

-Rich


If these are two different mailboxes, grant the main account Send As
permission over the secondary account.

--
Sue Mosher, Outlook MVP
Author of Configuring Microsoft Outlook 2003

and Microsoft Outlook Programming - Jumpstart for
Administrators, Power Users, and Developers
 
R

Rich Roller

And am I right about Q2? Messages always go to the primary SentItems
regardless of what is in the From: field? -Rich

If these are two different mailboxes, grant the main account Send As
permission over the secondary account.

--
Sue Mosher, Outlook MVP
Author of Configuring Microsoft Outlook 2003

and Microsoft Outlook Programming - Jumpstart for
Administrators, Power Users, and Developers
 
S

Sue Mosher [MVP-Outlook]

It is not possible to grant Send As permission in Outlook. You must use Active Directory Users & Computers for that.

--
Sue Mosher, Outlook MVP
Author of Configuring Microsoft Outlook 2003

and Microsoft Outlook Programming - Jumpstart for
Administrators, Power Users, and Developers
 
Ad

Advertisements

R

Rich Roller

You're absolutely right... my mistake. I was thinking of the granular
mailbox folder permissions in Outlook.

Anway, for this particular user, they're on a hosted Exchange Server, where
there's a custom web-based control-panel (very nice actually) which allows
you to set two things at the user/mailbox level:
1. Advanced tab -> "Grant Full Mailbox Access to"
2. Delivery tab -> "Give Send On Behalf Of Permissons to"

I'm guessing that #1 points to the AD Security tab, which includes "Send As"
permission. And I guess #2 points to the AD Exchange General tab, Delivery
Options, which includes "Send on behalf" permission.

I'm in discussion with the hosting company to try to confirm all this, but
their techs don't know much more than how to setup Outlook profiles! So I
was hoping to find something definitive that should work and if it's a
server-side change then ask them to make it happen.

So in the end, I guess I'm back to the original question... is it possible
to supress "On Behalf Of" from showing in the sender address, when you
change the From: field to send as someone else? And if so, is it controlled
in the above places or if not where?

Thanks again!

-Rich


It is not possible to grant Send As permission in Outlook. You must use
Active Directory Users & Computers for that.

--
Sue Mosher, Outlook MVP
Author of Configuring Microsoft Outlook 2003

and Microsoft Outlook Programming - Jumpstart for
Administrators, Power Users, and Developers
 
S

Sue Mosher [MVP-Outlook]

Again, it's controlled from AD. The Send As permission is what's required. What your host's controls actually do is something that only they know. I suspect they do not provide a way for you to grant Send As.

--
Sue Mosher, Outlook MVP
Author of Configuring Microsoft Outlook 2003

and Microsoft Outlook Programming - Jumpstart for
Administrators, Power Users, and Developers
 
Ad

Advertisements

R

Rich Roller

So in the end, I guess I'm back to the original question... is it possible
to supress "On Behalf Of" from showing in the sender address, when you
change the From: field to send as someone else? And if so, is it
controlled in the above places or if not where?

I'm happy to report that the problem is solved, so I can now answer this
question myself: Indeed it is possible to supress "On Behalf Of" from
appearing in the Sender.

In my case, the Exchange admins at the hosting company admitted that the AD
setup for this user was incorrect. They fixed something (unfortunately they
have not told me what) and now it works fine.

So I can also answer the 2nd part of the question: This issue is controlled
on the server-side in AD.

Hurrah, resolution! The user only had to put up with the incorrect behavior
for a year or so. ;-)

-Rich
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top