Vista 64 can't accept new drivers


G

Guest

Hi!

I just got a Nvidia GeForce 7600 GS and a Windows Vista 64-bit. After
installing and downloading Forceware Drivers 101.41 (64-bit) Vista could
still not detect the new ones and still defaults to the old drivers.

I've already tried

1. Manually installing the new drivers through the device manager but
Windows still holds on to the old driver version "7.15.0011.0065 (English)"

2. Uninstalling the default windows drivers themselves but when I restart,
Vista reinstalls it back.

3. When I don't restart and install the new drivers immediately, the
Graphics Card disappears from the Device Manager. When I try to install the
new driver, The driver setup could not detect a driver suitable for the
hardware.

Please help! and thanks!
 
Ad

Advertisements

S

Steve Jain

Hi!

I just got a Nvidia GeForce 7600 GS and a Windows Vista 64-bit. After
installing and downloading Forceware Drivers 101.41 (64-bit) Vista could
still not detect the new ones and still defaults to the old drivers.

I've already tried

1. Manually installing the new drivers through the device manager but
Windows still holds on to the old driver version "7.15.0011.0065 (English)"

2. Uninstalling the default windows drivers themselves but when I restart,
Vista reinstalls it back.

3. When I don't restart and install the new drivers immediately, the
Graphics Card disappears from the Device Manager. When I try to install the
new driver, The driver setup could not detect a driver suitable for the
hardware.

Please help! and thanks!

You should:
1. Uninstall the nVidia drivers via control panel
2. reboot
3. disable you AV
4. Install the 101.41 drivers
5. reboot
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top