USB2 device can't find USB2 Port...


G

Guest

I've read about similar problems in other threads, but I can't get anything
to work.

My problem: I have a USB2 scanner. When I plug it in and turn it on I get a
message stating: "This USB device can perform faster if you connect it to a
Hi-Speed USB 2.0 Port. For a list of available ports, click here."

I click on the message and it lists "USB Root Hub" with 8 ports available.
My computer is an MSI K8n Neo motherboard and has 8 USB2 ports, 4 on the back
and two USB connections on the motherboard (JUSB1 and JUSB2) for putting
extra ports in the expansion slots. I have that cable hooked up. No matter
which port I plug into (any of the 8 I have available) I get the message.

In Device Manager under Universal Serial Bus controllers I have the
following listed:
Standard Enhanced PCI to USB Host Controller
Standard OpenHCD USB Host Controller
Standard OpenHCD USB Host Controller
USB Root Hub
USB Root Hub
USB Root Hub

When I go into properties for the three USB Root Hub entries and select the
Power tab I get (from top to bottom) 4 ports available, 4 ports available, 8
ports available. Of course that's with the scanner unplugged.

I have an internal USB2 card reader that plugs into the JUSBx port on the
motherboard. When I plug that in to the JUSB2 connection it adds a "USB Mass
Storage Device" into the list and it shows up in the first USB Root Hub under
Power. If I plug in my printer (Canon S9000) into one of the back USB ports
it shows up in the first USB Root Hub under Power and a USB Printing Support
entry shows up under USB Controllers. When I plug my scanner in after these
devices I get different messages depending on which port I plug into. If I
use the back ports it says the same message as above, that I need to plug it
into a hi-speed port. If I plug it into one of the ports supplied by JUSB1 it
says "Unknown Device" and that it's not functioning properly.

Any clues? I have tried turning off all USB devices and uninstalling all
the entries under USB Controllers and then restarting. They all come back.
But it doesn't help.

Of course this used to work, and I haven't changed anything. Seriously, it
used to work yesterday and today it doesn't. The Card reader is always on (as
it doens't have an off switch) and the printer is left on also. The scanner
is turned on when necessary. Taking the printer and card reader out don't
help. I have also tried disabling each of the USB Root Hub's in all
combinations and either the scanner isn't recognized at all, or it gives me
the message that I need a hi-speed port.

Thanks,

Scott
 
Ad

Advertisements

R

Richard Urban

You didn't say if you installed the software for your USB 2 scanner. Mine
wouldn't function until I did.

--


Regards,

Richard Urban
Microsoft MVP Windows Shell/User

Quote from George Ankner:
If you knew as much as you think you know,
You would realize that you don't know what you thought you knew!
 
G

Guest

Richard Urban said:
You didn't say if you installed the software for your USB 2 scanner. Mine
wouldn't function until I did.

I didn't say that specifically but I did say it was working only yesterday.
So yes, I have installed the scanner driver/software. I also uninstalled it
in device manager, then ran setup again for the driver/software. Same issue.

The weirdest thing to me is the three USB Root Hub entries in device
manager. I only have 8 ports available, but with the three USB Root Hub
entries it seems the computer thinks I have 16. 8 of which seem to show as
USB 1 and the other 8 as USB 2, but I can't plug a device in and get it to
show up as a device under the 8 that Windows thinks is USB2.

My USB2 card reader doesn't give me this message when I plug it in to the
JUSB1 connection on the motherboard, and it shows up as a device in the same
USB Root Hub as my scanner.

Even stranger I think the scanner is working at USB 2 speeds. It has a
firewire connection as well and when I plug it in using the Firewire cable it
functions just as fast as when plugged in via USB. Either I'm getting USB2
speeds even though the message is showing up, or my Firewire is really slow.
 
R

R. McCarty

Sorry to repeat myself, but there is a general misunderstanding about
USB. In most all PCs there is a single USB Enhanced controller. It
is internally routed to ALL sockets. Then in addition, there are also
Standard USB1(.1) hubs. So if your PC has 8 sockets, there will be
4 Standard USB controllers/Hubs in addition to the single enhanced
controller. As to your problem, I would probably unplug all the USB
peripherals. Add the System Environment variable:
DevMgr_Show_NonPresent_Devices
set it's value to 1.
Open Device Manager, Click View & tic/check "Show Hidden Devices:"
Uninstall everything in the Universal Serial Bus Controller category.
Then remove "Phantoms" from their appropriate categories (Except
for System/Sound/Non-Plug&Play. Then download and install the
latest Chipset driver package for your motherboard, Install & Reboot.
 
G

Guest

R. McCarty: I tried your suggestion of putting in the environment variable,
the removing phantom entries. There were a lot.

I "think" I tried turning on the scanner after doing that and got the same
message. I'm a little fuzzy on if I did that or not because I tried updating
my bios and it fried my system. I am no longer getting the machine to post or
even attempt to access the floppy drive during power-on.

So, I may never know if it actually worked. I will keep it in mind if I get
the machine back up and running.
 
Ad

Advertisements

G

Guest

OK. I'm back up and running without the errors when I turn on my scanner.

As noted in my other post my machine stopped posting or doing anything after
flashing my bios. I had to take the motherboard out of the computer, hook it
up externally and it booted. I flashed it again with an even newer bios, put
it back in the case and now everything is working correctly. I must have had
something shorting out, but it's a mystery why flashing the bios made it show
up.

Now when I turn on my scanner it shows up in the USB Root Hub entry in
Device Manager that Windows originally thought were my USB2 ports. My card
reader is also showing up there too. So hopefully I'll get better speed out
of both, or at least the speed I thought I was getting before this whole
thing started.

Thanks for the help.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top