usb plug and play devices


G

Guest

I have a mini usb mass storage device that has no driver. I used to plug it
with my windows xp and it shows right away. I know its a plug and play but
why does vista ask for a driver ? I need help because even my external hard
drive wont allow to connect it to my usb port !!!

Thanks !
 
Ad

Advertisements

C

Cal Bear '66

One quick and easy thing you could try is to plug in your USB devices, power
them on, and run Windows Update and check for new updates. Windows Update
"might" be able to detect and install USB updates.

There have also been a couple of hotfixes for USB problems.
 
G

Guest

duchchozen,

Perhaps you have a USB device driver recognition issue that can be resolved
by deleting the INFCACHE.1 file. It can get corrupted with bad data and
cause issues like you MAY have. The file is located at: C:\Windows\inf.
There, scroll down to the INFCACHE.1 file and right click it and select
delete. To do this, you will likely have to give yourself permission to
delete it, because of Windows built-in security. Just right click the file,
select Properties and then click on the security tab. Let us know whether
this procedure does anything. Sometimes it does and sometimes it doesn't. It
does no harm to delete that file, even when it has nothing to do with the
problem. Post back on results.
 
G

Guest

It seems every plug and play usb device I put in is asking for a driver...
Does everyone has this problem ? I bought my laptop from best buy and it suck
because it has remote access... does this affect my usb connections or my
programs ?

BTW... it didn't work... same ol' same ol '

Thanks anyway...
 
G

Guest

I downloaded it and its still the same

plug usb device
searches for driver
it only allows you to find the driver from your hard drive and not from the
internet
it searches for the closest driver available
then few mins. later, it goes back to search the driver
vista sucks....
 
Ad

Advertisements

G

Guest

cant take credit for this, it was posted in response to another queston by
Robert N. I tried it and it worked!!! Been working on this issue for several
days
Packman


Try this solution !!!

Re: USB Drive Problems with Vista
Was this post helpful ?



I believe that possibly during Vista installation, usbstor.inf (inf that
installs "USB Mass Storage Device") got corrupted or got accidentally deleted
from c:\Windows\inf. When usbstor.inf was restored to c:\Windows\inf and the
system was rebooted, the drives mounted normally again when the device is
plugged in.



There are two ways to get the usbstor.inf file

1. From another Vista system (copy it out of another Vista system and copy
it directly into the C:\Windows\inf directory)

2. If you only have 1 Vista system, run Command Prompt (Run as
administrator). From C:\ do a dir usbstor.inf /s . Wherever the file is
found, copy it to the C:\Windows\inf directory if it is missing from it. (I
remember it being in the driver store cache somewhere on the HDD)

Regards,

Rob


PS if you need a copy of the file you can have a friend email it to you but
make sure it's either zipped or change the file extension to .txt so your
email wont reject it then change it back to .inf and copy it............ Hope
this works for you too.

Packman
 
G

Guest

i have 7 files listed on my command prompt

c:\windows/softwaredistribution\download\

c:\windows\system32\driverstore\filerepository\

c:\windowswinsxs\x86_usbstor.inf

each file has 2 directories except for

c:windows\inf

any suggestions ?

thank you for helping me out guys !!!
 
Ad

Advertisements

G

Guest

I may be wrong but the driver does not seem to be the issue on my new
machine. If I have the Microsoft USB wireless mouse plugged in prior to
boot, it works fine. If I plug it in after booting, nothing at all
happens...it is like the machine does not even recognize that I have
installed a new device.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top