USB mass storage devices not working properly under XP SP3



I have a Samsung digital camera with 4GB SDHC card, Sandisk SDDR-89 Imagemate
12 in 1 reader and WD 2TB mirror external drive. Operation on USB is erratic.

Imagemate installs OK but XP does not recognise the card types so all
assigned drive are listed as 'removable disk. SD cards read OK but My
Computer freezes if a CF card is inserted. Response is hopelessly slow.

Samsung digital camera hung up during plug and play. It eventually installed
and I can get into the disk but clicking on any files freezes My Computer. In
any case response is very slow.

WD external mirror drive did not install correctly during plug and play. The
drive appears but indicates no volume.

All this hardware rund fine on a Vista machine. Both my XP machines exhibit
similar problems. I have tried updating all system drivers, bios and Windows.
I have checked all the hardware and it all seems to be OK. I have removed the
USB host controllers to force reinstallation of all the devices but no
change. I have ensured that all security applications are disabled and
repeated all the steps at least 6 times so far. My PC supplier is baffled and
everything points to a major problem with XP.
Other USB devices like keyboard, mouse, printer etc are working fine. The
problem only seems to be affecting mass storage devices. None of the affected
devices use manufacturers drivers. All of them are reliant on the native XP
USB drivers. Tried rolling back to SP2 but I doubt that I am getting a clean

I am out of ideas. Tried to buy some Microsoft technical support but the
online system will not accept any of my credit card numbers (how convenient).
So far I have racked up 100+ hours getting nowhere. Sandisk have told me that
Microsoft have an unresolved USB problem with SP3. Does anyone out there know

Leonard Grey

I have the identical card reader, and I can confirm that it works
perfectly on Windows XP SP 3. (The ImageMate software is unneeded and I
did not install it.)

To use the device I simply plug my SDHC card into the reader and then
plug the reader into a USB port. In a second or two the SDHC card shows
up in My Computer with a drive letter. To transfer images from the SDHC
card to my computer I simply drag and drop.

Did SanDisk explain the nature of the "unresolved USB problem with SP3"?
It's hard to diagnose a problem when the description is that vague.

For best results, plug the reader into a USB port directly on the
computer (i.e., do not plug into a hub.) If that doesn't work, try a
different USB port a or a different USB cable. Make sure all connections
are tight (including making sure that the SDHC card facing the right way
and is inserted all the way.)

Just about any card reader works the same way, so try a different card
Leonard Grey
Errare humanum est

"A Day in the Life of a Web 2.0 Hacker" - PC Magazine,2817,2330952,00.asp

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question