Urgent - RunAs stopped working in new disk images


Rick Corbett

I cannot get the RunAs command to work on recent Toshiba laptops.

Background info:
I create the Win XP Pro disk images at work where we only use hp/Compaq base
units and Toshiba laptops. Each disk image is setup with the default
Administrator account and a single Power User account. We do not allow Power
Users to access the Control Panel (so they find it more difficult to mess
things up). Most problems are resolved by the Help Desk using VNC to remote
in. To allow access to the Control Panel I've been using a script that lets
the remote Help Desk run CONTROL.EXE locally as Administrator (and similar
scripts to carry out other tasks as Administrator). The use of RunAs
continues to work well on hp/Compaq D510 and D530 desktops... but not on
recent Toshiba laptops. I'm experiencing problems with the Toshiba SP A10,
A30 and now A40 models, i.e. I just cannot get RunAs to work.

To test things out, I've tried using the same Windows XP Pro installation
media, the same script, running RunAs from a CMD prompt, a fresh image build
with no XP SP1a (nor any other Critical Update)... all with no luck.

I don't understand why, for example, using CMD, this command works on the
desktops but not on the laptops: runas /env /user:Administrator

The prompt for the Administrator password appears on both the desktops and
laptops. When I enter the password on the desktops... the Control Panel
appears as expected. When I enter the password on the laptops, I see the
same "Attempting to start control.exe as user "CHANGEME\Administrator"..."
as on the desktop but nothing happens. (We use CHANGEME as the computername
until they're out in use.)

Using a VBS script to run the same command works on the desktops but not on
the laptops... even though a MsgBox shows the same password is being sent
(i.e. to try to discount any differences in how Toshiba laptop keyboards
pass characters).

Does anyone have any ideas?

Rick Corbett

Oops, I forgot to add...

- The Secondary Logon service IS started.
- I've tried adding the computername, i.e. 'runas /env
/user:CHANGEME\Administrator' to no avail.
- When I enter the Administrator password I can see hard disk activity (so
something's happening) but that's all.
- CapsLock ISN'T on.
- The Administrator password uses only standard ASCII characters.
- Base units and laptops both use the same 'English (United Kingdom)'
settings for 'default input language' in 'Regional an Language Options'.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads

runas explorer /separate 2
RUNAS has stopped 3
Autologon=yes not working. 2
runas issue 5
runas - access denied 4
Runas to open Windows Explorer 2
Can't RUNAS appwiz.cpl 4
RunAs problem 2