Unblocking & Reading Certain Zip Files


B

Ben

Hi,

I have a user who runs IBM Business Modeler software, using this they create
business models and export them as ZIP files. The user is now trying to open
one of these ZIP files using the built in Windows XP zip tool, but windows
is telling the user that the file is blocked, and he needs to unblock it by
going to the files properties & clicking the unblock button. However this
button doesn't exist in the properties of the file. The user has sent me the
file, and I have tried, however I can't even see the contents of the zip
file, it appears blank, and there is still no unblock button in the
properties.

However, if I open WinZip, or WinRar, and try to open the file, I can see
all the contents, AND can extract them.

So, is this an issue with Windows, (we're running Win XP SP2, all latest
hotfixes & patches), or with the way IBM Business Modeler zips up the file,
I'm trying to find out more about the modeler zip process, i.e. what library
it uses, compression method etc (I've read Windows zip tool has problems
reading files compressed with sharpziplib).

Also, can anyone think of a way around this issue, without installing
winzip/winrar?

Many thanks

Ben
 
Ad

Advertisements

B

Ben

Hi NC,

Correct, on the zip files created by IBM Business Modeler there is no
unblock button under Properties. However other zip files, such as the latest
Broadcom network drivers I downloaded, and 99% of other zips, the button
does exist.

I'm trying to find out if this is a possible issue with the zip.dll file
found in the java runtime that ships with this IBM software. Although I
think it might be easier to do as you suggest and add all zips to a safe
list.

Do you know the reg key where this setting exists? I would use your little
program, but I'd like to roll this out company wide through group policy.

Many thanks

Ben
 
N

Newbie Coder

Ben,

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Association
s

Key Name: LowRiskFileTypes
Type: STRING
 
Ad

Advertisements

B

Ben

Hi Newbie,

I tried adding that registry setting to a group policy, however WinXP is
still blocking zip files. Here is an export of my setting:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Associations]
"LowRiskFileTypes"=".ZIP;"

I've also tried placing the same entry under
HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\Associations

And also tried upper & lowercase file extensions, & both together
"LowRiskFileTypes"=".ZIP;.zip;"

Any ideas why, or how I can get this setting working?

Cheers

Ben
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top