Unable to Change or Create File Associations


D

Daddy

I have Windows XP Home SP 3. I am unable to change or create file associations.

In Windows Explorer | Tools | Folder Options | File Types I cannot change file associations or create new file associations because the 'Apply' button is disabled (grey).

I am usually able to change a file association by right-clicking on a file and selecting Open With... but I cannot do this from File Types as described above. Even Doug Knox's .reg files (for those who are familiar) don't fix file associations.

How can I fix this? What's disabling the 'Apply' button in File Types?

Thanks for your help.

Daddy
 
Ad

Advertisements

R

Rich Barry

I have encountered the same issue, and have made an adjustment in the
registry to solve it.

It is a really good idea to back up the registry before you make any
changes....That being said, what I am suggesting as a fix will change the
ability for power or administrative users of your XP machine to modify the
'global' file associations.

1. As the local adminsitrator on your PC, Run 'regedit' tool and dial down
to
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer]
2. right-click on the NoFileAssociate key, and select modify
3. edit the "Value data:" field to 0 (zero)and select OK.
4. the NoFileAssociate entry should now be:
"NoFileAssociate" "REG_DWORD" "0x00000000(0)"
5. Close the registry editor tool
6. You may need to logoff and log back in to see the changes. Then modify
your file associations through the GUI as per usual. Your edit options
should no longer be grayed out.









I have Windows XP Home SP 3. I am unable to change or create file
associations.

In Windows Explorer | Tools | Folder Options | File Types I cannot change
file associations or create new file associations because the 'Apply' button
is disabled (grey).

I am usually able to change a file association by right-clicking on a file
and selecting Open With... but I cannot do this from File Types as described
above. Even Doug Knox's .reg files (for those who are familiar) don't fix
file associations.

How can I fix this? What's disabling the 'Apply' button in File Types?

Thanks for your help.

Daddy
 
D

Daddy

Hi Rich:

Thank you for your idea. The registry edit you mention is one I have read about elsewhere. I actually have that key in my registry and the DWORD is set to 0. Unfortunately, it makes no difference in my case.

Daddy
 
J

ju.c

Try re-installing the shell32.dll file:

Copy and paste this line into the Run box:
regsvr32.exe /i shell32.dll


ju.c


Daddy said:
Hi Rich:

Thank you for your idea. The registry edit you mention is one I have read about elsewhere. I actually have that key in my registry
and the DWORD is set to 0. Unfortunately, it makes no difference in my case.

Daddy

Rich Barry said:
I have encountered the same issue, and have made an adjustment in the
registry to solve it.

It is a really good idea to back up the registry before you make any
changes....That being said, what I am suggesting as a fix will change the
ability for power or administrative users of your XP machine to modify the
'global' file associations.

1. As the local adminsitrator on your PC, Run 'regedit' tool and dial down
to
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer]
2. right-click on the NoFileAssociate key, and select modify
3. edit the "Value data:" field to 0 (zero)and select OK.
4. the NoFileAssociate entry should now be:
"NoFileAssociate" "REG_DWORD" "0x00000000(0)"
5. Close the registry editor tool
6. You may need to logoff and log back in to see the changes. Then modify
your file associations through the GUI as per usual. Your edit options
should no longer be grayed out.









I have Windows XP Home SP 3. I am unable to change or create file
associations.

In Windows Explorer | Tools | Folder Options | File Types I cannot change
file associations or create new file associations because the 'Apply' button
is disabled (grey).

I am usually able to change a file association by right-clicking on a file
and selecting Open With... but I cannot do this from File Types as described
above. Even Doug Knox's .reg files (for those who are familiar) don't fix
file associations.

How can I fix this? What's disabling the 'Apply' button in File Types?

Thanks for your help.

Daddy
 
Ad

Advertisements

D

Daddy

Perhaps you meant re-register instead of reinstall?

In any case, that didn't work.

If I could figure out what is disabling the Apply button, I would have my answer.

Daddy

ju.c said:
Try re-installing the shell32.dll file:

Copy and paste this line into the Run box:
regsvr32.exe /i shell32.dll


ju.c


Daddy said:
Hi Rich:

Thank you for your idea. The registry edit you mention is one I have read about elsewhere. I actually have that key in my registry
and the DWORD is set to 0. Unfortunately, it makes no difference in my case.

Daddy

Rich Barry said:
I have encountered the same issue, and have made an adjustment in the
registry to solve it.

It is a really good idea to back up the registry before you make any
changes....That being said, what I am suggesting as a fix will change the
ability for power or administrative users of your XP machine to modify the
'global' file associations.

1. As the local adminsitrator on your PC, Run 'regedit' tool and dial down
to
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer]
2. right-click on the NoFileAssociate key, and select modify
3. edit the "Value data:" field to 0 (zero)and select OK.
4. the NoFileAssociate entry should now be:
"NoFileAssociate" "REG_DWORD" "0x00000000(0)"
5. Close the registry editor tool
6. You may need to logoff and log back in to see the changes. Then modify
your file associations through the GUI as per usual. Your edit options
should no longer be grayed out.









I have Windows XP Home SP 3. I am unable to change or create file
associations.

In Windows Explorer | Tools | Folder Options | File Types I cannot change
file associations or create new file associations because the 'Apply' button
is disabled (grey).

I am usually able to change a file association by right-clicking on a file
and selecting Open With... but I cannot do this from File Types as described
above. Even Doug Knox's .reg files (for those who are familiar) don't fix
file associations.

How can I fix this? What's disabling the 'Apply' button in File Types?

Thanks for your help.

Daddy
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top