Trouble with Microsoft IME (Typing Japanese on US Keyboard)


G

Guest

To recap:

I have a recently purchased HP Slimline desktop with Vista Home Premium for
my wife. She uses her computer to send e-mails, chat, etc. with her family
in Japan. Using my past experience with XP, I set this computer up so she
could use Microsoft IME to input Japanese characters. The problem? The
stupid thing thinks her US 101 key keyboard is actually a Japanese keyboard
and jumbles the keys around making it very annoying.

---

So far I have reinstalled Vista twice with no positive results. I was
finally at the end of my rope with Vista and I decided to test an install
with XP Media Center from my laptop. As soon as XP was installed in this HP
slimline, I went straight to configuring Microsoft IME and guess what... The
damn thing worked like a champ. No longer did the OS think I had a keyboard
I didn't actually have. No jumbled keys, just smooth sailing. Vista was the
culprit.

So, since I was confident that Vista was the problem, I sent an e-mail to
Microsoft tech support about it and even told them what happened when I
installed XP. Their answer? Ask HP. What the hell is HP going to do for
me, they didn't make Vista! I don't see any Hewlitt-Packard IME on my
keyboard options... do you?!

As soon as I can get some good drivers for this slimline, I'm throwing Vista
right out the window and putting XP back on, because THAT OS actually works.

Any new suggestions out there? Any work arounds, besides using an actual
Japanese keyboard?
 
Ad

Advertisements

S

Stephan Rose

To recap:

I have a recently purchased HP Slimline desktop with Vista Home Premium for
my wife. She uses her computer to send e-mails, chat, etc. with her family
in Japan. Using my past experience with XP, I set this computer up so she
could use Microsoft IME to input Japanese characters. The problem? The
stupid thing thinks her US 101 key keyboard is actually a Japanese keyboard
and jumbles the keys around making it very annoying.

---

So far I have reinstalled Vista twice with no positive results. I was
finally at the end of my rope with Vista and I decided to test an install
with XP Media Center from my laptop. As soon as XP was installed in this HP
slimline, I went straight to configuring Microsoft IME and guess what... The
damn thing worked like a champ. No longer did the OS think I had a keyboard
I didn't actually have. No jumbled keys, just smooth sailing. Vista was the
culprit.

So, since I was confident that Vista was the problem, I sent an e-mail to
Microsoft tech support about it and even told them what happened when I
installed XP. Their answer? Ask HP. What the hell is HP going to do for
me, they didn't make Vista! I don't see any Hewlitt-Packard IME on my
keyboard options... do you?!

As soon as I can get some good drivers for this slimline, I'm throwing Vista
right out the window and putting XP back on, because THAT OS actually works.

Any new suggestions out there? Any work arounds, besides using an actual
Japanese keyboard?

I recall having a conversation with someone else in this very newsgroup
with the identical problem to yours.

We came to this conclusion:

マイクロソフã¨ã¯ã°ã‹ã§ã™ã€‚

The only keyboard combination that I am aware that works correctly under
windows with the Japanese IME is XP and US Keyboard, as you have
discovered. Try using an actual Japanese Keyboard under XP, it's a
nightmare. One day it's Japanese, next day it might be Chinese, the day
after that it might be recognized as US....trying to use a non-US keyboard
with XP and its Japanese IME is a nightmare.

I suppose that by the sound of it MS did actually fix this with Vista at
the cost of now requiring a Japanese keyboard which is equally ridiculous.

There actually is a way to fix it, though it's more difficult under Vista
than it is under XP.

The way to fix the problem, under either operating system, is to replace
the keyboard driver .sys files in the windows/system32 directory.

So in your case, you'd want to replace the japanese keyboard .sys file
with the US keyboard .sys file and you'd be good to go.

This is pretty easy to do in XP, but from what the other poster reported
back, not so easy under Vista as it doesn't like you messing with its
files there. So you need to somehow take ownership of the keyboard driver
files to be able to replace them like that.

That's about the only solution I know. Beyond that, I can only suggest
using a more multilingual friendly OS.

--
Stephan
2003 Yamaha R6

å›ã®ã“ã¨æ€ã„出ã™æ—¥ãªã‚“ã¦ãªã„ã®ã¯
å›ã®ã“ã¨å¿˜ã‚ŒãŸã¨ããŒãªã„ã‹ã‚‰
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads

Vista Japanese IME Problem 6
Japanese IME shift-problem 1
Using Japanese IME 4
global ime Japanese 1
Japanese IME 2
English/Japanese keybord - trouble 3
Keyboard Problems 2
hold or fold? 6

Top