Japanese IME shift-problem


J

JonnyHilly

WE purchased a new HP PC with Windows Vista Premium.
Turned on Japanese IME, the same was we use on our XP PC's
But discovered there is some kind of bug, that Vista thinks you are using a
Japanese keyboard, even though using US keyboard with IME.
So everytime you press SHIFT... the wrong character is displayed.

This is infuriating as you can imagine.
We did the full 9 yards with HP support, who have no idea. We doubt its a HP
issue. Looks like a Vista issue.

We did find a couple of other posts elsewhere where people had a similar
problem.

Is this a known issue that will be fixed in an upcoming update soon ?

Does MS have a temporary fix for this problem ?
or shall we just go back to XP ?
 
Ad

Advertisements

J

Joshua

Don't remove Vista just yet! I know your pain and also removed Vista to find
that XP wouldn't run correctly on my HP Slimline so I learned to live
inputing Japanese on a US keyboard that thought it was a Japanese keyboard.

There is a problem with Vista. Seems Vista has problems recognizing your
keyboard. If you're using a US 101 key keyboard with Japanese IME, Vista
instead says it's a 106 key keyboard and therefore you get the characters
assigned to keys that aren't supposed to be there.

The solution is editing your registry to trick Vista into thinking the 106
key keyboard is a 101 key keyboard. Microsoft has a page that instructs in
detail how to do this. I have done this procedure and after reboot, Vista no
longer gives me problems and thinks I'm inputting Japanese from a US keyboard.

Follow this link:

http://support.microsoft.com/kb/927824

Don't forget to reboot and I hope this helps you. I've been stumped by this
stupid problem for almost a year...
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top