The destination server is currently rejecting replication requests


Y

yoshi

Hi, I am having Ad problem with the error " The destination server is
currently rejecting replication requests" and I cannot fix it. please help
me out.

<server info>
domain: domain.com (single domain0
DCs: 6 DCs (all are windows 2k with sp4)

<story>
1. The Main DC1 (which had all FSMO roles) had a HDD failure(RAID1) and
replaced 1 new HDD. But unfortunely i've got boot sector error, and ended up
never boot it up anymore.

2. so I shutdown and gave up. Instead, I added another server(win2k) as new
DC and seized all FSMOs on new DC. It appeared that all seize command were
successful. But two of DCs failed to replicate with new one and started to
give me an error above (even though other DCs are replicated and updated.)
OLD PDC -> does not boot, so shutdown
NEW PDC -> seize FSMO and have all FSMO.
Two DCs do not repliate with new one.

3. Interesting thing is that, I looked at "AD users and computer" on one of
failed DCs, and looked at "operation master" property, it shows that it's
pointing to new PDC. However, from NTDSUTIL command("list roles for
connected server"), it shows that it still pointing to old PDC!! How that
happens???? Other failed DC has the same results.
From GUI -> two failed DCs point to new PDC.
From NTDSUTIL -> two failed DCs point to old PDC.

What should I fix? Please help.

Yoshi
 
Ad

Advertisements

Y

yoshi

did you in ANY way use images (or something similar) somewhere

What that means? Restoring?
I tried to restore from Tape Media many times, but I could not.

New DC has now all FSMO roles except GC.

But it cannot replicate still.. any idea?

Yoshi
 
J

Jorge de Almeida Pinto [MVP]

if you for example restored a DC from an image (or broke a RAID 1
configuration, booted the DC, shutdown/crash, and then insert the other part
of the RAID1 config) you will experience USN rollbacks. If you have a
certain hotfix installed it will most likely detect that and disable
replication on the offending DC and pause the netlogon service

any event IDs with warnings/errors?

if it is rejecting replication it has a reason!

--

Cheers,
(HOPEFULLY THIS INFORMATION HELPS YOU!)

# Jorge de Almeida Pinto # MVP Windows Server - Directory Services

BLOG --> http://blogs.dirteam.com/blogs/jorge/default.aspx
 
A

Ace Fekay [MVP]

In
yoshi said:
What that means? Restoring?
I tried to restore from Tape Media many times, but I could not.

New DC has now all FSMO roles except GC.

But it cannot replicate still.. any idea?

Yoshi
In addition to Jorge's questions, did you also run a Metadata Cleanup to
remove the original DC's reference and existence in AD?

Metadata Cleanup:
http://support.microsoft.com/default.aspx?scid=kb;en-us;216498

--
Ace

This posting is provided "AS-IS" with no warranties or guarantees and
confers no rights.

Having difficulty reading or finding responses to your post?
Instead of the website you're using, I suggest to use OEx (Outlook Express
or any other newsreader), and configure a news account, pointing to
news.microsoft.com. This is a direct link to the Microsoft Public
Newsgroups. It is FREE and requires NO ISP's Usenet account. OEx allows you
to easily find, track threads, cross-post, sort by date, poster's name,
watched threads or subject.

It's easy:
How to Configure OEx for Internet News
http://support.microsoft.com/?id=171164

Ace Fekay, MCSE 2003 & 2000, MCSA 2003 & 2000, MCSE+I, MCT, MVP
Microsoft MVP - Directory Services
Microsoft Certified Trainer

Infinite Diversities in Infinite Combinations
Assimilation Imminent. Resistance is Futile
"Very funny Scotty. Now, beam down my clothes."

The only thing in life is change. Anything more is a blackhole consuming
unnecessary energy. - [Me]
 
F

Fadi Awad \(MSFT\)

Please run "repadmin /options" on the DC and examine the output. if the
"DISABLE_OUTBOUND_REPL" option is on, you need to disable it using the same
command.

Thanks,
Fadi Awad [MSFT]
This posting is provided "AS IS" with no warranties, and confers no rights.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top