The application failed to initialize properly (0xc0000005)


Frank Saunders, MS-MVP OE

Export the key and then delete it. No one has yet posted a reason to keep

Frank Saunders, MS-MVP OE

Bryn said:
I too have been having problems with IE, only I get the "failureto
initialize" error message when I try to shut down my PC instead of
when I try to start IE. I discovered after sending error reports to
Microsoft that it is IE- associated, and supposedly they are working
on a solution but none found yet. After reading your posts, I'm
wondering if this could be solved by deletion of the file you
mentioned, or if anyone out there has any suggestions, I'd be


Bruce said:
I had this same problem and was able to fix it with much searching
using debugging tools. I fixed it by deleting the following
registry key:


Be sure to make a backup of any key before you delete it just in


My copy of IE stopped working on Dec 12th. Seems like the first reports of
this problem date from about Dec 10th (2005).

Spybot found nothing. Reinstall didn't help. Windows Update is broken. Runs
fine in Safe Mode.

Solution is to delete the RPCKDM key as described. (Doesn't even require a

Here are the contents of the RPCKDM registry key on my machine:


Sure would be nice if someone could figure out where this is coming from.

Would also be nice if someone could post this solution in the Microsoft
Knowledge base and also somewhere that Google can find it. (It took me two
weeks to find this thread. Good thing my Mac Mini kept working.)

Alan Edwards

Some of us are probably hoping that one of those afflicted can tell us
what they did to get the problem, but nobody seems to be able or
There must be something else apart from the RPCKDM key involved in
this suspected malware.


Joe Varga

Community, I too have a problem with my computer, not exactly like Mike's.

When I reactived my pc from sleep-mode my desktop was changed from the pic
to solid blue. Every time I try to play a video clip from thehun I get the
following error meassage

"Windows Media Player cannot play the file. If the file is on another
computer, verify that you are connected to the network. If you typed a path,
verify that it is correct. If the problem persists, the server might not be

I am new to the site, and any advice would be greatly appreciated.


Joel F holmes

Hiya folks,

Well for Joe's issue I think you might have SmitFraud.C or something simular.
I got this Trojan some how, and it screwed up MediaPlayer. It can also
change ans lock your desktop settings. To remove this virus use Meathod 1
posted by Grinler at the web site below.

With luck you will be able to remove it like I did.

Now as to this RPCKDM Registry thing. I have this listed registry entry,
but I can use IE6 fine with no issues. I will export and send this Reg file
to those that asked in hopes it might help yall out. Another thing is some
seem to have issues with Windows Update not working. Check out the article
about "MICE" here.

"MICE" can change your settings and disable your ability to use the Windows
Update site. After applyin the "unofficial" patch I was able to use Windows
Update normally again. Hope this might help.


glenn morris

I am having the same problem as desrcibed above. This started occurring in
May of 2006. When I search the registry, I can not find the referenced key.
Is there another key that I should be removing ?

Glenn Morris

glenn morris

...... nevermind !! I fixed the problem by doing a system restore to a few
days earlier at a point when I know the problem did not exist. That cleared
everything up !!

Matt P

I seem to have the same problem. The application failed to initialize
properly (0xc0000005) comes up as soon as I start my computer. Then only my
backgrund is there and I have to navigate through Task Manager. I looked
for that key suggested in the registry to delete but the nearest I have is
RpcSs. Any ideas?

andre lacouture

Please HELP... I have also looked... and looked... Can't find also...

Thanks... Andy

Kevin Wingrave

I get the same error message but I think my situation is a bit different.

I have a Dell Dimension XPS R desktop, with an Intel chip, recently upgraded
to XP SP3.
My sound has not worked for over a year (Soundblaster Audigy 2 XS). (dont
know if it is involved in the problem, but some posts cite it as a problem)

Internet Explorer 7 - works fine - no problems.

The problem is that recently Ive noticed that the machine has been getting
slower and slower. This sometines happens when it has not been rebooted for
many weeks.
Following reboot and on startup after user login, I got the above error
0xC0000005 on program userinit (twice). After starting Task Manager and
manually starting Explorer.exe it proceeded to commence the startup
procedures (ie start programs in the registry and in the startup folder),
each of which got the same oxC0000005 error message, (although many have
appeared to startup).

I attempted to run the adaware, spybot,hijackthis etc all getting the error
message, basically nothing worked.
Did a system restore to 3 days ago - the system restore facility wont go
back to any previous months even though I installed SP3 about 6 weeks ago,
and rebooted about 4 times.
After system restore rebooting which started up the machine without any
error messages, I was able to run adaware, spybot, hijackthis - but they only
detected what appears to be minor problems which were cleaned.
Reboot again and the same thing - userinit failed to initialise, manual
start of explorer.exe, other startup program failures.

Decided to uninstall SP3 - go to Control panel and all I get is an
0xc0000005 on rundll32 for everything.

Many other programs also fail ie Adobe acrobat, reader etc.
However IE7 does work - I am able to download MS patches fixes, but cannot
install them - you guessed it - same error message.

I feel that my last resort is to Format and reinstall everything from
scratch, but have run out of ideas to try, so before I get too drastic I'm
trying here.

If anyone has some more ideas of what is going on - I'd be very greatful to
read them.



I got the same issue, but when I look for the RPCKDM, I see that I don't have it. How would you fix it in this case?

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question