SUS - Client install


Yonis Smith


I've setup my lovely MS SUS Server (version 1, sp1). Its
synconising fine, and all is well, other than the fact
that I have to approve updates even when I've told it

I download the client to test all is well. My client PC
is running Win2k SP4. Can you guess what's coming? As
soon as I run the SUS Client, the following error message
arrives: -

Title: Microsoft Windows Update Auto Update
Body: Microsoftw Windows Update Auto Update requires
Windows 2000 SP2 or Windows XP.

NO! It's not OK, but it forces me too!

Do I really need to uninstall Win2k SP4, then install
Win2k SP2, then use Auto Update to patch me to SP4 only to
be told that it doesn't work with that?!??

Any ideas?



It is OK.

The client is already installed with SP3 and greater, that is why it
won't install.

To configure:

1. You will need the WUAU.adm file that describes the new policy
settings for Automatic Updates. WUAU.adm is automatically installed into
the %windir%\inf directory when you install Automatic Updates.
2. You can load %windir%\inf\wuau.adm as an administrative template
in the Group Policy Object Editor:
3. Click Start, and then click Run.
4. Type GPEDIT.msc to load the Group Policy snap-in.
5. Under Computer Configuration, right-click Administrative
6. Click Add/Remove Templates, and then click Add.
7. Enter the name of the Automatic Updates ADM file:
8. Click Open, and then click Close to load the wuau.adm file.
Once it is loaded, you will be able to configure policy settings for
Automatic Updates.

Once installed, go to Computer Configuration - Administrative Templates
- Windows Components - Windows Update

Under "Specify Intranet Microsoft Update Service" you can put in the
address of your SUS server.

This is from the SUS Deployment Guide. I had the same issue you did,
until I found the above. Once I performed the configuration, SUS worked



You do not need to install the client you downloaded. It
is apart of SP2 and later. Configure you client this way.

From the start menu go to run and enter "gpedit.msc"
This will open the group policy editor
From the Local Computer Policy
Computer Configuration
Right click Administrative Templates. Then left
click "Add/Remove Templates"
Then click the Add button
Select the wuau.adm template.
Next close the Add/Remove Templates windows.
Double click Windows Components folder
then, double click Windows update folder.
Double click "Configure Automatic Updates"
Select "Enabled"
Choose how you want automatic updating to work:
2 = Notify for download and install
3 = Auto download and notify for install
4 = Auto download and schedule to install
If you choose 4 then schedule the install time
Click the Next Policy button
"Specify intranet Microsoft update service location"
Choose "Enabled"
Set the intranet update service for detecting updates
Set the intranet statistics server
click Next Policy and choose
"Not configured" for "Reschedule Automatic Updates
scheduled installations"
Click Next Policy
"No auto-restart for scheduled Automatic Updates
choose "Enabled" if you don't want the computer to reboot
or "Not configured" if you want it to reboot.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question