StyleRef Formatting Frustrations


D

Dax Arroway

OK, this is driving me friggen nuts! I'm hoping someone can please help.

I have a form (Word 03) that I'm trying to use sbarnhill's SytleRef trick
with. The Useful StyleRef tricks page is:
http://sbarnhill.mvps.org/WordFAQs/StyleRef.htm#FormField
because I want to insert a Name field (client entered) and Date field
(client entered) into the footer. So far so good. I did all of the
instructions and everything works --except-- the formatting of the form
fields turn from my Normal Style Font (Arial 10pt.) to MS Gothic and I can't
figure out why or how to fix it.

I've tried switching the Style Type to Paragraph and it still changes to MS
Gothic when the style is applied to the form field. I tried deleting it and
reformatting it by entering Arial into the Formatting field ofthe New Style
dialog--still MS Gothic. And it gets weirder! If I insert a form field,
just a normal one, and apply the Normal Style to it, it changes to MS Gothic
Font even though it was all ready Normal Style in the first place! AAHHHH!!
Am I going crazy or what? Does anyone have any clue as to what the heck is
happening with this form? Where is the MS Gothic Font coming from? It's not
in any of my Styles or Normal.dot. Grrrrr.

Would someone kindly tell me where this might be coming from? 'Cause I'm
about to through my monitor out the window! I know that won't fix my problem
but it sure would feel good! I'm sure some of you know what I'm talking
about! Anyway, if any Gurus out there could please come to my rescue, I sure
would appreciate it. Much much thanks in advance!
Best,
Dax
 
Ad

Advertisements

S

Suzanne S. Barnhill

Are you using a paragraph or character style? If the latter, you should base
it on Default Paragraph Font, and you shouldn't see this issue. If it's a
paragraph style, what style is it based on?

FWIW, I've never even heard of MS Gothic.

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
http://word.mvps.org
 
P

Peter T. Daniels

MS Gothic is a Chinese font. In your Style(s) > Font, is there an
entry area under "Asian fonts"? If MS Gothic is chosen there, see if
you can change it to something innocuous like Arial or TNR.

There's a third area for a default font, called "Complex," which
covers Arabic/Hebrew and Indian fonts. You should also be able to make
that one Arial or TNR, too.

Presumably those two extra areas are only shown if your computer has
its Asian and Complex abilities turned on (mine were from the
beginning, so I don't know what it looks like without them.)
 
D

Dax Arroway

Ms. Barnhill herself! WOW! Thanks for coming to my rescue. I'm honored.

I'm using a character style. Funny thing is when I simply insert a form
field its Normal Style (Arial) but if I apply the Normal Style to the form
field, it switches to MS Gothic. If I insert the field and clear the
formatting (CTRL+Spacebar) it switches to MS Gothic. This leads me to
believe that there's an underlying Font field imbeded within the document
somewhere or somehow. I even changed the Default Font by using the Font
dialog box and selecting the Default button but this doesn't fix it.

PS: I don't even have MS Gothic on this machine. MS Gothic, or whatever
it's defaulting to... is ugly!
--
I would give my left hand to be ambidextrous!


Suzanne S. Barnhill said:
Are you using a paragraph or character style? If the latter, you should base
it on Default Paragraph Font, and you shouldn't see this issue. If it's a
paragraph style, what style is it based on?

FWIW, I've never even heard of MS Gothic.

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
http://word.mvps.org
 
D

Dax Arroway

Actually, I do have MS Gothic on my machine. My bad. But it's not a Chinese
font, it's English characters. I'm not sure where Styel(s)>Font is! In
Tools>Styles and Formatting, when I click it the Styles and Formatting pane
comes open and I don't see anywhere in any of my styles where there's
anything that says Asian Fonts or Complex and I'm not sure where to look.
Can you be a bit more specific? I'm using Word 03 on a WinXP machine if that
helps. --Dax
 
D

Dax Arroway

I could upload the file to my server and post a link to it if that's helpful.
Here, just in case, I'll upload it to:
http://www.awablue.com/506xTransferSummary.dot
If that at all helps.
--
I would give my left hand to be ambidextrous!


Suzanne S. Barnhill said:
Are you using a paragraph or character style? If the latter, you should base
it on Default Paragraph Font, and you shouldn't see this issue. If it's a
paragraph style, what style is it based on?

FWIW, I've never even heard of MS Gothic.

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
http://word.mvps.org
 
Ad

Advertisements

D

Dax Arroway

I found Microsoft Office 2003 Language Settings under Start\All Programs\MS
etc. etc. and the only language I have installed is English.
 
P

Peter T. Daniels

All the Chinese fonts have a full set of Roman letters (and lots of
stuff that doesn't appear in regular Roman fonts), and MS Gothic is
probably installed automatically.

Choose a style in the S&F panel, right-click, and choose Modify, and
in the panel that appears click Formatting > Fonts. You get the same
panel you see with Format > Fonts when you're out in your document,
and that's where you can change the fonts in case MS Gothic is the
Asian default (if Asian is enabled in Windows).

Or, you could simply uninstall the MS Gothic font by going to the
Fonts area of Start > Control Panel.
 
P

Peter T. Daniels

Aha! Ctrl-Spacebar is the Windows command to switch to the Chinese
IME, and it overrides Word's "clear formatting" command -- you have to
use Ctrl-Shift-Z to clear formatting in Word. (Changing the Windows
keyboard shortcut for switching to Chinese -- in the Regional and
Language Settings part of Control Panel -- does _not_ stick.)

Which means that Asian typing is enabled on your computer.
 
S

Suzanne S. Barnhill

I think Peter has identified some of the key issues involved. In the past,
similar issues have been associated with form fields converting to MS Mincho
(a Japanese font), which is equally infuriating, and I have had this happen
even outside of fields when using Ctrl+Spacebar on some characters that I
believe are (covertly) drawn from Arial Unicode MS (en and em spaces). I
don't have any Asian language enabled, either, so it is puzzling why this
happens. I know that MS (or at least some people at MS) are aware of issues
of this type because I've submitted problem documents where this sort of
thing was happening.

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
http://word.mvps.org

Dax Arroway said:
Ms. Barnhill herself! WOW! Thanks for coming to my rescue. I'm honored.

I'm using a character style. Funny thing is when I simply insert a form
field its Normal Style (Arial) but if I apply the Normal Style to the form
field, it switches to MS Gothic. If I insert the field and clear the
formatting (CTRL+Spacebar) it switches to MS Gothic. This leads me to
believe that there's an underlying Font field imbeded within the document
somewhere or somehow. I even changed the Default Font by using the Font
dialog box and selecting the Default button but this doesn't fix it.

PS: I don't even have MS Gothic on this machine. MS Gothic, or whatever
it's defaulting to... is ugly!
 
D

Dax Arroway

Hi Peter,
Thanks for the input. That's just the thing though. On my machine at work
(Word07) I don't have MS Gothic installed and from following your
instructions S&F>RightClickOnAStyle>Modify>Format>Font I see nowhere where
there's anywhere where I can set an Asian Font and Arial is listed as the
default font. Same with my computer at home (Word03)

When I go to S&F>RightClickOnAStyle>Modify>Format>Language the only Language
that's set is English. I can see where I can add different fonts, but none
of them are selected. (Maybe becaues they're listed does that mean that
they're installed because they're available but if it weren't available on
other client's machines [because i'll be putting this file out on the server
for others in my company to use--03 and 07 users] that this would default to
something else and continue to be a neusance instead of reverting back to
Arial?

Also, when I insert a Text Form Field into the document, it works fine and
stays Arial but when I create a character style and apply it to the field,
that's where it changes to this MS Gothic, which obviously is continuing to
drive me NUTS!

So it doesn't seem that I have other languages turned on anywhere and I'm
not sure how the settings on my computer will affect a .dot when it's
uploaded to the server but do you see any other ways of controling this
behavior or am I just SOL and will have to live with it?

--Dax
 
Ad

Advertisements

L

Lene Fredborg

In the past, similar issues have been associated with form fields converting
to MS Mincho

I don’t have any Asian language enabled, either. In Word 2003, when I use
Ctrl+Spacebar (which runs the ResetChar command as does Ctrl+Shift+Z), the
font of the form fields here change to MS Mincho. I have created a lot of
forms and the problem is rather annoying. However, resetting the form fields
(e.g. using Reset Form Fields in the Forms toolbar) corrects the problem here
and reverts the form fields to the correct formatting.

MS Mincho is also erroneously applied if I apply a character style to a form
field. Resetting the form fields also cures that problem here. Maybe it will
work for you too, Dax.

I have just checked in Word 2007 and the problem seems to be gone there. I
am inclined to use Word 2003 whenever possible but maybe I will use Word 2007
for forms from now on…

By the way, I am ambidextrous ;-)

--
Regards
Lene Fredborg - Microsoft MVP (Word)
DocTools - Denmark
www.thedoctools.com
Document automation - add-ins, macros and templates for Microsoft Word
 
D

Dax Arroway

Oh so totally close! So, thinking that I'd just scrap the whole thing and
start from scratch I decided to practice on a blank doc first. Open New>
Insert Text Form Field> Create New Character Style> Apply Character Style to
Form Field> yep, changes to MS Mincho on this machine (home--Word03)> apply
Form Reset (that works)> insert StyleRef into Header> Lock the Form> Test,
and then... What happens is the first word, whether it's one character or
20, is formatted with the MS Mincho font and the following words, after the
first space, is formatted with my Normal Paragraph Font. *sigh*

I don't think other languages are installed and I'm not sure where to go to
check. I tried uninstalling both MS Mincho and MS Gothic and my PC says it
can't uninstall them cause another program is using it (not sure which).
I'll reboot in safe mode and see if I can get rid of them and try this again.
 
S

Suzanne S. Barnhill

Can you add a CharFormat switch to the form field and/or StyleRef field?
Though that might actually do just the opposite of what you want. <sigh>

--
Suzanne S. Barnhill
Microsoft MVP (Word)
Words into Type
Fairhope, Alabama USA
http://word.mvps.org
 
D

Dax Arroway

Nope. That didn't work. Anomoly remains (it's just Arial Unicode MS now
instead of MS Micho or MS Gothic)

How about any help getting rid of the Chinese IME that Peter mentioned? I
dunno, I'm at a loss here. --Dax
 
D

Dax Arroway

I'm not sure which switch that would be or if it's possible. Switches I see
available are \l \n \p \r \t and \w all of which do not control characters.
Is there one that I can add?
 
Ad

Advertisements

S

Stefan Blom

STYLEREF field supports formatting switches but, as far as I know, form
fields do not.

More importantly, however, in recent versions of Word, form fields and font
formatting may be difficult for the reason explained in the following KB
article: http://support.microsoft.com/kb/828501/en-us ("Incorrect font is
applied after a style is applied to a form field in Word 2007 or in Word
2003").
 
D

Dax Arroway

I read the article and tried making internation languages and language
unavailable but the issue still remains. This wouldn't change anything, I'm
thinking, because if it were open by another on the server (form is a .dot
available to the company) then what was installed and turned on on the user's
machine would dictate.

What's the CharFormat switch for the StyleRef?
 
S

Stefan Blom

You are right, of course: changing the template won't help with existing
documents.

To add the CHARFORMAT switch to a STYLEREF field, press Alt+F9 to display
field codes. You will see something like this:

{ STYLEREF "style name here" }

Add \* CHARFORMAT at the end of the field code. (If you see \* MERGEFORMAT,
delete it.) Font formatting applied to the field (or actually to the first
character of the field code) will then determine the formatting of the field
result.
 
Ad

Advertisements

P

Peter T. Daniels

That one's easy. If you're in Word2003, you're probably in Windows XP?
If so, go to Start > Control Panel > Regional and Language Settings;
IIRC when you choose the Language tab, you'll see a panel with two
check boxes in the lower part, one for Complex Scripts (that means
Hebrew/Arabic/Indic) and one for Asian Scripts. Uncheck the latter.
(Or both,.)

In Vista, the tab is Keyboards and Languages. Go to the Keyboards
section and Remove/Delete the Chinese(/Japanese/Korean) keyboard(s).

You could also uninstall the Arial Unicode font, but then you probably
wouldn't be able to read all that Taiwanese spam.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top