Star Trek Generations on XP


K

Kracko

Does anyone know how to get Star Trek Generations to work
on XP? I know that Microsoft released a patch for Win
2000 to allow it work on that OS and that in their
Compatibility Application Toolkit, there's a description
of a compatibility fix (although my attempts to apply it
didn't seem to work; mind you, I'm not sure I understood
HOW I was supposed to do it!). As such, I'm SURE there
is a way to get it to work.

Anyone have the answer?

Kracko.
 
Ad

Advertisements

J

Jimmy S.

Hi Kracko,

Try installing STG using either 95 or 98 compatibility mode...

To install a program using Windows XP's Compatibility Mode, hold
down SHIFT as you insert the game CD, use My Computer to browse
to the setup program, and then skip down to step 1 in the list below:

To run an installed program using Windows XP's Compatibility Mode,
first right click the program and "Send To..." / Desktop (create shortcut).

1.. Right click on the shortcut to the program.
2.. Click on Properties.
3.. Click on the Compatibility tab.
4.. Click on Run this program in compatibility mode and select one of these:
a.. Windows 95
b.. Windows 98
c.. Windows NT 4
d.. Windows 2000
5.. Under Display settings, check mark the mode that you think that is best:
a.. Run in 256 colors.
b.. Run in 640 X 480 screen resolution.
c.. Disable visual themes.

Click on Apply.Click on Ok.Double click on the program.

Of course, let's not forget to check for any patches or updates for that game.
A good place to look is: http://www.fileplanet.com/section.aspx?s=174&v=90002

For more details please review the source at:
http://support.microsoft.com/?kbid=292533

--
Cheers,
Jimmy S.

Additional Support Resources: My Zone.com Helpsite: http://nibblesnbits.tk
Microsoft Online Tech Support: http://go.microsoft.com/fwlink/?LinkId=376
Game FAQ's: http://support.microsoft.com/default.aspx?scid=FH;[LN];gms
My advice is donated "AS IS" without warranty; nor do I confer any rights.
_________________________________________________________

| Does anyone know how to get Star Trek Generations to work
| on XP? I know that Microsoft released a patch for Win
| 2000 to allow it work on that OS and that in their
| Compatibility Application Toolkit, there's a description
| of a compatibility fix (although my attempts to apply it
| didn't seem to work; mind you, I'm not sure I understood
| HOW I was supposed to do it!). As such, I'm SURE there
| is a way to get it to work.
|
| Anyone have the answer?
|
| Kracko.
 
K

Kracko

Hi Jimmy,

The problem with the game is not installing it. The game
installs fine and even begins no problem. After the long
intro, the game is supposed to prompt you to change from
Disk 1 to Disk 2. However, what happens is that the game
simply shuts down; there is no error message, no mimized
window. Even if I restart the game after this, it simply
happens again. The problem really seems to be getting XP
to recognize the game prompt for switching CDs rather
than shutting down.

If anyone had a similar problem with another game, I'd
really like to know if you found out how to fix this.

Thanks,

Kracko.

-----Original Message-----
Hi Kracko,

Try installing STG using either 95 or 98 compatibility mode...

To install a program using Windows XP's Compatibility Mode, hold
down SHIFT as you insert the game CD, use My Computer to browse
to the setup program, and then skip down to step 1 in the list below:

To run an installed program using Windows XP's Compatibility Mode,
first right click the program and "Send To..." / Desktop (create shortcut).

1.. Right click on the shortcut to the program.
2.. Click on Properties.
3.. Click on the Compatibility tab.
4.. Click on Run this program in compatibility mode and select one of these:
a.. Windows 95
b.. Windows 98
c.. Windows NT 4
d.. Windows 2000
5.. Under Display settings, check mark the mode that you think that is best:
a.. Run in 256 colors.
b.. Run in 640 X 480 screen resolution.
c.. Disable visual themes.

Click on Apply.Click on Ok.Double click on the program.

Of course, let's not forget to check for any patches or updates for that game.
A good place to look is: http://www.fileplanet.com/section.aspx?s=174&v=90002

For more details please review the source at:
http://support.microsoft.com/?kbid=292533

--
Cheers,
Jimmy S.

Additional Support Resources: My Zone.com Helpsite: http://nibblesnbits.tk
Microsoft Online Tech Support: http://go.microsoft.com/fwlink/?LinkId=376
Game FAQ's: http://support.microsoft.com/default.aspx? scid=FH;[LN];gms
My advice is donated "AS IS" without warranty; nor do I confer any rights.
_________________________________________________________

| Does anyone know how to get Star Trek Generations to work
| on XP? I know that Microsoft released a patch for Win
| 2000 to allow it work on that OS and that in their
| Compatibility Application Toolkit, there's a description
| of a compatibility fix (although my attempts to apply it
| didn't seem to work; mind you, I'm not sure I understood
| HOW I was supposed to do it!). As such, I'm SURE there
| is a way to get it to work.
|
| Anyone have the answer?
|
| Kracko.


.
 
J

Jimmy S.

Hi Krako,

Fair enough, if the installation went well there's no need
to use compatibility mode to install the game. Have you
tried playing the game using compatibility mode as well?

--
Cheers,
Jimmy S.

Additional Support Resources: My Zone.com Helpsite: http://nibblesnbits.tk
Microsoft Online Tech Support: http://go.microsoft.com/fwlink/?LinkId=376
Game FAQ's: http://support.microsoft.com/default.aspx?scid=FH;[LN];gms
My advice is donated "AS IS" without warranty; nor do I confer any rights.
_________________________________________________________
 
Joined
Mar 10, 2011
Messages
1
Reaction score
0
I have the same prob as Kracko, and I have tried running the game in compatibility mode. This allowed me to run the game, but as Kracko said, it shuts down when you enter he space station thingy. I suspect he was running the game in compatibility mode already as I am running xp and I couldn't even get the game to run without using compatibility mode. Any more suggestions?
 
Joined
Jun 13, 2012
Messages
2
Reaction score
0
You can actually get the game to work. Run it in compatibility mode for windows 95, 640x480 resolution mode, when the mission launches to the screen of the amargosa station click the screen frantically with your left and right mouse buttons. I know this sounds crazy but one day I was so mad about it not working I just started doing that and sure enough it worked. It has something to do with the dx 3.0 drivers. By going "click crazy" it seems to override it and it keeps the application active rather than killing it. I'm not sure if this trick might also work on win 7 or vista but it might, going to try that next. Kill Soran for me.

Daniel
 
Ad

Advertisements

Joined
Jan 18, 2017
Messages
1
Reaction score
0
Hi, I managed to do it:

1. you need to do ISO images of both ST discs
2. download daemon tools 3.47 and install it
3. you will get new icon next to clock on task bar
4. change number virtual drives to 2
5. mount first disk ST iso image to first drive
5. mount second ST iso imgae to first drive
6. run game in compatibility mode.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top