Solved: Failed to initialize after GPO installation



I'm fairly sure I've solved this and it turns out it's a bit of a none issue.
Here's what I think is happening. As I'm sure most are aware there are
three phases of installation for a GPO based install:

1: After a reboot, the managed software is installed
2: Defender will then go and get an update to it's definition file. If you
login during this phase and try and run defender you'll get a 0x80070005 error
3: After that phase, defender will run a quick scan. If you logon now you'll
see the scan window. You will also possible see a 0x80070005 error.

If you login after phase 3 you'll still get a 0x80070005 error. However
after a reboot you'll be able to run Defender normally. I *think* this is
because after the install Defender is still running at the elevated Admin
privilige of the installation. A reboot is needed to get it to run normally.

If you want to do a GPO install :

1: Add the .adm files to your GPO. This isn't needed but will give control
over defender
2: Do your GPO install
3: wait for the scan to finish (sadly I don't think you can determine this
4: reboot the machine and all should be well.

Hope this helps someone out !



That doesn't really solve anything as the user will always want to login as
soon as the machine is back up. A solution would be for the message not to
appear at all.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question