Setup failed to install the product catalogs - still a problem after deleting catroot2


P

pchrgt

Recently I attempted to install East Asian Languages and files for
Complex Scripts in the Regional and Language options for my Windows XP
Professional Service Pack 2. I tried installing it but a few files were
not found, so I installed it again using a different cd I got from
work. In the process I also changed the Language version of the Non
Unicode programs to Japanese to use some software that required it.
Somehow that must have corrupted my XP because when I rebooted suddenly
I was at a login screen, something that I had never used on my PC
before. When I clicked my name it said Loading your preferences, then
that Loading your preferences disapeared, and I was never able to login
after that. Safe mode took me to the same screen but added
Administrator as well as my name, and neither would login.

I took it back to the shop I bought it from and they installed a
separate installation of Windows XP. They were in the process of re
installing XP on someone elses PC so they used by cd to install on
another PC and it worked fine, so that rules out the CD being faulty.
The second installation of XP has no drivers and no other programs
work, and since it would take a very long time to find all the driver
cds if I could at all, and all the other software I'd paid for would
have to be paid for again if I couldn't find the registrations in the
registry I thought I'd try Repair Installation on the XP I could not
login to.

On running the repair however, I encounted this error:

Error:

The signature for Windows XP Professional Upgrade is invalid. The
error code is 800b0100.

No signature was present in the subject.


***

Fatal Error:

Setup failed to install the product catalogs. This is a fatal error.
The setup log files should contain more information.

Clicking Close will always reboot, and come back to restart this
installation, there is no time to select the second installation which
I can get into as XP always assumes you want to finish the repair
installation. It will always stop at this point and it appears I will
never access this PC normally again.

I have googled this extensively and before anyone points me to this
article here:

http://support.microsoft.com/default.aspx?scid=kb;en-us;823303

The 3 solutions did not work for me

1. I have tried renaming and deleting C:\Windows\System32\catroot2
multiple times, even tried catroot just in case.

2. Not relevand because I am not upgrading from an earlier version.

3. They tested it with different RAM in the shop I bought it from and
it came up with the same error.

I do not want to format the hard drive if I can help it, so if there is
anywhere else the product catelogs might be that needs to be deleted or
if there are any other options to try please let me know.
 
Ad

Advertisements

Joined
May 31, 2010
Messages
2
Reaction score
0
The Fix!

I know this is an old thread but since I came across it when researching this problem in 2010 I figured there might be others in this boat.



It was a major headache but I was able to fix this and I wanted to share what it was and what needed done because it doesn’t seem to be documented anywhere.



For me it began as a severely infected computer that was rendered unbootable after removing the viruses and attempting a repair install of XP (boot to CD, hit ENTER on first menu and R on second), hanging at 39 minutes with "The signature for windows XP professional Upgrade is invalid. The error code is 426" There was also a product catalog error.



The reason for this, in my case, was that the infection had created a dependency for many critical Windows services, including cryptographic (CryptSvc) service, lanmanworkstation and RpcSs (amongst a few others). When ComboFix removed the threats (files), it did not remove the dependencies created for those services and meant that the legitimate services could not start.



The dependencies must be removed before you can continue. To verify that this is also your problem, when stuck at the 39 minute screen, press Shift+F10 to bring up command prompt. Type regedit and hit Enter. Expand HKLM>SYSTEM>CurrentControlSet>Services. Start with RpcSs. Click on RpcSs in the left window. On the right you should not see ANY strings listing "DependOnService" or "DependOnGroup." If you do, as I did, finding a dependency "keyb" (AKA Keyboard Manager, type32.dll) service listed then that is your problem. Examining the ComboFix log confirmed these Keyboard Manager files were deleted. I also saw "keyb" listed as a service required for lanmanworkstation and cryptsvc (amongst others) to start. Because ComboFix had removed the malicious service it was not found by the legit services allowing them to start.



The problem is that you cannot just remove those dependencies and continue the repair. Even if you remove them and restart your repair install it will fail.



What has to be done is a system restore to restore the malicious "keyb" service in the registry, but how do you do that in the middle of a repair install? You need Hiren's BootCD 10.4. Boot to this CD, load Mini XP mode and navigate to System Restore. Restore your system to a time before the virus removal.



After a successful restore, remove the CD and boot to Safe Mode. Inside Safe Mode, open regedit (if you do not have a start menu like I didn't, press Ctrl+Shift+Esc to bring up Task Manager and from the file menu select Run...) and navigate to the services location HKLM>SYSTEM>CurrentControlSet. In my case the keyb service was the nasty, so I searched the CurrentControlSet high and low for "keyb" (without quotes) and removed the "DependOnService" and "DependOnGroup" strings if "keyb" was listed. Be VERY careful as there will be plenty of legit entries for "keyboard" that you don't want to delete. Also search the ControlSet00X keys! While you are in the registry, also take a look at the key HKLM>Software>Microsoft>Windows NT>SvcHost. When I clicked on SvcHost there were two strings present on the right side that needed to be deleted. They were trr360 and MediaCenter. DELETE THEM if you see them.



Now that the dependencies are removed, restart your computer in Safe Mode again. At this point I had a normal looking Windows. My start menu appeared, my network connections were back, device manager was full, services.msc was loading properly. Confirm the malicious dependencies are no longer listed in the registry. It's now OK to run any malware removal tool (I recommend ComboFix at this stage). Because the necessary Windows Services will no longer depend on the threats you’ll remove, you have the upper hand to get rid of any lingering bugs. You can even attempt the Windows Repair again.



I know this is a bit exhausting but I was dealing with a PC that simply could not be formatted due to the software installed on it and you might be too. Maybe my overnight job will save someone sleep one night!



Good luck.
 
Ad

Advertisements

Joined
Apr 24, 2011
Messages
1
Reaction score
0
Thank you mike25! I have been trying to install a legal copy
of Windows XP Pro on a Gateway Laptop. The laptop had some beta
version of Windows XP Pro Service Pack 2 installed on it. The
Restore Disk of the Gateway Laptop was at Service Pack 1 for the
initial install. Each time I attempted to do a repair install
I got stuck at the 39 minute mark (beginning) of the XP install
process and it never progressed any further. It took anywhere
from 30 minutes to several hours before getting the message:

Setup has problems registering the following OLE control DLL:
C:\WINDOWS\system32\initpki.dll

Contact System Administrator

The signature for Windows XP Professional upgrade is invalid.
The error code is 426.

The service has not been started.

Luckily I had imaged the drive before attempting the upgrade.
So, I had many attempts at it after cloning the imaged drive
copy back to try again.
What I tried unsuccessfully:
Before an attempted upgrade
1. Replaced initpki.dll from a working Windows XP Pro Machine
2. Used Dial-a-fix Version 0.60.0.24 to register all dlls
3. Installing IE 7 before the upgrade
4. Deleting all contents of C:\WINDOWS\system32\CatRoot2 directory
5. Using MSCONFIG to configure the boot.ini file with the
Advanced Options to set /MAXMEM=128
6. Failed To Install Product Catalog Error Message When You Install Windows XP
http://support.microsoft.com/kb/823303
7. Tried different Memory Modules.
None of the above worked.

Solution:
Here's what worked which is a little different from the mike25 post,
but it got the install going.
1. I am stuck again the 39 minute mark in the repair install process
2. Press Shift+F10 to bring up command prompt
3. Enter regedit and press Enter
4. Maneuver to HKLM>SYSTEM>CurrentControlSet>Services>RpcSs
5. On the right you should not see any strings listing
DependOnService or DependOnGroup
6. I had DependOnService DComLaunch
7. Delete this DependOnService DComLaunch entry and exit regedit
8. Launch the Command Prompt again with Shift+F10
9. Delete the DComLaunch Service at the command prompt with syntax:
SC Delete DComLaunch
10. The setup then continued and completed successfully
11. Installed XP Service Pack 2
12. Installed XP Service Pack 3

Complete Upgrade now successful.

Hope this helps someone.
Danman
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top