setting a fixed default to check spelling and grammar


C

crossroads

Under Tools/language/set language I have unchecked "do not check spelling or
grammar" on my default Word template. I also have this default on a special
report template. I often have to copy and paste other documents I receive
from external sources into this special report template and before I do, I
make sure I set these other documents to uncheck their "do not check..."
The problem is that after I copy and paste into my special report template,
the "do not check spelling or grammar" box gets mysteriously checked. I'm
continually having to go and uncheck it so I can see the spelling and
grammatical errors.
Any help please?
 
Ad

Advertisements

C

crossroads

sorry graham - I'm not as advanced as you - I get the drift of edit/paste
special but you lost me from then on.
 
C

crossroads

From a few minutes ago ... I just realised what you meant. I pasted
(special) the document unformatted as you said into my template having made
sure that the language/spell checks were right. After I pasted I still had
to uncheck so I could see the spelling/grammar
 
G

Graham Mayor

That is not normal behaviour. The proofing settings are associated with the
text. Pasting as unformatted should cause the pasted text to adopt the
format at the destination. If that has the language parameter you require
then so should the pasted text, regardless of how is was previously
formatted.

There may be some mechanism interfering with the required action. To attempt
to verify this start Word in its safe mode by holding the CTRL key whilst
starting and acknowledge the prompt which ensues.

Does the paste work correctly in that mode? If it does, see
http://www.gmayor.com/what_to_do_when_word_crashes.htm then
http://word.mvps.org/FAQs/AppErrors/ProblemsStartingWord.htm.

--
<>>< ><<> ><<> <>>< ><<> <>>< <>><<>
Graham Mayor - Word MVP

My web site www.gmayor.com

<>>< ><<> ><<> <>>< ><<> <>>< <>><<>
 
Ad

Advertisements

G

Graham Mayor

Does it work if you add force the setting in the macro? eg

Sub PasteUnf()
On Error GoTo oops
With Selection
.NoProofing = False
.PasteSpecial _
DataType:=wdPasteText, _
Placement:=wdInLine
End With
Exit Sub
oops:
Beep
End Sub

If not I haven't a clue as I can't reproduce the problem

--
<>>< ><<> ><<> <>>< ><<> <>>< <>><<>
Graham Mayor - Word MVP

My web site www.gmayor.com

<>>< ><<> ><<> <>>< ><<> <>>< <>><<>
 
C

crossroads

Hi Graham - I know absolutely zero about macros so looks like I'm stuck with
the original problem which I had thought naively that there's be an easy fix
for. Thanks anyway
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top