Seting screen saver exeuctable name in GPO has side effects


B

Brian McCauley

Setting the Group Policy item "Screen Saver executable name" to
"SomeFilename.scr" whilst leaving the "Password protect the screen saver" not
configured does not work as documented.

According to both common sense and the documentation it should leave the
"Password protect the screen saver" choice to the user but the actual effect
is that the "Password protect the screen saver" checkbox is cleared and
greyed out. (And the screen saver is not actually enabled).

The reason for this is that half the system thinks "SomeFilename.scr" is not
a valid screen saver whilst the other half thinks it is.

The work-round is to specify the screen saver as
"%SystemRoot%\system32\SOMEFI~1.SCR" and then it all works as it should.
 
Ad

Advertisements

S

Shenan Stanley

Brian said:
Setting the Group Policy item "Screen Saver executable name" to
"SomeFilename.scr" whilst leaving the "Password protect the screen
saver" not configured does not work as documented.

According to both common sense and the documentation it should
leave the "Password protect the screen saver" choice to the user
but the actual effect is that the "Password protect the screen
saver" checkbox is cleared and greyed out. (And the screen saver is
not actually enabled).

The reason for this is that half the system thinks
"SomeFilename.scr" is not a valid screen saver whilst the other
half thinks it is.

The work-round is to specify the screen saver as
"%SystemRoot%\system32\SOMEFI~1.SCR" and then it all works as it
should.

What are you referring to? What specific 'documentation'?
 
B

Brian McCauley

Shenan Stanley said:
What are you referring to? What specific 'documentation'?

Well, primarily the "explaination" tabs on the desktop settings in GPO
editor. The same information is repeated in many places.

But let's face it that's not really relevant. The fact that the 8.3 name
works as one would intuatively expect and the long name does something else
means this is a bug plain and simple.
 
Ad

Advertisements

S

Shenan Stanley

Brian said:
Well, primarily the "explaination" tabs on the desktop settings in
GPO editor. The same information is repeated in many places.

But let's face it that's not really relevant. The fact that the 8.3
name works as one would intuatively expect and the long name does
something else means this is a bug plain and simple.

Not necessarily.

Did you try putting the long path name in quotes? Traditionally, long
filenames/paths - especially those containing spaces, etc - are put in
quotes.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top