SATA Western Digital Caviar HD install and set up problems


J

John

I'm having mega headaches trying to install a SATA HD and get it running.

My motherboard is a Gigabyte 915P MB -GA-8195P Duo (Pro), new about 2 ½
years ago - which initially had 2 Hitachi 160 GB SATA HDs set up in a Raid O
array. These occupy two of the four SATA slots on the MB.

It also had an IDE DVD RW originally and I later added a SATA Pioneer DVD RW
in one of the spare slots. This was recognised by windows and worked
immediately.

I've now acquired a Western Digital 400GB SATA drive to occupy the last
remaining SATA slot.

WD's web site indicated that a jumper was required to cause this second
generation SATA drive to revert to a 150MB?s transfer rate which is the
speed quoted in the Gigabyte MB user guide. It reads:



"S_ATA0/S_ATA1/S_ATA2/S_ATA3 (Serial ATA Connector)

Serial ATA can provide 150MB'stransfer rate. Please refer to the BIOS
settings for the Serial ATA and install the proper driver in order to work
properly" (My italics - I don't understand the reference to installing a
driver).



The problem.

The WD HD shows up during POST and in CMOS but Windows will not boot.
Instead the following message appears:

"Boot from CD

Boot from CD

Disk boot failure. Insert system disk and press enter."



I've been into BIOS to try and fix things.



In Bios, the standard CMOS features show the following:

"IDE Channel 0 Master HL-DTST DVD RAM GSH (The IDE DVD
RW?)

IDE Channel 0 Slave None

IDE Channel 2 Master S_ATA1_ Raid drive

IDE Channel 2 Slave S_ATA2_ (the Western's id)

IDE Channel 3 Master S_ATA3_ Raid drive

IDE Channel 3 Slave S_ATA4_ (the Pioneer's id)"



In the Advanced BIOS features the boot priority is:

"Hard drive

CD Rom

Floppy."



On entering the Hard Drive Boot Priority, I found at first that the WD HD
appeared before Intel Raid - Volume 0 (assumed to be the Hitachi RAID
drives. I changed the order and rebooted, hoping that I had solved the
problem. But the same "Disk boot failure. Insert system disk and press
enter." Message appears.



What have I missed? The MB user guide reference to "Please refer to the
BIOS settings for the Serial ATA and install the proper driver in order to
work properly" confuses me. What drivers?

Can anyone help me out with this and tell me what to do to get this new HD
up and running?



TIA

John
 
Ad

Advertisements

B

Bob Harris

First, the drivers to which the WD website refers are SATA controller
drivers, which are usually necessary for XP to see a SATA hard drive. These
come with the motherboard, not with the hard drive.

However, since you already have 2 SATA drives working, my first inclination
is to guess that the drivers must already be installed within XP. That
would be true is all SATA slots have the same type of controller. However,
some motherboards use two different SATA controllers, thus require two
different drivers.

But, none of that should matter to your current booting problem, since you
do not want to boot from the new drive. At worst XP should just not see it,
if XP does not have drivers for it. I am assuming that this new drive will
eventually be used to store data. However, if it has been "cloned" to
contain a copy of the operating system, that could cause an numberr of
problems, so long as the original drivers were still attached.

My best guess is that the booting problem is somewhere in the BIOS setup.
The WD drive is before the Hatachi raided-drives. The WD drive contains
nothing, and might not even be paritioned and formatted. Thus, the error.

As for how to get the Hatachi raided-drives to be first in the boot process,
that will require some tinkering in the BIOS. Read the motherboard manual,
twice. Then, unplug the WD drive, verify the PC booots, then reboot and
enter the BIOS setup. Carefully copy all information about booting. I
recommned a digital camera to be sure you get exactly what is on every
screen. Be aware that in addiiton to the "BOOT" tab in the BIOS setup, some
aspect of booting may be controlled in another tab, such as general or
advanced. So, make copies of those, too. Boot back into XP to print the
pictures. Then, power off and add the WD drive. Power-on and enter the
BIOS setup. Look for changes and try to determine what needs to be adjusted
to boot form the original SATA raided-drives instead of the WD drive.

Good luck.
 
I

ijkl523

_well_done_gays__let_me_tell_you_a_joke__An_old_man_named_bet365_was_in_his_golden_years,_but_that_didn't_stop_him_from_trying_to_pick_up_the_younger_ladies._He_went_to_the_local_bar,_approached_a_very_pretty_and_very_young_woman_and_said,_\"Where_have_you_been_all_my_life?\"_The_young_lady_takes_one_glance_at_him_and_says,_\"For_the_first_half_of_it,_I_wasn't_even_born_yet.\"__by_
'bet365' (http://whser.com) _have_a_nice_day_today
 
A

Andrew E.

Some of youre problem may be in the BIOS,enabling both RAID controllers
to work at same time,even if WDC SATA is solo...Also,Alot of hds,specially
SATA dont even get recognized since they are in a "raw state" from mfg..Try
enabling as needed in BIOS,boot to xp cd,press F6 option,with WDC SATA conn-
ected,install youre SATA drivers for that controller,once thru,& just
before xp
cd menu starts,tap r For recovery,disreguard the "no OS is present,etc" at
recovery entrance page,type:DiskPart In DiskPart,create a partition,press
ESC
key,then,either type:FORMAT E: /FS:NTFS E: being WDC SATA,or type:EXIT
Let xp start-up...Format in diskmgmt.msc
 
J

John

Bob, Andrew,

Many thanks for your help.



Disconnecting the WD allows Windows to boot again. Reconnecting it causes
the boot failure.



The WD is a ‘straight from the box drive’. I’ve read and re-read the MB
manual until I can quote chunks of it verbatim but there’s no further
reference to this issue. Nor can I find anything under any of the tabs,
every one of which I’ve been into.

I was just beginning to think about the reference to ‘Boot from CD’ and the
F6 process involved in setting up the Raid 0 array when I first acquired
this PC when I saw Andrew’s post. Setting up Raid originally was a
nightmare, in large part due to Gigabyte’s less than total command of
English. Here in Australia we’re lumped with Asia and everything, manuals,
support mail, is translated in Taiwan. Gigabyte just will not employ a
native English speaker to ensure clarity of language and the results often
are incomprehensible gibberish. It would be comical if not so frustrating!
If I hadn’t eventually accessed a support site in the States (where there
was a step by step, illustrated ‘child’s guide’, I doubt I’d ever have set
it up.



Andrew, is there any danger, when going back into the F6 process, of losing
the existing Raid0 array/the XP installation/data? I’ll be doing a full
back up before attempting this but the very thought of repeating that
experience brings me out in a cold sweat. (Don’t forget, just because you’re
paranoid doesn’t mean they’re not trying to get you!)



I’ll give it a go but would appreciate your further advice on this point.



Regards,



John
 
D

DL

The F6 option may be required when you initially install win, in order to
utilise the sata/raid controller.
Since your system is functioning, under raid, there is no need to install
via F6 again.
Your mobo can utilise two forms of raid using two different drivers, this I
believe is what the bios is referring to (IDE & Sata) since you are
successfully using raid sata there is no need for the other.
According to the mobo & bios settings manual if you are allready using sata
raid there is nothing else required to use another sata drive.
Have you tried this drive on another system, or even used WD Seatools to
test this drive?
BTW You can download the manual from UK or US Gigabyte sites - the
translation may be easier on the eye.
Andrew is I'm afraid mixing fact with fiction, as usual, There is no need to
F6 or use DiskPart or any other command line tools
 
Ad

Advertisements

P

PuDiTiNu

Hello John, When you first go into Bio's. Where you can change you clock
date ecetra, you see the drives, Yes? They should state Master then your HD
Manufacturer, Then Slave and it's Manufacturer. With the curser on the first
drive, ( MASTER ) hit enter it will seek the HD information, Repeat to the
second or ( Slave) HD. That should automatically recognize the new drive or
drives. The Jumpers, On the HD's Them Selves should be placed accordingly,
One jumper is placed to maked it the MASTER, and the other should be placed
in the SLAVE position. Or, if you have the proper ribbon cable witch is
marked Master /Slave you can put both drives in cable select. The Difference
in the cables are the number of conductors. I Think the exact amount is a 40
conductor and 80 conductor, But in CABLE SELECT, THE CABLE Wires look Real
Fine, or 80 conductors. I'm not sure why you would want to limit the size of
the drive, when your putting a much bigger drive in. I'm not even sure if I
helped you out. Oh and why are the set up as a RAID partition, Shouldn't they
be partitioned as a basic drive?
 
P

PuDiTiNu

I was under the impression, That he replaced the two smaller Hd's with bigger
drives. But, the drives replaced would have been formatted with a BASIC
PARTITION. In his Bio's he list the DVD drive in the Master slot, and then
the RAID drives. I was under the impression. RAID drives Do Not contain BOOT
Files. And there is NO Basic Drive in there. He also mentioned a jumper, But
he said it limits the drive from 400 Gb, to 150 Gb's.. I'm wondering if his
jumpers aren't set rite on the drives as far as Master/Slave/Cable select. (
CABLE SELECT POS) Requires the 80 conductor ribbon cable, as opposed to, the
40 Conductor MASTER / SLAVE cable set up. I may be totally off base, But The
Drives are either BASIC, DYNAMIC, or RAID, You need the boot files on a basic
drive to boot up. LoL ..... then again, I'm no Professional.
 
F

frog

Hi Guys.

Some confusion is getting into this.

For clarification the scenario is this.

Back in 2005 I drew up the specs for a replacement PC, had the ingredients
checked for mutual compatibility and the PC assembled by the component
suppliers for 20 bucks. This PC had (and still does) two Hitachi HDs and an
Ide DVD RW. The MB has a total of 4 SATA slots of which the Hitachis
occupied two.

On delivery I set up the two Hitachis in a RAID 0 array and installed XP
SP2.

About a year ago I decided to add (not replace) a second DVD RW and chose a
SATA model. Its installation was problem free and it was recognised
immediately. Three of the four SATA slots are now filled.

More recently I decided to fill the remaining SATA slot with a Western
Digital SATA HD. Again it is an addition, not a replacement for anything.
The MB is first generation SATA, the WD HD is a second generation SATA drive
and according to WD a jumper must be added to make it compatible with the
older MB. It is this Western HD, brand new from the box that has been put
in, jumper fitted, power and SATA connections made, the PC switched on and I
cannot get the thing to function. It shows up in BIOS but the error
message described (see previous posts) appears when XP should start loading.

I'm simply asking advice on how to get it up and running.

Regards,

John
 
D

DL

There is no other advice, since according to the manual, it should be
recognised, as you are allready using sata/raid therefore need no additional
drivers or bios settings
As the hd is recognised in the bios use the WD utility (on their site) to
create the bootable floppy/cd test utility
 
J

John

I did the WD diagnostic tests ( I'm grateful for being directed to those),
both short and full and they reported no errors. I've no spare system on
which to test it but presumably the tests are sufficient to clear the HD of
suspicion?

Am I right in thinking this must now be a motherboard issue? Before going
to Gigabyte's support, can it be confirmed that there is no possibility of
the order of the SATA connections being the cause of this? The PC vendors
installed the two Hitachis as two masters and I've not swapped the SATA
cables around on them.

I ask this question because an Eide DVD RAM will only work if connected to
the EIDE 1 slot. That information is buried in the MB manual and apparently
has caused many people much grief. But at least it is in the manual whereas
there is nothing on the problem I've got.
Regards,
John
 
Ad

Advertisements

D

DL

I can see nothing on the mobo manual that requires you to set any
addintional Bios or other settings if you are allready running sata drives.
You could I guess try disconnecting your sata dvd drive, then connect the
wd.
or even swapping these two connections.
 
Ad

Advertisements

J

jgrtmp

Sounds like your hitting a device limit.I have an MSI mobo & w/ it you have a
4 IDE to 2 SATA device limit.Sounds like your maxed out .Try a boot w/o the
SATA DVD RW & see if the post takes for your new drive on boot.I have the
inverse headache of not being able to install my SATA drivers because I maxed
the IDE & no longer have a floppy(gave up on it 2 yrs ago)to do a Windows
recovery install.High Tech is amazing-pass the aspirin..
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top