Rule with "sender" clause not working


S

Sabin Coanda

Hi there,

I create a simple rule which has to select the emails containing the domain
of the sender address and move it to a specified folder.

How I do that:
- I get the sender addres from the message option window, internet headers
text box, field "From:". Suppose it is "From: John Doe <[email protected]>"
- I make the rule checking the option "with specific words in the sender's
address", and add in the related window the phrase "@x.com"
- I check the option move in the specified folder, and I select my
destination folder

When the emails arrives, I found for some emails the rule works, for other
it doesn't work, so the emails from some senders are selecting well, moving
them to the desired folder, but the emails from other senders are kept in
inbox. I tried to verify the rule removing the emails which were moved in
inbox, and I run again my rule. I found that systematically the same emails
which were previously moved are moved again, and the emails which were not
moved before are kept in inbox as well.

What is the problem ?

TIA,
Sabin
 
Ad

Advertisements

S

Sabin Coanda

I found some differences between the emails.

Those which are kept in inbox have some tags more: X-MS-Has-Attach,
X-MS-Exchange-Organization-SCL, X-MS-TNEF-Correlator,
X-Auto-Response-Suppress.

Maybe helps to find the problem
 
V

VanguardLH

Sabin said:
I create a simple rule which has to select the emails containing the
domain of the sender address and move it to a specified folder.

How I do that:
- I get the sender addres from the message option window, internet
headers text box, field "From:". Suppose it is "From: John Doe
<[email protected]>"
- I make the rule checking the option
"with specific words in the sender's address", and add in the related
window the phrase "@x.com"
- I check the option move in the specified
folder, and I select my destination folder

When the emails arrives, I found for some emails the rule works, for
other it doesn't work, so the emails from some senders are selecting
well, moving them to the desired folder, but the emails from other
senders are kept in inbox. I tried to verify the rule removing the
emails which were moved in inbox, and I run again my rule. I found
that systematically the same emails which were previously moved are
moved again, and the emails which were not moved before are kept in
inbox as well.

Are the problematic senders also listed in your contact records, and
did you enable the whitelisting function in the Safe Senders options to
include senders in your contacts?
 
S

Sabin Coanda

Are the problematic senders also listed in your contact records, and
did you enable the whitelisting function in the Safe Senders options to
include senders in your contacts?

Neither the right senders nor the problematic senders are in my contact
records, or in my safe senders list.
 
Ad

Advertisements

V

VanguardLH

Sabin said:
Neither the right senders nor the problematic senders are in my contact
records, or in my safe senders list.

Did you disable all rules except the one that moves the e-mails from
senders in the x.com domain? If you don't use the stop clause in your
rules, they get OR'ed together in the order they are listed. That means
you could end up with side effects, like one rule undoing what another
did.
 
S

Sabin Coanda

Did you disable all rules except the one that moves the e-mails from
senders in the x.com domain? If you don't use the stop clause in your
rules, they get OR'ed together in the order they are listed. That means
you could end up with side effects, like one rule undoing what another
did.

Yes, I disable the other rules.

In fact when I run the rules on demand by "Run Rules Now", all the rules are
disabled by default, and I enable just the rule I need. On the other hand,
in spite I have "Stop processing more rules" clause, I don't have a rule
which keeps explicitely an email in the Inbox. All my rules move the emails
in different folders by different criteria and stop then processing more
rules, to avoid processing an email by two different rules.

BTW, I found quite annoying this parallel processing, and not sequential as
the Outlook Express or Windows Mail do. However this is another story :)
 
V

VanguardLH

Sabin said:
Yes, I disable the other rules.

In fact when I run the rules on demand by "Run Rules Now", all the rules are
disabled by default, and I enable just the rule I need. On the other hand,
in spite I have "Stop processing more rules" clause, I don't have a rule
which keeps explicitely an email in the Inbox. All my rules move the emails
in different folders by different criteria and stop then processing more
rules, to avoid processing an email by two different rules.

BTW, I found quite annoying this parallel processing, and not sequential as
the Outlook Express or Windows Mail do. However this is another story :)

Are you using the value of From as rendered in Outlook's GUI? Or did
you use View -> Options menu to see the headers to see what value is
shown there?

What happens when you load Outlook in its safe mode which does not load
any add-ons that you installed in Outlook ("outlook.exe /safe")?
 
Ad

Advertisements

S

Sabin Coanda

Are you using the value of From as rendered in Outlook's GUI? Or did
you use View -> Options menu to see the headers to see what value is
shown there?

As I write in the head email of this thread, I get the sender addres from
"Message Options" window, "Internet headers" text box, field "From:".
Supposing it is "From: John Doe <[email protected]>", I select "@x.com". Also I
tried to use the value which is shown in the Inbox window, column "From",
which is in my sample "John Doe". It is the same behavior.

What happens when you load Outlook in its safe mode which does not load
any add-ons that you installed in Outlook ("outlook.exe /safe")?

With "outlook.exe /safe" I found the same behavior.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top