Repost: How to set up Windows XP so that FrontPage recgonises local webs?


D

Dave Logan

Hi - can anyone help me? I'm reposting this because I've had no responses to my original post, apart from one suggestion that I uninstall and reinstall IIS, which I did but it made no difference.

I'm using FrontPage 2000 and Windows XP SP2. I recently bought a new laptop and I can't remember how to set up a local web so that FrontPage will recognise it. On my old laptop, if I go into FrontPage and select File + Open Web, I can see "Web folders" under "My Computer", and within "Web folders" I can see "localhost", and all the websites that I have created within localhost. Also, if I type http://localhost/ or http://localhost/DavesWeb/, the website opens.

I have copied all my data to my new laptop, and installed IIS and the FrontPage 2000 Server Extensions. On my new machine I can go to http://localhost/DavesWeb in my browser. But in FrontPage, if I select File + Open Web, I can't see "Web folders" under "My Computer"; and if I type http://localhost/ or http://localhost/DavesWeb/, I get a message saying: "The folder http://localhost/DavesWeb/ [for example] isn't accessible. The folder may be located on an unavailable volume or protected with a password." The message box also referred me to a text file, "wecerr.txt", which stated: "Server Application Error. The server has encountered an error while loading an application during the processing of your request. Please refer to the even log for more detail [sic] information. Please contact the server administrator for assistance."

Yet as I say, I can open http://localhost/DavesWeb/ from within my browser.

Also, if I go into IIS on my new laptop and right-click the DavesWeb folder and select "All Tasks" + "Open in FrontPage", it just opens index.html, but not the website (i.e. there's no folder list). And if I right-click on "Default Web Site" in IIS and select "All Tasks" + "Open With FrontPage", I get in message in FrontPage saying: "The server could not complete your request. Contact your Internet Service Provider or web server administrator to make sure that the server has the FrontPage Server Extensions installed. For more specific information click Details." Clicking "Details" gives the same message as in "wecerr.txt" above.

Also, if I open "C:\inetpub\wwwroot" in FrontPage, and then right-click on the "Davesweb" folder and select "Convert to web", I get a message: "Server error: Unable to create a disk-based web at "C:\inetpub\wwwroot\Davesweb" because the parent web would not be a disk-based web. Create the disk-based web elsewhere, outside of your web server's document hierarchy." I tried googling for this, but the posts I saw all said I should open the root web in FP as a server based web (http://localhost) - which as I say, FrontPage won't let me do.

And whereas on my old laptop, if I open http://localhost/Davesweb in FrontPage and select Tools + Web Settings, the dialog box says "Server version: Microsoft-IIS/5.1", on my new laptop, if I open "C:\inetpub\wwwroot" in FrontPage (it won't let me open "C:\inetpub\wwwroot\Davesweb" as a web), and select Tools + Web Settings, , the dialog box says "Server version: no server installed."

Clearly I haven't configured IIS correctly in order for FrontPage to recognise that there is a local web on http://localhost/ - although my browser does recognise it.

What do I need to do to fix this?

Dave
 
Ad

Advertisements

R

Ronx

Open the IIS MMC (Control Panel->Administration Tools->Internet
Information Services)

Expand the tree in the left column and right click Default Web
Choose All Tasks->Check server extensions
Agree to tighten security
Check the report for problems.


Have you configured the extensions?
Right click on default site, Choose Properties- Extensions tab. Make
sure that authoring is enabled.
--
Ron Symonds - Microsoft MVP (FrontPage)
Reply only to group - emails will be deleted unread.

http://www.rxs-enterprises.org/fp

FrontPage Support: http://www.frontpagemvps.com/




Hi - can anyone help me? I'm reposting this because I've had no responses to my original post, apart from one suggestion that I uninstall and reinstall IIS, which I did but it made no difference.

I'm using FrontPage 2000 and Windows XP SP2. I recently bought a new laptop and I can't remember how to set up a local web so that FrontPage will recognise it. On my old laptop, if I go into FrontPage and select File + Open Web, I can see "Web folders" under "My Computer", and within "Web folders" I can see "localhost", and all the websites that I have created within localhost. Also, if I type http://localhost/ or http://localhost/DavesWeb/, the website opens.

I have copied all my data to my new laptop, and installed IIS and the FrontPage 2000 Server Extensions. On my new machine I can go to http://localhost/DavesWeb in my browser. But in FrontPage, if I select File + Open Web, I can't see "Web folders" under "My Computer"; and if I type http://localhost/ or http://localhost/DavesWeb/, I get a message saying: "The folder http://localhost/DavesWeb/ [for example] isn't accessible. The folder may be located on an unavailable volume or protected with a password." The message box also referred me to a text file, "wecerr.txt", which stated: "Server Application Error. The server has encountered an error while loading an application during the processing of your request. Please refer to the even log for more detail [sic] information. Please contact the server administrator for assistance."

Yet as I say, I can open http://localhost/DavesWeb/ from within my browser.

Also, if I go into IIS on my new laptop and right-click the DavesWeb folder and select "All Tasks" + "Open in FrontPage", it just opens index.html, but not the website (i.e. there's no folder list). And if I right-click on "Default Web Site" in IIS and select "All Tasks" + "Open With FrontPage", I get in message in FrontPage saying: "The server could not complete your request. Contact your Internet Service Provider or web server administrator to make sure that the server has the FrontPage Server Extensions installed. For more specific information click Details." Clicking "Details" gives the same message as in "wecerr.txt" above.

Also, if I open "C:\inetpub\wwwroot" in FrontPage, and then right-click on the "Davesweb" folder and select "Convert to web", I get a message: "Server error: Unable to create a disk-based web at "C:\inetpub\wwwroot\Davesweb" because the parent web would not be a disk-based web. Create the disk-based web elsewhere, outside of your web server's document hierarchy." I tried googling for this, but the posts I saw all said I should open the root web in FP as a server based web (http://localhost) - which as I say, FrontPage won't let me do.

And whereas on my old laptop, if I open http://localhost/Davesweb in FrontPage and select Tools + Web Settings, the dialog box says "Server version: Microsoft-IIS/5.1", on my new laptop, if I open "C:\inetpub\wwwroot" in FrontPage (it won't let me open "C:\inetpub\wwwroot\Davesweb" as a web), and select Tools + Web Settings, , the dialog box says "Server version: no server installed."

Clearly I haven't configured IIS correctly in order for FrontPage to recognise that there is a local web on http://localhost/ - although my browser does recognise it.

What do I need to do to fix this?

Dave
 
J

Jens Peter Karlsen [FP-MVP]

Remember that there are such a thing as too long lines. Makes a
message hard to read. Set your newsreader to wrap at the usual 72
characters.

See inline.
Hi - can anyone help me? I'm reposting this because I've had no responses to my original post, apart from one suggestion that I uninstall and reinstall IIS, which I did but it made no difference.

I'm using FrontPage 2000 and Windows XP SP2. I recently bought a new laptop and I can't remember how to set up a local web so that FrontPage will recognise it. On my old laptop, if I go into FrontPage and select File + Open Web, I can see "Web folders" under "My Computer", and within "Web folders" I can see "localhost", and all the websites that I have created within localhost. Also, if I type http://localhost/ or http://localhost/DavesWeb/, the website opens.

I have copied all my data to my new laptop, and installed IIS and the FrontPage 2000 Server Extensions. On my new machine I can go to http://localhost/DavesWeb in my browser. But in FrontPage, if I select File + Open Web, I can't see "Web folders" under "My Computer"; and if I type http://localhost/ or http://localhost/DavesWeb/, I get a message saying: "The folder http://localhost/DavesWeb/ [for example] isn't accessible. The folder may be located on an unavailable volume or protected with a password." The message box also referred me to a text file, "wecerr.txt", which stated: "Server Application Error. The server has encountered an error while loading an application during the processing of your request. Please refer to the even log for more detail [sic] information. Please contact the server administrator for assistance."

Do not copy a Server based Web. You must Publish it using http. You
can open the online Web in FP and Publish it to your new computer.
Yet as I say, I can open http://localhost/DavesWeb/ from within my browser.

Also, if I go into IIS on my new laptop and right-click the DavesWeb folder and select "All Tasks" + "Open in FrontPage", it just opens index.html, but not the website (i.e. there's no folder list). And if I right-click on "Default Web Site" in IIS and select "All Tasks" + "Open With FrontPage", I get in message in FrontPage saying: "The server could not complete your request. Contact your Internet Service Provider or web server administrator to make sure that the server has the FrontPage Server Extensions installed. For more specific information click Details." Clicking "Details" gives the same message as in "wecerr.txt" above.

That is normal.
Also, if I open "C:\inetpub\wwwroot" in FrontPage, and then right-click on the "Davesweb" folder and select "Convert to web", I get a message: "Server error: Unable to create a disk-based web at "C:\inetpub\wwwroot\Davesweb" because the parent web would not be a disk-based web. Create the disk-based web elsewhere, outside of your web server's document hierarchy." I tried googling for this, but the posts I saw all said I should open the root web in FP as a server based web (http://localhost) - which as I say, FrontPage won't let me do.

That also normal you must open serverbased webs using http not a file
path.
And whereas on my old laptop, if I open http://localhost/Davesweb in FrontPage and select Tools + Web Settings, the dialog box says "Server version: Microsoft-IIS/5.1", on my new laptop, if I open "C:\inetpub\wwwroot" in FrontPage (it won't let me open "C:\inetpub\wwwroot\Davesweb" as a web), and select Tools + Web Settings, , the dialog box says "Server version: no server installed."

As already said you must use http.
Clearly I haven't configured IIS correctly in order for FrontPage to recognise that there is a local web on http://localhost/ - although my browser does recognise it.

What do I need to do to fix this?

Publish your Web instead of copying.

Regards Jens Peter Karlsen. Microsoft MVP - Frontpage.
 
T

Thomas A. Rowe

You need to remove all webs and IIS/FP Extensions from the new machine since you copied the files
over from your old machine.

Next install IIS with the FP extensions from the Windows XP Pro CD, then under IIS MMC configure the
default web with the extensions.

Next access http://localhost from within FP, if this is success, then open your live/remote web /
site and publish back down to the http://localhost/subwebname

--
==============================================
Thomas A. Rowe
Microsoft MVP - FrontPage

http://www.Ecom-Data.com
==============================================


Hi - can anyone help me? I'm reposting this because I've had no responses to my original post, apart
from one suggestion that I uninstall and reinstall IIS, which I did but it made no difference.

I'm using FrontPage 2000 and Windows XP SP2. I recently bought a new laptop and I can't remember how
to set up a local web so that FrontPage will recognise it. On my old laptop, if I go into FrontPage
and select File + Open Web, I can see "Web folders" under "My Computer", and within "Web folders" I
can see "localhost", and all the websites that I have created within localhost. Also, if I type
http://localhost/ or http://localhost/DavesWeb/, the website opens.

I have copied all my data to my new laptop, and installed IIS and the FrontPage 2000 Server
Extensions. On my new machine I can go to http://localhost/DavesWeb in my browser. But in FrontPage,
if I select File + Open Web, I can't see "Web folders" under "My Computer"; and if I type
http://localhost/ or http://localhost/DavesWeb/, I get a message saying: "The folder
http://localhost/DavesWeb/ [for example] isn't accessible. The folder may be located on an
unavailable volume or protected with a password." The message box also referred me to a text file,
"wecerr.txt", which stated: "Server Application Error. The server has encountered an error while
loading an application during the processing of your request. Please refer to the even log for more
detail [sic] information. Please contact the server administrator for assistance."

Yet as I say, I can open http://localhost/DavesWeb/ from within my browser.

Also, if I go into IIS on my new laptop and right-click the DavesWeb folder and select "All Tasks" +
"Open in FrontPage", it just opens index.html, but not the website (i.e. there's no folder list).
And if I right-click on "Default Web Site" in IIS and select "All Tasks" + "Open With FrontPage", I
get in message in FrontPage saying: "The server could not complete your request. Contact your
Internet Service Provider or web server administrator to make sure that the server has the FrontPage
Server Extensions installed. For more specific information click Details." Clicking "Details" gives
the same message as in "wecerr.txt" above.

Also, if I open "C:\inetpub\wwwroot" in FrontPage, and then right-click on the "Davesweb" folder and
select "Convert to web", I get a message: "Server error: Unable to create a disk-based web at
"C:\inetpub\wwwroot\Davesweb" because the parent web would not be a disk-based web. Create the
disk-based web elsewhere, outside of your web server's document hierarchy." I tried googling for
this, but the posts I saw all said I should open the root web in FP as a server based web
(http://localhost) - which as I say, FrontPage won't let me do.

And whereas on my old laptop, if I open http://localhost/Davesweb in FrontPage and select Tools +
Web Settings, the dialog box says "Server version: Microsoft-IIS/5.1", on my new laptop, if I open
"C:\inetpub\wwwroot" in FrontPage (it won't let me open "C:\inetpub\wwwroot\Davesweb" as a web), and
select Tools + Web Settings, , the dialog box says "Server version: no server installed."

Clearly I haven't configured IIS correctly in order for FrontPage to recognise that there is a local
web on http://localhost/ - although my browser does recognise it.

What do I need to do to fix this?

Dave
 
D

Dave Logan

Thanks all, but how can I publish to http://localhost/DavesWeb given that I can't open http://localhost/DavesWeb from within FrontPage? FrontPage won't open even http://localhost/ - it doesn't recognise the path.

Dave


| Remember that there are such a thing as too long lines. Makes a
| message hard to read. Set your newsreader to wrap at the usual 72
| characters.
|
| See inline.
| On Wed, 25 Jul 2007 08:29:14 +0100, "Dave Logan"
|
| >Hi - can anyone help me? I'm reposting this because I've had no responses to my original post, apart from one suggestion that I uninstall and reinstall IIS, which I did but it made no difference.
| >
| >I'm using FrontPage 2000 and Windows XP SP2. I recently bought a new laptop and I can't remember how to set up a local web so that FrontPage will recognise it. On my old laptop, if I go into FrontPage and select File + Open Web, I can see "Web folders" under "My Computer", and within "Web folders" I can see "localhost", and all the websites that I have created within localhost. Also, if I type http://localhost/ or http://localhost/DavesWeb/, the website opens.
| >
| >I have copied all my data to my new laptop, and installed IIS and the FrontPage 2000 Server Extensions. On my new machine I can go to http://localhost/DavesWeb in my browser. But in FrontPage, if I select File + Open Web, I can't see "Web folders" under "My Computer"; and if I type http://localhost/ or http://localhost/DavesWeb/, I get a message saying: "The folder http://localhost/DavesWeb/ [for example] isn't accessible. The folder may be located on an unavailable volume or protected with a password." The message box also referred me to a text file, "wecerr.txt", which stated: "Server Application Error. The server has encountered an error while loading an application during the processing of your request. Please refer to the even log for more detail [sic] information. Please contact the server administrator for assistance."
|
| Do not copy a Server based Web. You must Publish it using http. You
| can open the online Web in FP and Publish it to your new computer.
| >
| >Yet as I say, I can open http://localhost/DavesWeb/ from within my browser.
| >
| >Also, if I go into IIS on my new laptop and right-click the DavesWeb folder and select "All Tasks" + "Open in FrontPage", it just opens index.html, but not the website (i.e. there's no folder list). And if I right-click on "Default Web Site" in IIS and select "All Tasks" + "Open With FrontPage", I get in message in FrontPage saying: "The server could not complete your request. Contact your Internet Service Provider or web server administrator to make sure that the server has the FrontPage Server Extensions installed. For more specific information click Details." Clicking "Details" gives the same message as in "wecerr.txt" above.
|
| That is normal.
| >
| >Also, if I open "C:\inetpub\wwwroot" in FrontPage, and then right-click on the "Davesweb" folder and select "Convert to web", I get a message: "Server error: Unable to create a disk-based web at "C:\inetpub\wwwroot\Davesweb" because the parent web would not be a disk-based web. Create the disk-based web elsewhere, outside of your web server's document hierarchy." I tried googling for this, but the posts I saw all said I should open the root web in FP as a server based web (http://localhost) - which as I say, FrontPage won't let me do.
|
| That also normal you must open serverbased webs using http not a file
| path.
| >
| >And whereas on my old laptop, if I open http://localhost/Davesweb in FrontPage and select Tools + Web Settings, the dialog box says "Server version: Microsoft-IIS/5.1", on my new laptop, if I open "C:\inetpub\wwwroot" in FrontPage (it won't let me open "C:\inetpub\wwwroot\Davesweb" as a web), and select Tools + Web Settings, , the dialog box says "Server version: no server installed."
|
| As already said you must use http.
| >
| >Clearly I haven't configured IIS correctly in order for FrontPage to recognise that there is a local web on http://localhost/ - although my browser does recognise it.
| >
| >What do I need to do to fix this?
|
| Publish your Web instead of copying.
|
| Regards Jens Peter Karlsen. Microsoft MVP - Frontpage.
 
D

Dave Logan

Hi Ronx

| Open the IIS MMC (Control Panel->Administration Tools->Internet
| Information Services)
|
| Expand the tree in the left column and right click Default Web
| Choose All Tasks->Check server extensions
| Agree to tighten security

I've tried that but it made no difference.

| Check the report for problems.

I couldn't find "report for problems". the only button on the "Check server extensions" button was "Close".


| Have you configured the extensions?

Not sure what you mean by configuring them.

| Right click on default site, Choose Properties- Extensions tab. Make
| sure that authoring is enabled.

Yes it is.

Dave
 
Ad

Advertisements

D

Dave Logan

Hi Thomas

| You need to remove all webs and IIS/FP Extensions from the new machine since you copied the files
| over from your old machine.

I'm not sure what you mean? Do you mean I should first go to Windows Esploerer and go to C:\inetpub\wwroot and delete the entire contents of that folder, and then uninstall IIS using Add/Remove Windows Components?

| Next install IIS with the FP extensions from the Windows XP Pro CD, then under IIS MMC configure the
| default web with the extensions.

Not sure what you mean by "configure the default web with the extensions"? Do you mean run "All Tasks" + "Check Server Extensions"?

Dave
 
D

Dave Logan

Update: I have now deleted the entire contents of C:\inetpub\wwwroot\ from within Windows Explorer, and now the IIS menu has changed. If I right-click "Default Web Site" and select "All Tasks", it now says "Configure Server Extensions" (it didn't before). But if I run the wizard, I can't make sense of the dialogs in the wizard. For example, it's asking me if I want to create local machine groups - do I, and if so, why? And why is it asking for an email address based on my machine name (no such email address exists)? And do I need to uninstall and reinstall IIS again before I run the wizard in any case?

Dave


| You need to remove all webs and IIS/FP Extensions from the new machine since you copied the files
| over from your old machine.
|
| Next install IIS with the FP extensions from the Windows XP Pro CD, then under IIS MMC configure the
| default web with the extensions.
|
| Next access http://localhost from within FP, if this is success, then open your live/remote web /
| site and publish back down to the http://localhost/subwebname
|
| --
| ==============================================
| Thomas A. Rowe
| Microsoft MVP - FrontPage
|
| http://www.Ecom-Data.com
| ==============================================
|
|
| | Hi - can anyone help me? I'm reposting this because I've had no responses to my original post, apart
| from one suggestion that I uninstall and reinstall IIS, which I did but it made no difference.
|
| I'm using FrontPage 2000 and Windows XP SP2. I recently bought a new laptop and I can't remember how
| to set up a local web so that FrontPage will recognise it. On my old laptop, if I go into FrontPage
| and select File + Open Web, I can see "Web folders" under "My Computer", and within "Web folders" I
| can see "localhost", and all the websites that I have created within localhost. Also, if I type
| http://localhost/ or http://localhost/DavesWeb/, the website opens.
|
| I have copied all my data to my new laptop, and installed IIS and the FrontPage 2000 Server
| Extensions. On my new machine I can go to http://localhost/DavesWeb in my browser. But in FrontPage,
| if I select File + Open Web, I can't see "Web folders" under "My Computer"; and if I type
| http://localhost/ or http://localhost/DavesWeb/, I get a message saying: "The folder
| http://localhost/DavesWeb/ [for example] isn't accessible. The folder may be located on an
| unavailable volume or protected with a password." The message box also referred me to a text file,
| "wecerr.txt", which stated: "Server Application Error. The server has encountered an error while
| loading an application during the processing of your request. Please refer to the even log for more
| detail [sic] information. Please contact the server administrator for assistance."
|
| Yet as I say, I can open http://localhost/DavesWeb/ from within my browser.
|
| Also, if I go into IIS on my new laptop and right-click the DavesWeb folder and select "All Tasks" +
| "Open in FrontPage", it just opens index.html, but not the website (i.e. there's no folder list).
| And if I right-click on "Default Web Site" in IIS and select "All Tasks" + "Open With FrontPage", I
| get in message in FrontPage saying: "The server could not complete your request. Contact your
| Internet Service Provider or web server administrator to make sure that the server has the FrontPage
| Server Extensions installed. For more specific information click Details." Clicking "Details" gives
| the same message as in "wecerr.txt" above.
|
| Also, if I open "C:\inetpub\wwwroot" in FrontPage, and then right-click on the "Davesweb" folder and
| select "Convert to web", I get a message: "Server error: Unable to create a disk-based web at
| "C:\inetpub\wwwroot\Davesweb" because the parent web would not be a disk-based web. Create the
| disk-based web elsewhere, outside of your web server's document hierarchy." I tried googling for
| this, but the posts I saw all said I should open the root web in FP as a server based web
| (http://localhost) - which as I say, FrontPage won't let me do.
|
| And whereas on my old laptop, if I open http://localhost/Davesweb in FrontPage and select Tools +
| Web Settings, the dialog box says "Server version: Microsoft-IIS/5.1", on my new laptop, if I open
| "C:\inetpub\wwwroot" in FrontPage (it won't let me open "C:\inetpub\wwwroot\Davesweb" as a web), and
| select Tools + Web Settings, , the dialog box says "Server version: no server installed."
|
| Clearly I haven't configured IIS correctly in order for FrontPage to recognise that there is a local
| web on http://localhost/ - although my browser does recognise it.
|
| What do I need to do to fix this?
|
| Dave
|
|
 
T

Thomas A. Rowe

First Uninstall IIS, then remove the content via Windows Explorer or My Computer.

After re-installing, open the Default Web, right click and Select All Task, you should see an option
about applying the extensions.

--
==============================================
Thomas A. Rowe
Microsoft MVP - FrontPage

http://www.Ecom-Data.com
==============================================


Hi Thomas

| You need to remove all webs and IIS/FP Extensions from the new machine since you copied the files
| over from your old machine.

I'm not sure what you mean? Do you mean I should first go to Windows Esploerer and go to
C:\inetpub\wwroot and delete the entire contents of that folder, and then uninstall IIS using
Add/Remove Windows Components?

| Next install IIS with the FP extensions from the Windows XP Pro CD, then under IIS MMC configure
the
| default web with the extensions.

Not sure what you mean by "configure the default web with the extensions"? Do you mean run "All
Tasks" + "Check Server Extensions"?

Dave
 
T

Thomas A. Rowe

Do you have a admin login set up on this machine and are you logged in under this account?

--
==============================================
Thomas A. Rowe
Microsoft MVP - FrontPage

http://www.Ecom-Data.com
==============================================


Update: I have now deleted the entire contents of C:\inetpub\wwwroot\ from within Windows Explorer,
and now the IIS menu has changed. If I right-click "Default Web Site" and select "All Tasks", it now
says "Configure Server Extensions" (it didn't before). But if I run the wizard, I can't make sense
of the dialogs in the wizard. For example, it's asking me if I want to create local machine groups -
do I, and if so, why? And why is it asking for an email address based on my machine name (no such
email address exists)? And do I need to uninstall and reinstall IIS again before I run the wizard in
any case?

Dave


| You need to remove all webs and IIS/FP Extensions from the new machine since you copied the files
| over from your old machine.
|
| Next install IIS with the FP extensions from the Windows XP Pro CD, then under IIS MMC configure
the
| default web with the extensions.
|
| Next access http://localhost from within FP, if this is success, then open your live/remote web /
| site and publish back down to the http://localhost/subwebname
|
| --
| ==============================================
| Thomas A. Rowe
| Microsoft MVP - FrontPage
|
| http://www.Ecom-Data.com
| ==============================================
|
|
| | Hi - can anyone help me? I'm reposting this because I've had no responses to my original post,
apart
| from one suggestion that I uninstall and reinstall IIS, which I did but it made no difference.
|
| I'm using FrontPage 2000 and Windows XP SP2. I recently bought a new laptop and I can't remember
how
| to set up a local web so that FrontPage will recognise it. On my old laptop, if I go into
FrontPage
| and select File + Open Web, I can see "Web folders" under "My Computer", and within "Web folders"
I
| can see "localhost", and all the websites that I have created within localhost. Also, if I type
| http://localhost/ or http://localhost/DavesWeb/, the website opens.
|
| I have copied all my data to my new laptop, and installed IIS and the FrontPage 2000 Server
| Extensions. On my new machine I can go to http://localhost/DavesWeb in my browser. But in
FrontPage,
| if I select File + Open Web, I can't see "Web folders" under "My Computer"; and if I type
| http://localhost/ or http://localhost/DavesWeb/, I get a message saying: "The folder
| http://localhost/DavesWeb/ [for example] isn't accessible. The folder may be located on an
| unavailable volume or protected with a password." The message box also referred me to a text file,
| "wecerr.txt", which stated: "Server Application Error. The server has encountered an error while
| loading an application during the processing of your request. Please refer to the even log for
more
| detail [sic] information. Please contact the server administrator for assistance."
|
| Yet as I say, I can open http://localhost/DavesWeb/ from within my browser.
|
| Also, if I go into IIS on my new laptop and right-click the DavesWeb folder and select "All Tasks"
+
| "Open in FrontPage", it just opens index.html, but not the website (i.e. there's no folder list).
| And if I right-click on "Default Web Site" in IIS and select "All Tasks" + "Open With FrontPage",
I
| get in message in FrontPage saying: "The server could not complete your request. Contact your
| Internet Service Provider or web server administrator to make sure that the server has the
FrontPage
| Server Extensions installed. For more specific information click Details." Clicking "Details"
gives
| the same message as in "wecerr.txt" above.
|
| Also, if I open "C:\inetpub\wwwroot" in FrontPage, and then right-click on the "Davesweb" folder
and
| select "Convert to web", I get a message: "Server error: Unable to create a disk-based web at
| "C:\inetpub\wwwroot\Davesweb" because the parent web would not be a disk-based web. Create the
| disk-based web elsewhere, outside of your web server's document hierarchy." I tried googling for
| this, but the posts I saw all said I should open the root web in FP as a server based web
| (http://localhost) - which as I say, FrontPage won't let me do.
|
| And whereas on my old laptop, if I open http://localhost/Davesweb in FrontPage and select Tools +
| Web Settings, the dialog box says "Server version: Microsoft-IIS/5.1", on my new laptop, if I open
| "C:\inetpub\wwwroot" in FrontPage (it won't let me open "C:\inetpub\wwwroot\Davesweb" as a web),
and
| select Tools + Web Settings, , the dialog box says "Server version: no server installed."
|
| Clearly I haven't configured IIS correctly in order for FrontPage to recognise that there is a
local
| web on http://localhost/ - although my browser does recognise it.
|
| What do I need to do to fix this?
|
| Dave
|
|
 
D

Dave Logan

If you mean does my Windows login have Administrator rights, yes it does - is that what you were asking?

Dave


| Do you have a admin login set up on this machine and are you logged in under this account?
|
| --
| ==============================================
| Thomas A. Rowe
| Microsoft MVP - FrontPage
|
| http://www.Ecom-Data.com
| ==============================================
|
|
| | Update: I have now deleted the entire contents of C:\inetpub\wwwroot\ from within Windows Explorer,
| and now the IIS menu has changed. If I right-click "Default Web Site" and select "All Tasks", it now
| says "Configure Server Extensions" (it didn't before). But if I run the wizard, I can't make sense
| of the dialogs in the wizard. For example, it's asking me if I want to create local machine groups -
| do I, and if so, why? And why is it asking for an email address based on my machine name (no such
| email address exists)? And do I need to uninstall and reinstall IIS again before I run the wizard in
| any case?
|
| Dave
|
|
|| You need to remove all webs and IIS/FP Extensions from the new machine since you copied the files
|| over from your old machine.
||
|| Next install IIS with the FP extensions from the Windows XP Pro CD, then under IIS MMC configure
| the
|| default web with the extensions.
||
|| Next access http://localhost from within FP, if this is success, then open your live/remote web /
|| site and publish back down to the http://localhost/subwebname
||
|| --
|| ==============================================
|| Thomas A. Rowe
|| Microsoft MVP - FrontPage
||
|| http://www.Ecom-Data.com
|| ==============================================
||
||
|| || Hi - can anyone help me? I'm reposting this because I've had no responses to my original post,
| apart
|| from one suggestion that I uninstall and reinstall IIS, which I did but it made no difference.
||
|| I'm using FrontPage 2000 and Windows XP SP2. I recently bought a new laptop and I can't remember
| how
|| to set up a local web so that FrontPage will recognise it. On my old laptop, if I go into
| FrontPage
|| and select File + Open Web, I can see "Web folders" under "My Computer", and within "Web folders"
| I
|| can see "localhost", and all the websites that I have created within localhost. Also, if I type
|| http://localhost/ or http://localhost/DavesWeb/, the website opens.
||
|| I have copied all my data to my new laptop, and installed IIS and the FrontPage 2000 Server
|| Extensions. On my new machine I can go to http://localhost/DavesWeb in my browser. But in
| FrontPage,
|| if I select File + Open Web, I can't see "Web folders" under "My Computer"; and if I type
|| http://localhost/ or http://localhost/DavesWeb/, I get a message saying: "The folder
|| http://localhost/DavesWeb/ [for example] isn't accessible. The folder may be located on an
|| unavailable volume or protected with a password." The message box also referred me to a text file,
|| "wecerr.txt", which stated: "Server Application Error. The server has encountered an error while
|| loading an application during the processing of your request. Please refer to the even log for
| more
|| detail [sic] information. Please contact the server administrator for assistance."
||
|| Yet as I say, I can open http://localhost/DavesWeb/ from within my browser.
||
|| Also, if I go into IIS on my new laptop and right-click the DavesWeb folder and select "All Tasks"
| +
|| "Open in FrontPage", it just opens index.html, but not the website (i.e. there's no folder list).
|| And if I right-click on "Default Web Site" in IIS and select "All Tasks" + "Open With FrontPage",
| I
|| get in message in FrontPage saying: "The server could not complete your request. Contact your
|| Internet Service Provider or web server administrator to make sure that the server has the
| FrontPage
|| Server Extensions installed. For more specific information click Details." Clicking "Details"
| gives
|| the same message as in "wecerr.txt" above.
||
|| Also, if I open "C:\inetpub\wwwroot" in FrontPage, and then right-click on the "Davesweb" folder
| and
|| select "Convert to web", I get a message: "Server error: Unable to create a disk-based web at
|| "C:\inetpub\wwwroot\Davesweb" because the parent web would not be a disk-based web. Create the
|| disk-based web elsewhere, outside of your web server's document hierarchy." I tried googling for
|| this, but the posts I saw all said I should open the root web in FP as a server based web
|| (http://localhost) - which as I say, FrontPage won't let me do.
||
|| And whereas on my old laptop, if I open http://localhost/Davesweb in FrontPage and select Tools +
|| Web Settings, the dialog box says "Server version: Microsoft-IIS/5.1", on my new laptop, if I open
|| "C:\inetpub\wwwroot" in FrontPage (it won't let me open "C:\inetpub\wwwroot\Davesweb" as a web),
| and
|| select Tools + Web Settings, , the dialog box says "Server version: no server installed."
||
|| Clearly I haven't configured IIS correctly in order for FrontPage to recognise that there is a
| local
|| web on http://localhost/ - although my browser does recognise it.
||
|| What do I need to do to fix this?
||
|| Dave
||
||
|
|
 
Ad

Advertisements

T

Thomas A. Rowe

Yes.

--
==============================================
Thomas A. Rowe
Microsoft MVP - FrontPage

http://www.Ecom-Data.com
==============================================


If you mean does my Windows login have Administrator rights, yes it does - is that what you were
asking?

Dave


| Do you have a admin login set up on this machine and are you logged in under this account?
|
| --
| ==============================================
| Thomas A. Rowe
| Microsoft MVP - FrontPage
|
| http://www.Ecom-Data.com
| ==============================================
|
|
| | Update: I have now deleted the entire contents of C:\inetpub\wwwroot\ from within Windows
Explorer,
| and now the IIS menu has changed. If I right-click "Default Web Site" and select "All Tasks", it
now
| says "Configure Server Extensions" (it didn't before). But if I run the wizard, I can't make sense
| of the dialogs in the wizard. For example, it's asking me if I want to create local machine
groups -
| do I, and if so, why? And why is it asking for an email address based on my machine name (no such
| email address exists)? And do I need to uninstall and reinstall IIS again before I run the wizard
in
| any case?
|
| Dave
|
|
|| You need to remove all webs and IIS/FP Extensions from the new machine since you copied the files
|| over from your old machine.
||
|| Next install IIS with the FP extensions from the Windows XP Pro CD, then under IIS MMC configure
| the
|| default web with the extensions.
||
|| Next access http://localhost from within FP, if this is success, then open your live/remote web /
|| site and publish back down to the http://localhost/subwebname
||
|| --
|| ==============================================
|| Thomas A. Rowe
|| Microsoft MVP - FrontPage
||
|| http://www.Ecom-Data.com
|| ==============================================
||
||
|| || Hi - can anyone help me? I'm reposting this because I've had no responses to my original post,
| apart
|| from one suggestion that I uninstall and reinstall IIS, which I did but it made no difference.
||
|| I'm using FrontPage 2000 and Windows XP SP2. I recently bought a new laptop and I can't remember
| how
|| to set up a local web so that FrontPage will recognise it. On my old laptop, if I go into
| FrontPage
|| and select File + Open Web, I can see "Web folders" under "My Computer", and within "Web folders"
| I
|| can see "localhost", and all the websites that I have created within localhost. Also, if I type
|| http://localhost/ or http://localhost/DavesWeb/, the website opens.
||
|| I have copied all my data to my new laptop, and installed IIS and the FrontPage 2000 Server
|| Extensions. On my new machine I can go to http://localhost/DavesWeb in my browser. But in
| FrontPage,
|| if I select File + Open Web, I can't see "Web folders" under "My Computer"; and if I type
|| http://localhost/ or http://localhost/DavesWeb/, I get a message saying: "The folder
|| http://localhost/DavesWeb/ [for example] isn't accessible. The folder may be located on an
|| unavailable volume or protected with a password." The message box also referred me to a text
file,
|| "wecerr.txt", which stated: "Server Application Error. The server has encountered an error while
|| loading an application during the processing of your request. Please refer to the even log for
| more
|| detail [sic] information. Please contact the server administrator for assistance."
||
|| Yet as I say, I can open http://localhost/DavesWeb/ from within my browser.
||
|| Also, if I go into IIS on my new laptop and right-click the DavesWeb folder and select "All
Tasks"
| +
|| "Open in FrontPage", it just opens index.html, but not the website (i.e. there's no folder list).
|| And if I right-click on "Default Web Site" in IIS and select "All Tasks" + "Open With FrontPage",
| I
|| get in message in FrontPage saying: "The server could not complete your request. Contact your
|| Internet Service Provider or web server administrator to make sure that the server has the
| FrontPage
|| Server Extensions installed. For more specific information click Details." Clicking "Details"
| gives
|| the same message as in "wecerr.txt" above.
||
|| Also, if I open "C:\inetpub\wwwroot" in FrontPage, and then right-click on the "Davesweb" folder
| and
|| select "Convert to web", I get a message: "Server error: Unable to create a disk-based web at
|| "C:\inetpub\wwwroot\Davesweb" because the parent web would not be a disk-based web. Create the
|| disk-based web elsewhere, outside of your web server's document hierarchy." I tried googling for
|| this, but the posts I saw all said I should open the root web in FP as a server based web
|| (http://localhost) - which as I say, FrontPage won't let me do.
||
|| And whereas on my old laptop, if I open http://localhost/Davesweb in FrontPage and select Tools +
|| Web Settings, the dialog box says "Server version: Microsoft-IIS/5.1", on my new laptop, if I
open
|| "C:\inetpub\wwwroot" in FrontPage (it won't let me open "C:\inetpub\wwwroot\Davesweb" as a web),
| and
|| select Tools + Web Settings, , the dialog box says "Server version: no server installed."
||
|| Clearly I haven't configured IIS correctly in order for FrontPage to recognise that there is a
| local
|| web on http://localhost/ - although my browser does recognise it.
||
|| What do I need to do to fix this?
||
|| Dave
||
||
|
|
 
D

Dave Logan

Hi Thomas

I uninstalled and reinstalled IIS and the FrontPage Extensions, and deleted
the contents of C:\inetpub\wwwroot\. and in IIS, I right-clicked "Default
Web Server" and selected "All Tasks" + "Configure Server Extensions". As
before, it asked me whether I want to create local machine groups, and I
deselected that option. On the next screen it again asked me to configure my
mail server settings, but I don't want to have a mail server, I'm simply
trying to set up a local web, so I selected "No, I'll do it later".

Then I went into FrontPage, selected File + Open Web, typed
http://localhost/ and clicked Open, and as before, I get a message saying:
"The folder http://localhost/ isn't accessible. The folder may be located on
an unavailable volume or protected with a password."

Dave


| Yes.
|
| --
| ==============================================
| Thomas A. Rowe
| Microsoft MVP - FrontPage
|
| http://www.Ecom-Data.com
| ==============================================
|
|
| | If you mean does my Windows login have Administrator rights, yes it does -
is that what you were
| asking?
|
| Dave
|
|
|| Do you have a admin login set up on this machine and are you logged in
under this account?
||
|| --
|| ==============================================
|| Thomas A. Rowe
|| Microsoft MVP - FrontPage
||
|| http://www.Ecom-Data.com
|| ==============================================
||
||
|| || Update: I have now deleted the entire contents of C:\inetpub\wwwroot\
from within Windows
| Explorer,
|| and now the IIS menu has changed. If I right-click "Default Web Site" and
select "All Tasks", it
| now
|| says "Configure Server Extensions" (it didn't before). But if I run the
wizard, I can't make sense
|| of the dialogs in the wizard. For example, it's asking me if I want to
create local machine
| groups -
|| do I, and if so, why? And why is it asking for an email address based on
my machine name (no such
|| email address exists)? And do I need to uninstall and reinstall IIS again
before I run the wizard
| in
|| any case?
||
|| Dave
||
||
||| You need to remove all webs and IIS/FP Extensions from the new machine
since you copied the files
||| over from your old machine.
|||
||| Next install IIS with the FP extensions from the Windows XP Pro CD, then
under IIS MMC configure
|| the
||| default web with the extensions.
|||
||| Next access http://localhost from within FP, if this is success, then
open your live/remote web /
||| site and publish back down to the http://localhost/subwebname
|||
||| --
||| ==============================================
||| Thomas A. Rowe
||| Microsoft MVP - FrontPage
|||
||| http://www.Ecom-Data.com
||| ==============================================
|||
|||
||| ||| Hi - can anyone help me? I'm reposting this because I've had no
responses to my original post,
|| apart
||| from one suggestion that I uninstall and reinstall IIS, which I did but
it made no difference.
|||
||| I'm using FrontPage 2000 and Windows XP SP2. I recently bought a new
laptop and I can't remember
|| how
||| to set up a local web so that FrontPage will recognise it. On my old
laptop, if I go into
|| FrontPage
||| and select File + Open Web, I can see "Web folders" under "My Computer",
and within "Web folders"
|| I
||| can see "localhost", and all the websites that I have created within
localhost. Also, if I type
||| http://localhost/ or http://localhost/DavesWeb/, the website opens.
|||
||| I have copied all my data to my new laptop, and installed IIS and the
FrontPage 2000 Server
||| Extensions. On my new machine I can go to http://localhost/DavesWeb in
my browser. But in
|| FrontPage,
||| if I select File + Open Web, I can't see "Web folders" under "My
Computer"; and if I type
||| http://localhost/ or http://localhost/DavesWeb/, I get a message saying:
"The folder
||| http://localhost/DavesWeb/ [for example] isn't accessible. The folder
may be located on an
||| unavailable volume or protected with a password." The message box also
referred me to a text
| file,
||| "wecerr.txt", which stated: "Server Application Error. The server has
encountered an error while
||| loading an application during the processing of your request. Please
refer to the even log for
|| more
||| detail [sic] information. Please contact the server administrator for
assistance."
|||
||| Yet as I say, I can open http://localhost/DavesWeb/ from within my
browser.
|||
||| Also, if I go into IIS on my new laptop and right-click the DavesWeb
folder and select "All
| Tasks"
|| +
||| "Open in FrontPage", it just opens index.html, but not the website (i.e.
there's no folder list).
||| And if I right-click on "Default Web Site" in IIS and select "All Tasks"
+ "Open With FrontPage",
|| I
||| get in message in FrontPage saying: "The server could not complete your
request. Contact your
||| Internet Service Provider or web server administrator to make sure that
the server has the
|| FrontPage
||| Server Extensions installed. For more specific information click
Details." Clicking "Details"
|| gives
||| the same message as in "wecerr.txt" above.
|||
||| Also, if I open "C:\inetpub\wwwroot" in FrontPage, and then right-click
on the "Davesweb" folder
|| and
||| select "Convert to web", I get a message: "Server error: Unable to
create a disk-based web at
||| "C:\inetpub\wwwroot\Davesweb" because the parent web would not be a
disk-based web. Create the
||| disk-based web elsewhere, outside of your web server's document
hierarchy." I tried googling for
||| this, but the posts I saw all said I should open the root web in FP as a
server based web
||| (http://localhost) - which as I say, FrontPage won't let me do.
|||
||| And whereas on my old laptop, if I open http://localhost/Davesweb in
FrontPage and select Tools +
||| Web Settings, the dialog box says "Server version: Microsoft-IIS/5.1",
on my new laptop, if I
| open
||| "C:\inetpub\wwwroot" in FrontPage (it won't let me open
"C:\inetpub\wwwroot\Davesweb" as a web),
|| and
||| select Tools + Web Settings, , the dialog box says "Server version: no
server installed."
|||
||| Clearly I haven't configured IIS correctly in order for FrontPage to
recognise that there is a
|| local
||| web on http://localhost/ - although my browser does recognise it.
|||
||| What do I need to do to fix this?
|||
||| Dave
|||
|||
||
||
|
|
 
D

Dave Logan

Also, I've tried logging off from Windows and logging in as Administrator,
going into FrontPage and trying to open http://localhost, and I get the same
error message.

And I've also checked that on the "Server Extensions" tab of the "Default
Web Site Properties" dialog, "Enable Authoring" is ticked.

What should I do now?

Dave


| Hi Thomas
|
| I uninstalled and reinstalled IIS and the FrontPage Extensions, and
deleted
| the contents of C:\inetpub\wwwroot\. and in IIS, I right-clicked "Default
| Web Server" and selected "All Tasks" + "Configure Server Extensions". As
| before, it asked me whether I want to create local machine groups, and I
| deselected that option. On the next screen it again asked me to configure
my
| mail server settings, but I don't want to have a mail server, I'm simply
| trying to set up a local web, so I selected "No, I'll do it later".
|
| Then I went into FrontPage, selected File + Open Web, typed
| http://localhost/ and clicked Open, and as before, I get a message saying:
| "The folder http://localhost/ isn't accessible. The folder may be located
on
| an unavailable volume or protected with a password."
|
| Dave
|
|
| || Yes.
||
|| --
|| ==============================================
|| Thomas A. Rowe
|| Microsoft MVP - FrontPage
||
|| http://www.Ecom-Data.com
|| ==============================================
||
||
|| || If you mean does my Windows login have Administrator rights, yes it
does -
| is that what you were
|| asking?
||
|| Dave
||
||
| ||| Do you have a admin login set up on this machine and are you logged in
| under this account?
|||
||| --
||| ==============================================
||| Thomas A. Rowe
||| Microsoft MVP - FrontPage
|||
||| http://www.Ecom-Data.com
||| ==============================================
|||
|||
||| ||| Update: I have now deleted the entire contents of C:\inetpub\wwwroot\
| from within Windows
|| Explorer,
||| and now the IIS menu has changed. If I right-click "Default Web Site"
and
| select "All Tasks", it
|| now
||| says "Configure Server Extensions" (it didn't before). But if I run the
| wizard, I can't make sense
||| of the dialogs in the wizard. For example, it's asking me if I want to
| create local machine
|| groups -
||| do I, and if so, why? And why is it asking for an email address based on
| my machine name (no such
||| email address exists)? And do I need to uninstall and reinstall IIS
again
| before I run the wizard
|| in
||| any case?
|||
||| Dave
|||
|||
| |||| You need to remove all webs and IIS/FP Extensions from the new machine
| since you copied the files
|||| over from your old machine.
||||
|||| Next install IIS with the FP extensions from the Windows XP Pro CD,
then
| under IIS MMC configure
||| the
|||| default web with the extensions.
||||
|||| Next access http://localhost from within FP, if this is success, then
| open your live/remote web /
|||| site and publish back down to the http://localhost/subwebname
||||
|||| --
|||| ==============================================
|||| Thomas A. Rowe
|||| Microsoft MVP - FrontPage
||||
|||| http://www.Ecom-Data.com
|||| ==============================================
||||
||||
|||| |||| Hi - can anyone help me? I'm reposting this because I've had no
| responses to my original post,
||| apart
|||| from one suggestion that I uninstall and reinstall IIS, which I did but
| it made no difference.
||||
|||| I'm using FrontPage 2000 and Windows XP SP2. I recently bought a new
| laptop and I can't remember
||| how
|||| to set up a local web so that FrontPage will recognise it. On my old
| laptop, if I go into
||| FrontPage
|||| and select File + Open Web, I can see "Web folders" under "My
Computer",
| and within "Web folders"
||| I
|||| can see "localhost", and all the websites that I have created within
| localhost. Also, if I type
|||| http://localhost/ or http://localhost/DavesWeb/, the website opens.
||||
|||| I have copied all my data to my new laptop, and installed IIS and the
| FrontPage 2000 Server
|||| Extensions. On my new machine I can go to http://localhost/DavesWeb in
| my browser. But in
||| FrontPage,
|||| if I select File + Open Web, I can't see "Web folders" under "My
| Computer"; and if I type
|||| http://localhost/ or http://localhost/DavesWeb/, I get a message
saying:
| "The folder
|||| http://localhost/DavesWeb/ [for example] isn't accessible. The folder
| may be located on an
|||| unavailable volume or protected with a password." The message box also
| referred me to a text
|| file,
|||| "wecerr.txt", which stated: "Server Application Error. The server has
| encountered an error while
|||| loading an application during the processing of your request. Please
| refer to the even log for
||| more
|||| detail [sic] information. Please contact the server administrator for
| assistance."
||||
|||| Yet as I say, I can open http://localhost/DavesWeb/ from within my
| browser.
||||
|||| Also, if I go into IIS on my new laptop and right-click the DavesWeb
| folder and select "All
|| Tasks"
||| +
|||| "Open in FrontPage", it just opens index.html, but not the website
(i.e.
| there's no folder list).
|||| And if I right-click on "Default Web Site" in IIS and select "All
Tasks"
| + "Open With FrontPage",
||| I
|||| get in message in FrontPage saying: "The server could not complete your
| request. Contact your
|||| Internet Service Provider or web server administrator to make sure that
| the server has the
||| FrontPage
|||| Server Extensions installed. For more specific information click
| Details." Clicking "Details"
||| gives
|||| the same message as in "wecerr.txt" above.
||||
|||| Also, if I open "C:\inetpub\wwwroot" in FrontPage, and then right-click
| on the "Davesweb" folder
||| and
|||| select "Convert to web", I get a message: "Server error: Unable to
| create a disk-based web at
|||| "C:\inetpub\wwwroot\Davesweb" because the parent web would not be a
| disk-based web. Create the
|||| disk-based web elsewhere, outside of your web server's document
| hierarchy." I tried googling for
|||| this, but the posts I saw all said I should open the root web in FP as
a
| server based web
|||| (http://localhost) - which as I say, FrontPage won't let me do.
||||
|||| And whereas on my old laptop, if I open http://localhost/Davesweb in
| FrontPage and select Tools +
|||| Web Settings, the dialog box says "Server version: Microsoft-IIS/5.1",
| on my new laptop, if I
|| open
|||| "C:\inetpub\wwwroot" in FrontPage (it won't let me open
| "C:\inetpub\wwwroot\Davesweb" as a web),
||| and
|||| select Tools + Web Settings, , the dialog box says "Server version: no
| server installed."
||||
|||| Clearly I haven't configured IIS correctly in order for FrontPage to
| recognise that there is a
||| local
|||| web on http://localhost/ - although my browser does recognise it.
||||
|||| What do I need to do to fix this?
||||
|||| Dave
||||
||||
|||
|||
||
||
|
|
 
D

Dave Logan

Hi Thomas

| First Uninstall IIS, then remove the content via Windows Explorer or My
Computer.
|
| After re-installing, open the Default Web, right click and Select All
Task, you should see an option
| about applying the extensions.

I uninstalled and reinstalled IIS and the FrontPage Extensions, and deleted
the contents of C:\inetpub\wwwroot\. and in IIS, I right-clicked "Default
Web Server" and selected "All Tasks" + "Configure Server Extensions". As
before, it asked me whether I want to create local machine groups, and I
deselected that option. On the next screen it again asked me to configure my
mail server settings, but I don't want to have a mail server, I'm simply
trying to set up a local web, so I selected "No, I'll do it later".

Then I went into FrontPage, selected File + Open Web, typed
http://localhost/ and clicked Open, and as before, I get a message saying:
"The folder http://localhost/ isn't accessible. The folder may be located on
an unavailable volume or protected with a password."

Also, I've tried logging off from Windows and logging in as Administrator,
going into FrontPage and trying to open http://localhost, and I get the same
error message.

And I've also checked that on the "Server Extensions" tab of the "Default
Web Site Properties" dialog, "Enable Authoring" is selected.

What should I do now? Your help would be greatly appreciated.

Dave
 
D

Dave Logan

Hi Jens Peter


| Do not copy a Server based Web. You must Publish it using http. You
| can open the online Web in FP and Publish it to your new computer.

If I open the internet (non-local) website in FrontPage, and try to publish
to http://localhost/davesweb/, I get the following message:

"The server you are publishing to does not have the FrontPage Server
Extensions installed, and therefore does not support publishing via HTTP. To
continue publishing, specify a location that will work with FTP."

But I DO have the FrontPage extensions installed, and I have uninstalled and
reinstalled them over and over again. I have also deleted the contents of
C:\inetpub\wwwroot\ several times.

I must be missing something, but what could I be missing?

Dave
 
Ad

Advertisements

D

Dave Logan

Just to fill in the thread, I spoke to Thomas but he couldn't think what
else I could try. I've now also tried uninstalling my ZoneAlarm firewall and
my anti-virus software, and then uninstalling and reinstalling IIS and the
Server Extensions yet again, but with exactly the same results as before -
FrontPage thinks that the Server Extensions are not installed, but they are
installed. The craziest thing is that if I select the Default Web from
within IIS and then select "Open in FrontPage", FrontPage tells me that the
Server Extensions aren't installed - but if they weren't installed then I
wouldn't be able to select "Open in FrontPage" from within IIS in the first
place!!

I'm at my wits end. Can anyone think of anything?

Dave


| Contact me via http://www.ecom-data.com/Corp/AboutUs.asp
|
| --
| ==============================================
| Thomas A. Rowe
| Microsoft MVP - FrontPage
|
| http://www.Ecom-Data.com
| ==============================================
|
|
| | > Hi Thomas
| >
| > | > | First Uninstall IIS, then remove the content via Windows Explorer or
My
| > Computer.
| > |
| > | After re-installing, open the Default Web, right click and Select All
| > Task, you should see an option
| > | about applying the extensions.
| >
| > I uninstalled and reinstalled IIS and the FrontPage Extensions, and
deleted
| > the contents of C:\inetpub\wwwroot\. and in IIS, I right-clicked
"Default
| > Web Server" and selected "All Tasks" + "Configure Server Extensions". As
| > before, it asked me whether I want to create local machine groups, and I
| > deselected that option. On the next screen it again asked me to
configure my
| > mail server settings, but I don't want to have a mail server, I'm simply
| > trying to set up a local web, so I selected "No, I'll do it later".
| >
| > Then I went into FrontPage, selected File + Open Web, typed
| > http://localhost/ and clicked Open, and as before, I get a message
saying:
| > "The folder http://localhost/ isn't accessible. The folder may be
located on
| > an unavailable volume or protected with a password."
| >
| > Also, I've tried logging off from Windows and logging in as
Administrator,
| > going into FrontPage and trying to open http://localhost, and I get the
same
| > error message.
| >
| > And I've also checked that on the "Server Extensions" tab of the
"Default
| > Web Site Properties" dialog, "Enable Authoring" is selected.
| >
| > What should I do now? Your help would be greatly appreciated.
| >
| > Dave
| >
| >
|
|
 
D

Dave Logan

Some more information:

1) If I open My Network Places and open "Add Network Place", and type in
http://localhost, I get the message "the folder you entered does not appear
to be valid. Please choose another." Thus the problem has nothing to do with
FrontPage, it is a Windows or IIS problem, and not a FrontPage problem.

2) If I right-click My Computer and select Manage, then open the Event
Viewer, under Application I can see several Errors, all of which say "COM+"
under "Source"; and if I double-click on any of them, the Event Properties
Description reads:

"The run-time environment has detected an inconsistency in its internal
state. This indicates a potential instability in the process that could be
caused by the custom components running in the COM+ application, the
components they make use of, or other factors. Error in
d:\qxp_slp\com\com1x\src\comsvcs\txprop\dtcinfo.cpp(158).hr=8000fffff:
TransactionManager->GetWhereaboutsSize. For more information see Help and
Support Center at http://go.microsoft.com/fwlink/events.asp"

If I click the link to http://go.microsoft.com/fwlink/events.asp, I get a
message saying There is no additional information about this issue in the
Error and Event Log Messages or Knowledge Base databases"

Does that give anyone a clue? Do I have a corrupt COM file? If so, how do I
fix it?

Dave



Hi - can anyone help me? I'm reposting this because I've had no responses to
my original post, apart from one suggestion that I uninstall and reinstall
IIS, which I did but it made no difference.

I'm using FrontPage 2000 and Windows XP SP2. I recently bought a new laptop
and I can't remember how to set up a local web so that FrontPage will
recognise it. On my old laptop, if I go into FrontPage and select File +
Open Web, I can see "Web folders" under "My Computer", and within "Web
folders" I can see "localhost", and all the websites that I have created
within localhost. Also, if I type http://localhost/ or
http://localhost/DavesWeb/, the website opens.

I have copied all my data to my new laptop, and installed IIS and the
FrontPage 2000 Server Extensions. On my new machine I can go to
http://localhost/DavesWeb in my browser. But in FrontPage, if I select File
+ Open Web, I can't see "Web folders" under "My Computer"; and if I type
http://localhost/ or http://localhost/DavesWeb/, I get a message saying:
"The folder http://localhost/DavesWeb/ [for example] isn't accessible. The
folder may be located on an unavailable volume or protected with a
password." The message box also referred me to a text file, "wecerr.txt",
which stated: "Server Application Error. The server has encountered an error
while loading an application during the processing of your request. Please
refer to the even log for more detail [sic] information. Please contact the
server administrator for assistance."

Yet as I say, I can open http://localhost/DavesWeb/ from within my browser.

Also, if I go into IIS on my new laptop and right-click the DavesWeb folder
and select "All Tasks" + "Open in FrontPage", it just opens index.html, but
not the website (i.e. there's no folder list). And if I right-click on
"Default Web Site" in IIS and select "All Tasks" + "Open With FrontPage", I
get in message in FrontPage saying: "The server could not complete your
request. Contact your Internet Service Provider or web server administrator
to make sure that the server has the FrontPage Server Extensions installed.
For more specific information click Details." Clicking "Details" gives the
same message as in "wecerr.txt" above.

Also, if I open "C:\inetpub\wwwroot" in FrontPage, and then right-click on
the "Davesweb" folder and select "Convert to web", I get a message: "Server
error: Unable to create a disk-based web at "C:\inetpub\wwwroot\Davesweb"
because the parent web would not be a disk-based web. Create the disk-based
web elsewhere, outside of your web server's document hierarchy." I tried
googling for this, but the posts I saw all said I should open the root web
in FP as a server based web (http://localhost) - which as I say, FrontPage
won't let me do.

And whereas on my old laptop, if I open http://localhost/Davesweb in
FrontPage and select Tools + Web Settings, the dialog box says "Server
version: Microsoft-IIS/5.1", on my new laptop, if I open
"C:\inetpub\wwwroot" in FrontPage (it won't let me open
"C:\inetpub\wwwroot\Davesweb" as a web), and select Tools + Web Settings, ,
the dialog box says "Server version: no server installed."

Clearly I haven't configured IIS correctly in order for FrontPage to
recognise that there is a local web on http://localhost/ - although my
browser does recognise it.

What do I need to do to fix this?

Dave
 
Ad

Advertisements

D

Dave Logan

Could the following article be relevant -
http://support.microsoft.com/kb/909444?

The article is way over my head but it does mention the COM+ application
error that I'm getting. Please could some of the MVPs here look at this
article and let me know if it's relevant to my problem, and if so, in
layman's language, what I need to do to fix it?

Dave


| Some more information:
|
| 1) If I open My Network Places and open "Add Network Place", and type in
| http://localhost, I get the message "the folder you entered does not
appear
| to be valid. Please choose another." Thus the problem has nothing to do
with
| FrontPage, it is a Windows or IIS problem, and not a FrontPage problem.
|
| 2) If I right-click My Computer and select Manage, then open the Event
| Viewer, under Application I can see several Errors, all of which say
"COM+"
| under "Source"; and if I double-click on any of them, the Event Properties
| Description reads:
|
| "The run-time environment has detected an inconsistency in its internal
| state. This indicates a potential instability in the process that could be
| caused by the custom components running in the COM+ application, the
| components they make use of, or other factors. Error in
| d:\qxp_slp\com\com1x\src\comsvcs\txprop\dtcinfo.cpp(158).hr=8000fffff:
| TransactionManager->GetWhereaboutsSize. For more information see Help and
| Support Center at http://go.microsoft.com/fwlink/events.asp"
|
| If I click the link to http://go.microsoft.com/fwlink/events.asp, I get a
| message saying There is no additional information about this issue in the
| Error and Event Log Messages or Knowledge Base databases"
|
| Does that give anyone a clue? Do I have a corrupt COM file? If so, how do
I
| fix it?
|
| Dave
|
|
|
| | Hi - can anyone help me? I'm reposting this because I've had no responses
to
| my original post, apart from one suggestion that I uninstall and reinstall
| IIS, which I did but it made no difference.
|
| I'm using FrontPage 2000 and Windows XP SP2. I recently bought a new
laptop
| and I can't remember how to set up a local web so that FrontPage will
| recognise it. On my old laptop, if I go into FrontPage and select File +
| Open Web, I can see "Web folders" under "My Computer", and within "Web
| folders" I can see "localhost", and all the websites that I have created
| within localhost. Also, if I type http://localhost/ or
| http://localhost/DavesWeb/, the website opens.
|
| I have copied all my data to my new laptop, and installed IIS and the
| FrontPage 2000 Server Extensions. On my new machine I can go to
| http://localhost/DavesWeb in my browser. But in FrontPage, if I select
File
| + Open Web, I can't see "Web folders" under "My Computer"; and if I type
| http://localhost/ or http://localhost/DavesWeb/, I get a message saying:
| "The folder http://localhost/DavesWeb/ [for example] isn't accessible. The
| folder may be located on an unavailable volume or protected with a
| password." The message box also referred me to a text file, "wecerr.txt",
| which stated: "Server Application Error. The server has encountered an
error
| while loading an application during the processing of your request. Please
| refer to the even log for more detail [sic] information. Please contact
the
| server administrator for assistance."
|
| Yet as I say, I can open http://localhost/DavesWeb/ from within my
browser.
|
| Also, if I go into IIS on my new laptop and right-click the DavesWeb
folder
| and select "All Tasks" + "Open in FrontPage", it just opens index.html,
but
| not the website (i.e. there's no folder list). And if I right-click on
| "Default Web Site" in IIS and select "All Tasks" + "Open With FrontPage",
I
| get in message in FrontPage saying: "The server could not complete your
| request. Contact your Internet Service Provider or web server
administrator
| to make sure that the server has the FrontPage Server Extensions
installed.
| For more specific information click Details." Clicking "Details" gives the
| same message as in "wecerr.txt" above.
|
| Also, if I open "C:\inetpub\wwwroot" in FrontPage, and then right-click on
| the "Davesweb" folder and select "Convert to web", I get a message:
"Server
| error: Unable to create a disk-based web at "C:\inetpub\wwwroot\Davesweb"
| because the parent web would not be a disk-based web. Create the
disk-based
| web elsewhere, outside of your web server's document hierarchy." I tried
| googling for this, but the posts I saw all said I should open the root web
| in FP as a server based web (http://localhost) - which as I say, FrontPage
| won't let me do.
|
| And whereas on my old laptop, if I open http://localhost/Davesweb in
| FrontPage and select Tools + Web Settings, the dialog box says "Server
| version: Microsoft-IIS/5.1", on my new laptop, if I open
| "C:\inetpub\wwwroot" in FrontPage (it won't let me open
| "C:\inetpub\wwwroot\Davesweb" as a web), and select Tools + Web Settings,
,
| the dialog box says "Server version: no server installed."
|
| Clearly I haven't configured IIS correctly in order for FrontPage to
| recognise that there is a local web on http://localhost/ - although my
| browser does recognise it.
|
| What do I need to do to fix this?
|
| Dave
|
|
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top