Remote Desktop Connection Credentials


G

Gretchen Hembree

I have a few users that use Remote Desktop Connection to connect to our
Terminal Server (after a VPN connection is established.)

I have a Vista user that is asked for his user name and password directly
after hitting connect in RDC. After it then connects to the server he must
reenter it because he is actually connecting to a defferent machine (through
a drop down list.) I blamed this on a Vista issue and told him hopefully it
would be fixed with a Service Pack.

In the meantime I replaced my home machine with a XP pro and it works like
normal, not asking me for my username and password until I am at my server's
log on screen. However now I am looking at a different employee's home
laptop (XP Pro) and she is having the same issue as my Vista user.

I know the next question people are going to ask is what version of RDP am I
running. I can only vouch for the machine I am on now and it is 6.0. When
you look at the General Tab the Logon settings allow you to enter the comuter
name, but the User name is: {none} and below it says: You will be asked for
credentials when you connect.

Is this an easy fix or should I just tell these two users to just get over
being asked to enter their password twice? Thanks!
 
Ad

Advertisements

T

Terry R.

The date and time was 5/20/2008 10:25 AM, and on a whim, Gretchen
Hembree pounded out on the keyboard:
I have a few users that use Remote Desktop Connection to connect to our
Terminal Server (after a VPN connection is established.)

I have a Vista user that is asked for his user name and password directly
after hitting connect in RDC. After it then connects to the server he must
reenter it because he is actually connecting to a defferent machine (through
a drop down list.) I blamed this on a Vista issue and told him hopefully it
would be fixed with a Service Pack.

In the meantime I replaced my home machine with a XP pro and it works like
normal, not asking me for my username and password until I am at my server's
log on screen. However now I am looking at a different employee's home
laptop (XP Pro) and she is having the same issue as my Vista user.

I know the next question people are going to ask is what version of RDP am I
running. I can only vouch for the machine I am on now and it is 6.0. When
you look at the General Tab the Logon settings allow you to enter the comuter
name, but the User name is: {none} and below it says: You will be asked for
credentials when you connect.

Is this an easy fix or should I just tell these two users to just get over
being asked to enter their password twice? Thanks!

I have XP SP3 and it has changed from SP2. When I click the RDP icon,
the initial screen states "Computer" & "User name" (which doesn't have
an option, a change from SP2). If you click the Options button, on the
General tab, both are editable from there. You also have a checkbox to
allow the credentials to be saved. Are you stating that option in that
location for "User name" ISN'T an option?

--
Terry R.

***Reply Note***
Anti-spam measures are included in my email address.
Delete NOSPAM from the email address after clicking Reply.
 
G

Gretchen Hembree

Yes. When I initially click on RDP I only see computer with the IP address
already listed there. The user name doesn't show up. (It doesn't on my
personal machine either.) When I click options it brings up user name, but
next to it is {none} and that can't be altered.

I have figured out that is my user types the server they want\their user
name, it does allow them to bypass the requirement of entering thier user and
password twice. I am curious though as to why on these two machines (one XP
Pro SP2 and one Vista) the RDP requires user name and password entry even
before it connects to the server and why it doesn't on the others.

The main difference I have found is that the user name section on the intial
RDP (after hittting Options) is not alterable.
 
Ad

Advertisements

T

Terry R.

The date and time was 5/20/2008 11:31 AM, and on a whim, Gretchen
Hembree pounded out on the keyboard:
Yes. When I initially click on RDP I only see computer with the IP address
already listed there. The user name doesn't show up. (It doesn't on my
personal machine either.) When I click options it brings up user name, but
next to it is {none} and that can't be altered.

I have figured out that is my user types the server they want\their user
name, it does allow them to bypass the requirement of entering thier user and
password twice. I am curious though as to why on these two machines (one XP
Pro SP2 and one Vista) the RDP requires user name and password entry even
before it connects to the server and why it doesn't on the others.

The main difference I have found is that the user name section on the intial
RDP (after hittting Options) is not alterable.


On the two that have to be entered twice, can the credentials be saved
by checking the box? That should eliminate one set being entered.

Have you checked to see if a group policy was in effect? This is just
for passwords but you never know.

Start > Run > gpedit.msc > Computer Configuration > Administrative
Templates > Windows Components > Terminal Services > Client..Should be
set to "Not Configured" .

Also check the options under User Configuration > Administrative
Templates > Windows Components > Terminal Services to see if any of
those may have been changed.


--
Terry R.

***Reply Note***
Anti-spam measures are included in my email address.
Delete NOSPAM from the email address after clicking Reply.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top