Quotes

  • Thread starter Heimo Ernst WEISS
  • Start date

H

Heimo Ernst WEISS

I recognized a curious behaviour in Word 2007:

With Word Options / Proofing / AutoCorrect / Replace as you type / "straight
Quotes" with "Smart Quotes" selected

If I type in manually a quote the opening quote is changed to 201C (Unicode
hex) the closing quote to 201D (Unicode hex).
If I use find / replace " then the opening quote is changed to 201E (Unicode
hex) the closing quote to 201C (Unicode hex).

I have this behaviour on two different computers...

Does anybody know how to change this?
 
Ad

Advertisements

G

Graham Mayor

It works fine here, however your name suggests you may not be working with
the English language formatting attribute applied to your text. and you may
have automatically detect applied to the language. Smart quotes are language
dependent, so ensure that the language is correct and the automatically
detect language box is unchecked apply.

--
<>>< ><<> ><<> <>>< ><<> <>>< <>><<>
Graham Mayor - Word MVP

My web site www.gmayor.com

<>>< ><<> ><<> <>>< ><<> <>>< <>><<>
 
H

Heimo Ernst WEISS

Graham,

thanks for your fast response. you are correct I am from Austria. However my
installation (Word as well as Windws7) are US-English.

I am aware about the differetn behaviour of the autocorrect depending by
language settings - what bothers me is the fact that the autosorrect works
different depending on typing in a quote manually or using the function
find/replace in one document without changing anything in the language
settings.

But if you cannot reproduce it.... :-(

Regards Heimo
 
P

Peter T. Daniels

The pair of quotation marks inserted by your Find - Replace is correct
for German. Have you checked that the specific document in which you
observed this behavior has a Set Language of US English? Remember that
even a single character imported from a document that has a different
Set Language can reset the language; and uncheck "Detect language
automatically," in the spellcheck controls.
 
Ad

Advertisements

H

Heimo Ernst WEISS

Thaks Peter,

I 've checked it - if I mark the whole document and set the language to
English US and do the same with the footnotes nothing changes.

I could understand if all quotes (manually insereted and inserted by
find/replace) would be in the German format, but only the quotes treated with
find/replace are in that way all quotes inserted manually are correct in the
US "curly" style. Even if I add these quotes immediately after the search
replace.

Heimo
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top