Bug Word 2007: deleting selected spaces in front of smart quotes


K

KAM

I notice this on my Vista/Word 2007 setup but not on my XP/Word 2007 setup.
So the bug may or may not work on your setup. If you DO notice the bug, can
you let me know your OS? I am trying to determine if this is a Vista combo
with Word 2007 issue. Or is anyone else out there familiar with this bizarre
issue?

This is really neat. Try it:
1.Open new Word 2007 doc.
2.Make sure you have the Auto Correct option for replace straight quotes
with smart quotes turned ON. (Smart quotes ON)
3.Type: This is a "test".
4.Make sure they are smart quotes around test.
5.SELECT (highlight) the space between the a and the first quote.
6.Hit the delete key from your keyboard.

On my VISTA machine, the space won't delete if you HAVE IT SELECTED. (you
may delete it by un-selecting it placing the cursor in front of it and
deleting - but that isn't the point). You should be able to highlight the
space and delete it.

This bug will not happen if you have smart quotes turned off. I also noticed
the same behavior if brackets [] are used instead of the quotes.

Another interesting thing is if you have a tab character instead of the
space in front of the smart quote, if you SELECT the tab and delete it with
the keyboard key, it will replace it with a space. If you have the tab
somewhere else not in front of the smart quote, it will delete the tab
without replacing it.

Like I said, this does not occur on all configurations...It is happening on
two Vista/WORD2007 machines here - but not my XP/WORD2007 machine.

Any thoughts?
 
Ad

Advertisements

G

grammatim

Golly, you're right! On the plus side, why would you bother selecting
the space you wanted to delete, rather than just deleting it with
Backspace or Delete?
 
K

KAM

Actually, how I discovered it was in vba code. I have a template that selects
the characters (in certain situations) and verifies what it is (tab, space,
etc). If it is a space, it needs to delete it. Well, with this bug, it wasn't
deleting the space. I will have to re-work my code to check the character
then move then delete. It can be done, it is just a hassle since this is
obviously a bug.

grammatim said:
Golly, you're right! On the plus side, why would you bother selecting
the space you wanted to delete, rather than just deleting it with
Backspace or Delete?

I notice this on my Vista/Word 2007 setup but not on my XP/Word 2007 setup.
So the bug may or may not work on your setup. If you DO notice the bug, can
you let me know your OS? I am trying to determine if this is a Vista combo
with Word 2007 issue. Or is anyone else out there familiar with this bizarre
issue?

This is really neat. Try it:
1.Open new Word 2007 doc.
2.Make sure you have the Auto Correct option for replace straight quotes
with smart quotes turned ON. (Smart quotes ON)
3.Type: This is a "test".
4.Make sure they are smart quotes around test.
5.SELECT (highlight) the space between the a and the first quote.
6.Hit the delete key from your keyboard.

On my VISTA machine, the space won't delete if you HAVE IT SELECTED. (you
may delete it by un-selecting it placing the cursor in front of it and
deleting - but that isn't the point). You should be able to highlight the
space and delete it.

This bug will not happen if you have smart quotes turned off. I also noticed
the same behavior if brackets [] are used instead of the quotes.

Another interesting thing is if you have a tab character instead of the
space in front of the smart quote, if you SELECT the tab and delete it with
the keyboard key, it will replace it with a space. If you have the tab
somewhere else not in front of the smart quote, it will delete the tab
without replacing it.

Like I said, this does not occur on all configurations...It is happening on
two Vista/WORD2007 machines here - but not my XP/WORD2007 machine.

Any thoughts?
 
T

Tony Jollans

This is not, AFAIK, a bug, but deliberate behaviour - and, on balance, I
think it is probably correct more often than not. By default it happens in
both 2003 and 2007 and on both XP and Vista; I don't know how you have
managed to get your XP system not doing it. Lastly, it is the curly quote
characters themselves, amongst others, as you have pointed out, that
trigger the action (or refusal to act), regardless of the smart quotes
setting.
 
T

Tony Jollans

Instead of deleting, try setting the Range equal to "".

I have already posted that I think the behaviour reasonable in the UI; I do
however, tend to agree that it probably shouldn't behave this way in VBA;
that said, it is easy enough to work around.

--
Enjoy,
Tony

www.WordArticles.com

KAM said:
Actually, how I discovered it was in vba code. I have a template that
selects
the characters (in certain situations) and verifies what it is (tab,
space,
etc). If it is a space, it needs to delete it. Well, with this bug, it
wasn't
deleting the space. I will have to re-work my code to check the character
then move then delete. It can be done, it is just a hassle since this is
obviously a bug.

grammatim said:
Golly, you're right! On the plus side, why would you bother selecting
the space you wanted to delete, rather than just deleting it with
Backspace or Delete?

I notice this on my Vista/Word 2007 setup but not on my XP/Word 2007
setup.
So the bug may or may not work on your setup. If you DO notice the bug,
can
you let me know your OS? I am trying to determine if this is a Vista
combo
with Word 2007 issue. Or is anyone else out there familiar with this
bizarre
issue?

This is really neat. Try it:
1.Open new Word 2007 doc.
2.Make sure you have the Auto Correct option for replace straight
quotes
with smart quotes turned ON. (Smart quotes ON)
3.Type: This is a "test".
4.Make sure they are smart quotes around test.
5.SELECT (highlight) the space between the a and the first quote.
6.Hit the delete key from your keyboard.

On my VISTA machine, the space won't delete if you HAVE IT SELECTED.
(you
may delete it by un-selecting it placing the cursor in front of it and
deleting - but that isn't the point). You should be able to highlight
the
space and delete it.

This bug will not happen if you have smart quotes turned off. I also
noticed
the same behavior if brackets [] are used instead of the quotes.

Another interesting thing is if you have a tab character instead of the
space in front of the smart quote, if you SELECT the tab and delete it
with
the keyboard key, it will replace it with a space. If you have the tab
somewhere else not in front of the smart quote, it will delete the tab
without replacing it.

Like I said, this does not occur on all configurations...It is
happening on
two Vista/WORD2007 machines here - but not my XP/WORD2007 machine.

Any thoughts?
 
Ad

Advertisements

K

KAM

This has never happened to me in Word 2003.

You should be able to select (highlight) a character and hit delete from the
keyboard and have it delete the selected character.

Tony Jollans said:
This is not, AFAIK, a bug, but deliberate behaviour - and, on balance, I
think it is probably correct more often than not. By default it happens in
both 2003 and 2007 and on both XP and Vista; I don't know how you have
managed to get your XP system not doing it. Lastly, it is the curly quote
characters themselves, amongst others, as you have pointed out, that
trigger the action (or refusal to act), regardless of the smart quotes
setting.

--
Enjoy,
Tony

www.WordArticles.com

KAM said:
I notice this on my Vista/Word 2007 setup but not on my XP/Word 2007 setup.
So the bug may or may not work on your setup. If you DO notice the bug,
can
you let me know your OS? I am trying to determine if this is a Vista combo
with Word 2007 issue. Or is anyone else out there familiar with this
bizarre
issue?

This is really neat. Try it:
1.Open new Word 2007 doc.
2.Make sure you have the Auto Correct option for replace straight quotes
with smart quotes turned ON. (Smart quotes ON)
3.Type: This is a "test".
4.Make sure they are smart quotes around test.
5.SELECT (highlight) the space between the a and the first quote.
6.Hit the delete key from your keyboard.

On my VISTA machine, the space won't delete if you HAVE IT SELECTED. (you
may delete it by un-selecting it placing the cursor in front of it and
deleting - but that isn't the point). You should be able to highlight the
space and delete it.

This bug will not happen if you have smart quotes turned off. I also
noticed
the same behavior if brackets [] are used instead of the quotes.

Another interesting thing is if you have a tab character instead of the
space in front of the smart quote, if you SELECT the tab and delete it
with
the keyboard key, it will replace it with a space. If you have the tab
somewhere else not in front of the smart quote, it will delete the tab
without replacing it.

Like I said, this does not occur on all configurations...It is happening
on
two Vista/WORD2007 machines here - but not my XP/WORD2007 machine.

Any thoughts?
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top