Printing to Windows 2000 LPD Service

  • Thread starter Michael D. Ober
  • Start date

M

Michael D. Ober

Here's the Tru64 Unix /etc/printcap entry and also what I see when enter

lpr -PWAKE /etc/printcap
lpq -PWAKE

==================================
lp18|lp18|lp|WAKE|18:\
:lp=:\
:rm=10.96.253.1:\
:rp=Printer4:\
:sd=/usr/spool/lpd18:
conejos> lpq -PWAKE
conejos: Thu Oct 27 18:25:34 2005:
Rank Pri Owner Job Files Total Size
1st 0 mike 12 /etc/printcap 4518
bytes


Windows 2000 LPD Server
Printer \\10.96.253.1\Printer4

Owner Status Jobname Job-Id Size Pages Priority
----------------------------------------------------------------------------

===================================

The Windows Server is responding the the LPD request, but the print job
isn't routing to the queue. When "LPR -P 10.96.253.1 -Q Printer4
c:\windows\win.ini" is entered on an XP box on the same network as the Tru64
server, it works. Also, if there are print jobs in the Windows queue, they
show up in response to lpq -PWAKE.

Any ideas?

Thanks,
Mike Ober.
 
Ad

Advertisements

M

Michael D. Ober

Thanks, I just printed this article for reference. Right now, however, I'm
not getting anything from the Tru64 Unix system.

Mike Ober.

Alan Morris said:
the default data is text. If you are sending any other format you will need
to configure the Windows LPD service for passthru or specify this from the
unix client.


http://support.microsoft.com/kb/q150930/


--
Alan Morris
Windows Printing Team
Search the Microsoft Knowledge Base here:
http://support.microsoft.com/default.aspx?scid=fh;[ln];kbhowto

This posting is provided "AS IS" with no warranties, and confers no rights.

Michael D. Ober said:
Here's the Tru64 Unix /etc/printcap entry and also what I see when enter

lpr -PWAKE /etc/printcap
lpq -PWAKE

==================================
lp18|lp18|lp|WAKE|18:\
:lp=:\
:rm=10.96.253.1:\
:rp=Printer4:\
:sd=/usr/spool/lpd18:
conejos> lpq -PWAKE
conejos: Thu Oct 27 18:25:34 2005:
Rank Pri Owner Job Files Total
Size
1st 0 mike 12 /etc/printcap 4518
bytes


Windows 2000 LPD Server
Printer \\10.96.253.1\Printer4

Owner Status Jobname Job-Id Size Pages
Priority
--------------------------------------------------------------------------
--
===================================

The Windows Server is responding the the LPD request, but the print job
isn't routing to the queue. When "LPR -P 10.96.253.1 -Q Printer4
c:\windows\win.ini" is entered on an XP box on the same network as the
Tru64
server, it works. Also, if there are print jobs in the Windows queue,
they
show up in response to lpq -PWAKE.

Any ideas?

Thanks,
Mike Ober.
 
A

Alan Morris [MSFT]

Okay. I'll defer to anyone who has heard of the Tru64 OS.

--
Alan Morris
Windows Printing Team
Search the Microsoft Knowledge Base here:
http://support.microsoft.com/default.aspx?scid=fh;[ln];kbhowto

This posting is provided "AS IS" with no warranties, and confers no rights.

Michael D. Ober said:
Thanks, I just printed this article for reference. Right now, however,
I'm
not getting anything from the Tru64 Unix system.

Mike Ober.

Alan Morris said:
the default data is text. If you are sending any other format you will need
to configure the Windows LPD service for passthru or specify this from
the
unix client.


http://support.microsoft.com/kb/q150930/


--
Alan Morris
Windows Printing Team
Search the Microsoft Knowledge Base here:
http://support.microsoft.com/default.aspx?scid=fh;[ln];kbhowto

This posting is provided "AS IS" with no warranties, and confers no rights.

Michael D. Ober said:
Here's the Tru64 Unix /etc/printcap entry and also what I see when
enter

lpr -PWAKE /etc/printcap
lpq -PWAKE

==================================
lp18|lp18|lp|WAKE|18:\
:lp=:\
:rm=10.96.253.1:\
:rp=Printer4:\
:sd=/usr/spool/lpd18:
conejos> lpq -PWAKE
conejos: Thu Oct 27 18:25:34 2005:
Rank Pri Owner Job Files Total
Size
1st 0 mike 12 /etc/printcap 4518
bytes


Windows 2000 LPD Server
Printer \\10.96.253.1\Printer4

Owner Status Jobname Job-Id Size Pages
Priority
--------------------------------------------------------------------------
--
===================================

The Windows Server is responding the the LPD request, but the print job
isn't routing to the queue. When "LPR -P 10.96.253.1 -Q Printer4
c:\windows\win.ini" is entered on an XP box on the same network as the
Tru64
server, it works. Also, if there are print jobs in the Windows queue,
they
show up in response to lpq -PWAKE.

Any ideas?

Thanks,
Mike Ober.
 
R

rlmobil

Typical for MS knowledge base: A lot of text and no help.
Even if Postscript is sent to the printer via lpd, it should print it, as
PS is plain ASCII. All PS statements would appear on the printout.
Just not the desired result :)

Rainer
 
M

Michael D. Ober

Did you read the article itself? This is a workaround for LPR systems that
don't comply with the header bytes for LPR print jobs. There are a few
older unix's out there for which this is a problem.

Mike.
 
Ad

Advertisements

R

rlmobil

Mike,

did it help in your case? As I stated it should have printed the PS code
in case of a wrong format. In your post you said that it did not print at
all!
Rainer
I apologize my statement but I never found help there.
 
M

Michael D. Ober

No it didn't. The problem was on the Tru64 Unix server. The printing
subsystem had to be restarted. A Windows XP system on the same network as
the Tru64 server could print no problem and I could see the print jobs in
the Tru64 queue as well as my Windows 2000 LPD queue while logged in on the
Tru64 system.

One note - when you apply the registry edit described in this document you
will need to reboot your server. It causes the server to loose all its
printers.

Thanks for responding to my request for assistance. I ended up call HP
support. It turns out that an rm/rp queue on Tru64 Unix is unable to filter
print jobs. HP support sent me a document on how to do it using two print
queues and a filter script.

Mike.

rlmobil said:
Mike,

did it help in your case? As I stated it should have printed the PS code
in case of a wrong format. In your post you said that it did not print at
all!
Rainer
I apologize my statement but I never found help there.


Did you read the article itself? This is a workaround for LPR systems
that
don't comply with the header bytes for LPR print jobs. There are a few
older unix's out there for which this is a problem.

Mike.

rlmobil said:
Typical for MS knowledge base: A lot of text and no help.
Even if Postscript is sent to the printer via lpd, it should print it,
as
PS is plain ASCII. All PS statements would appear on the printout.
Just not the desired result :)

Rainer


On Wed, 9 Nov 2005 17:51:21 -0800, Alan Morris [MSFT]

the default data is text. If you are sending any other format you
will
need
to configure the Windows LPD service for passthru or specify this from
the
unix client.


http://support.microsoft.com/kb/q150930/
 
R

rlmobil

Mike,

great that it works now. Can you post the document to the community or at
least forward it to me?

Thanks
Rainer
No it didn't. The problem was on the Tru64 Unix server. The printing
subsystem had to be restarted. A Windows XP system on the same network
as
the Tru64 server could print no problem and I could see the print jobs in
the Tru64 queue as well as my Windows 2000 LPD queue while logged in on
the
Tru64 system.

One note - when you apply the registry edit described in this document
you
will need to reboot your server. It causes the server to loose all its
printers.

Thanks for responding to my request for assistance. I ended up call HP
support. It turns out that an rm/rp queue on Tru64 Unix is unable to
filter
print jobs. HP support sent me a document on how to do it using two
print
queues and a filter script.

Mike.

rlmobil said:
Mike,

did it help in your case? As I stated it should have printed the PS code
in case of a wrong format. In your post you said that it did not print
at
all!
Rainer
I apologize my statement but I never found help there.


Did you read the article itself? This is a workaround for LPR systems
that
don't comply with the header bytes for LPR print jobs. There are a few
older unix's out there for which this is a problem.

Mike.

Typical for MS knowledge base: A lot of text and no help.
Even if Postscript is sent to the printer via lpd, it should print it,
as
PS is plain ASCII. All PS statements would appear on the printout.
Just not the desired result :)

Rainer


On Wed, 9 Nov 2005 17:51:21 -0800, Alan Morris [MSFT]

the default data is text. If you are sending any other format you
will
need
to configure the Windows LPD service for passthru or specify this from
the
unix client.


http://support.microsoft.com/kb/q150930/
 
Ad

Advertisements

M

Michael D. Ober

As soon as it's verified, I'll post the entire configuration (both ends).

Mike.
rlmobil said:
Mike,

great that it works now. Can you post the document to the community or at
least forward it to me?

Thanks
Rainer
No it didn't. The problem was on the Tru64 Unix server. The printing
subsystem had to be restarted. A Windows XP system on the same network
as
the Tru64 server could print no problem and I could see the print jobs in
the Tru64 queue as well as my Windows 2000 LPD queue while logged in on
the
Tru64 system.

One note - when you apply the registry edit described in this document
you
will need to reboot your server. It causes the server to loose all its
printers.

Thanks for responding to my request for assistance. I ended up call HP
support. It turns out that an rm/rp queue on Tru64 Unix is unable to
filter
print jobs. HP support sent me a document on how to do it using two
print
queues and a filter script.

Mike.

rlmobil said:
Mike,

did it help in your case? As I stated it should have printed the PS code
in case of a wrong format. In your post you said that it did not print
at
all!
Rainer
I apologize my statement but I never found help there.


On Fri, 11 Nov 2005 07:30:04 -0700, Michael D. Ober

Did you read the article itself? This is a workaround for LPR systems
that
don't comply with the header bytes for LPR print jobs. There are a
few
older unix's out there for which this is a problem.

Mike.

Typical for MS knowledge base: A lot of text and no help.
Even if Postscript is sent to the printer via lpd, it should print
it,
as
PS is plain ASCII. All PS statements would appear on the printout.
Just not the desired result :)

Rainer


On Wed, 9 Nov 2005 17:51:21 -0800, Alan Morris [MSFT]

the default data is text. If you are sending any other format you
will
need
to configure the Windows LPD service for passthru or specify this from
the
unix client.


http://support.microsoft.com/kb/q150930/
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads


Top