Print Spooler Event ID 7031


Wayne Jones

I am receiving the error messages, posted belows, in the
System Event Log. These errors seem to occur at random
and I have not been able to nail it down to a particular
driver, or print monitor. Whenever the print spooler
stops after the error, I am unable to start the spooler
successfully until I clear the spool directory of its
contents. I have verified the contents of what was being
printed when the spooler crashes and the spooled document
is not always from the same application.

This is occurring on my Windows 2000 Server with SP4
print/file server. I have 13 printer shared out through
this server. The error occurs randomly and does not seem
to be happening when any particular printer or document is
being printed.

I have seen several TechNet articles related to applying
the latest service pack and using the Windows 2000 printer
drivers. This is the case with all but one of my
printers, a Brother HL-1440. I have removed this printer
and its driver and the problem still occurs randomly.

Event ID: 7031
The Print Spooler service terminated unexpectedly. It has
done this 1 time(s). The following corrective action will
be taken in 60000 milliseconds: Restart the service.

Event ID: 2510
The server service was unable to map error code 1722.

Any assistance would be greatly appreciated, as this has
gotten to be a rather annoying problem.

Wayne Jones

Alan Morris\(MSFT\)

You need an updated GDI32 binary. Or remove SP4.

GDI error 7031
Access Violation in Spoolsv.exe GDI32!IcmInitIcmInfo in Windows 2000

Date Time Version Size File name
11-Jun-2002 09:48 5.00.2195.5878 222,992 Gdi32.dll

Alan Morris
Windows Printing Team
Search the Microsoft Knowledge Base here:;[ln];kbhowto

This posting is provided "AS IS" with no warranties, and confers no rights.


We are having the same issues on our Windows 2000 SP4 server. Did you
ever get resolution on this issue. Any help would be greatly
appreciated. This is getting to be a real pain for us.



I have the same problem ... running metaframe 1.8 ...
i replaced the spoolsrv.exe file it worked the first time and now its
doing the same thing ... tried to replace the file again in
C\wnnt\system32 but it doesnt work now ...

should i remove sp4 ????

please advise ppl need to print asap




We had the same problem on our 2 Citrix Servers just yesterday (Mon 2n
Feb 2004), printing to the print server.
Print server is printing fine, and so is any other server that print
to the server.

Tried the suggested Microsoft Hotfix, no differnce.
Installed Win2k SP4, run windows updates. No difference.

Then, i deleted the the files within the Print Spooler directory
backed them up 1st though. Rebooted server, and viola. Workin
perfectly again.

Done same on other server too, Win2k SP4 + updates to keep them bot
the same.

Suggest you try this fix


Jojo Almario

I have had this exact problem(today)on my Citrix server no less.
Deleting the files in the /system32 print spool folder did th
trick(thanks Kawasakigtr)! Is it a coincidence that the fix worked o
Citrix servers or even occurs on Metaframes or is it something i
Citrix that causes this behavior

Jojo Almari

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question