Plug and Play user interface dialogs have been suppressed in factory mode.



I had this same problem... It seems that somebody used the Microsoft
"sysprep" utility to set up my system. It puts the computer in a
"factory mode" for easy loading of drivers and such. To get the
computer out of factory mode and ready for the user, the technician is
supposed to run the command "sysprep -reseal". So I downloaded the
sysprep utility from Microsoft's website

(comes inside of a cab file of utilities). I ran "sysprep -reseal".
The computer rebooted, and appeared to be re-installing windows
components. After this process, all my files/programs/drivers were
still there but any encrypted files (such as security certificates)
were rendered unreadable. It was pretty easy though to replace these
certificates and encrypted files. So that's one way to solve this
problem if you don't have a lot of encrypted files.

System Event log description says "Plug and Play user interface
dialogs have been suppressed in factory mode." Seems to result in a
problem with the XP "ADD HARDWARE WIZARD" because the wizard hesitates
and then returns a message which says "You can add only one device at
a time." I sure would like to solve this nagging problem! Especially
since there should be nothing related to hardware install going on in
the background.

Any responsible suggestions will be appreciated.



Jan 31, 2012
Reaction score
To fix the issue in Windows XP 32-bit versions, add a DWORD value that is named "SuppressNewHWUI" to the following registry subkey:

To configure this registry setting, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate the following subkey in the registry, and then click it: HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\DeviceInstall\Settings
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type SuppressNewHWUI for the name of the DWORD entry, and then press ENTER.
  5. Right-click SuppressNewHWUI, and then click Modify.
  6. Do one of the following:
    • To suppress messages, type 1 in the Value data box, and then click OK.
    • To stop suppressing messages, type 0 in the Value data box, and then click OK.
  7. Exit Registry Editor, and then restart the computer.

    Note The setting does not take effect until the computer is restarted.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question