Outlook 2007 rule not running automatically 1 runs 1 does not?


G

GeorgeBerz

Outlook 2007 rule not running automatically 1 runs 1 does not?
I am very frustrated, I have a new setup of Outlook 2007 and cannot get
rules to function correctly... here goes...

I use IMAP email form my web host as I want messages coordinated with the
server and addl computer at home.

I have created a rule to copy all mail from account [email protected]?????? to the
main inbox (this works fine)
then the 2nd rule does not run which is delete any message with the word
[SPAM] caps and in those brackets as the email server marks suspected
incoming SPAM with [SPAM] in the subject.
Our email server uses SPAM ASSASSIN in cpanel.

I have tried changing the order which the rules are processed and it does
not seem to matter.

anyhow the SPAM messages are supposed (by rule) to be MOVED to the junk mail
folder, this does not happen

Now I can click on rules manually and run rules NOW and it will move the
messages ok.

What is up how can this be automatic?

I have the same problem on 3 office computers 1 with vista home 32 and
others with xp pro all updated of course
 
Ad

Advertisements

B

Brian Tillman [MVP-Outlook]

I have created a rule to copy all mail from account [email protected]?????? to the
main inbox (this works fine)

What's the "main" Inbox, in your opinion.
then the 2nd rule does not run which is delete any message with the word
[SPAM] caps and in those brackets as the email server marks suspected
incoming SPAM with [SPAM] in the subject.
Our email server uses SPAM ASSASSIN in cpanel.

I have tried changing the order which the rules are processed and it does
not seem to matter.

anyhow the SPAM messages are supposed (by rule) to be MOVED to the junk mail
folder, this does not happen

Rules work only when a message is received. For an IMAP account, they'll work
only on the messages that remain in the IMAP's Inbox and only if you download
the full message and not just the headers. Since you say you want the rule to
operate after the message is in the "main" Inbox, I suspect that's where the
problem lies. Moreover, moving messages for an IMAP account works differently
than for another type of account. A "move" consists of a copy then a delete.
The copy should work OK, provided the rule is allowed to work on the IMAP
Inbox, but the delete will simply mark the message for deletion, displaying it
with an overstrike. IMAP deleted messages don't get purged from the folder
until you purge them, either with an explicit purge or by a setting in Outlook
to purge when you change folders or close Outlook. It might help to use the
"Hide Messages Marked for Deletion" view instead if the "IMAP Messages" view.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top