No password option for screen saver


J

Joe M.

Upon inactivity I would like to activate a password protected screensaver.
However my screensaver settings in the display properties does not have a
password option. I've heard that if your user account has a password then the
screen saver will also, but this isn't the case. When my screen saver runs
there's no password prompt. Can anyone help?

Thanks,
Joe M.
 
Ad

Advertisements

V

VanguardLH

in message
Upon inactivity I would like to activate a password protected
screensaver.
However my screensaver settings in the display properties does not
have a
password option. I've heard that if your user account has a password
then the
screen saver will also, but this isn't the case. When my screen
saver runs
there's no password prompt. Can anyone help?


You mean an option to enter the password, or an option to *enable*
password protection when the screen saver activates?There is an "on
resume" option to enable password protection. There is no input field
to specify the password as the same one gets reused that you used to
login to your Windows account. Are you saying that somehow the dialog
window shown at
http://www.askdavetaylor.com/how_do_i_stop_windows_xp_screensaver_asking_for_my_password.html
no longer shows the "on resume" password protect option (even if
grayed out) shown in the red circle in the picture?

Are you using the screen savers included in Windows or from a 3rd
party product?

Do you use auto-logging to automatically log into your Windows account
when you boot the computer?
 
J

Joe M.

In answer to your questions:

- There is no option to enable password protection.
- It is not grayed out, it doesn't appear at all.
- I do not use automatic logging. We have 3 user accounts and you must log
on in the welcome screen.
- These are with the Windows XP screensavers

Thanks,
Joe M.
 
V

VanguardLH

in message
In answer to your questions:

- There is no option to enable password protection.
- It is not grayed out, it doesn't appear at all.
- I do not use automatic logging. We have 3 user accounts and you
must log
on in the welcome screen.
- These are with the Windows XP screensavers

Are you logged in under an admin-level account when you check the
screensaver settings?

Is(are) the host(s) in a domain? If so, group policy can dictate that
users cannot modify screensaver settings. That includes preventing
the users from changing the time to wait before activating the
screensaver and disabling password protection. Group policies are
recorded in the registry so it is also possible to enforce the same
behavior using a local security policy. I don't know what is the
registry setting. However, my recollection when using a group/local
policy to disable the password protect option (usually to force it
enabled) is that the option is greyed out to show that changing it is
disabled, not that it disappears completely from that dialog.

If you pick no screensaver (i.e., "(None)"), do the Wait and "On
Resume" option appear (but greyed out)? Do they appear (whether
greyed out or not) if you pick a different screensaver?
 
J

Joe M.

- This is a home pc so there is no domain.
- My account is the administrator.
- The "wait" and "on resume" are visible regardless if a screensaver i
sselected or not.
- The wait for _minutes is visible. The only option to chose is "return to
Welcome screen".
- If I select a screensaver then it will appear after the wait time
specified. However there is no password prompt it just returns to the
desktop.

Thanks,
Joe M.
 
S

Shenan Stanley

Joe said:
Upon inactivity I would like to activate a password protected
screensaver. However my screensaver settings in the display
properties does not have a password option. I've heard that if your
user account has a password then the screen saver will also, but
this isn't the case. When my screen saver runs there's no password
prompt. Can anyone help?
You mean an option to enter the password, or an option to *enable*
password protection when the screen saver activates?There is an "on
resume" option to enable password protection. There is no input
field to specify the password as the same one gets reused that you
used to login to your Windows account. Are you saying that somehow
the dialog window shown at
http://www.askdavetaylor.com/how_do_i_stop_windows_xp_screensaver_asking_for_my_password.html
no longer shows the "on resume" password protect option (even if
grayed out) shown in the red circle in the picture?

Are you using the screen savers included in Windows or from a 3rd
party product?

Do you use auto-logging to automatically log into your Windows
account when you boot the computer?
In answer to your questions:

- There is no option to enable password protection.
- It is not grayed out, it doesn't appear at all.
- I do not use automatic logging. We have 3 user accounts and you
must log on in the welcome screen.
- These are with the Windows XP screensavers
Are you logged in under an admin-level account when you check the
screensaver settings?

Is(are) the host(s) in a domain? If so, group policy can dictate
that users cannot modify screensaver settings. That includes
preventing the users from changing the time to wait before
activating the screensaver and disabling password protection.
Group policies are recorded in the registry so it is also possible
to enforce the same behavior using a local security policy. I
don't know what is the registry setting. However, my recollection
when using a group/local policy to disable the password protect
option (usually to force it enabled) is that the option is greyed
out to show that changing it is disabled, not that it disappears
completely from that dialog.

If you pick no screensaver (i.e., "(None)"), do the Wait and "On
Resume" option appear (but greyed out)? Do they appear (whether
greyed out or not) if you pick a different screensaver?
- This is a home pc so there is no domain.
- My account is the administrator.
- The "wait" and "on resume" are visible regardless if a
screensaver i sselected or not.
- The wait for _minutes is visible. The only option to chose is
"return to Welcome screen".
- If I select a screensaver then it will appear after the wait time
specified. However there is no password prompt it just returns to
the desktop.

Okay - so what I see here is that you have an account that is of an
administrative level. When you turn off and turn on the power to said
computer - you have to click on the user account name on the Welcome Screen
and enter a password (not blank) to logon to utilize the computer.

You select a screensaver (like "Blank" or "Windows XP") and you do not see
"On Resume, display Welcome Screen" or "On resume, password protect" - or do
you and they are greyed out? I am confused here - having read through it
all a couple of times. heh

Control Panel --> User Accounts --> Change the way users logon
What are the settings there?

How long do you wait before de-activating the screensaver to see if it
returned to the logon prompt/welcome screen? I'd suggest installing TweakUI
and checking what the settings are for the "Grace Period".

Have you seen this?
http://support.microsoft.com/kb/328000

Checked the registry value?
http://www.pctools.com/guides/registry/detail/1189/
 
Ad

Advertisements

V

VanguardLH

in message
- This is a home pc so there is no domain.
- My account is the administrator.
- The "wait" and "on resume" are visible regardless if a screensaver
i
sselected or not.

Now you say that you CAN see the "on resume" (password) option in the
dialog used to select the screensaver. Before you said that option
was not present at all in that dialog. I specifically gave a URL to a
picture of that dialog that had the "on resume" option circled in red
and asked if that is what was NOT appearing in the dialog, and you
said it was not there. Disabled is NOT the same as hidden or missing.
- The wait for _minutes is visible. The only option to chose is
"return to
Welcome screen".

Oh, maybe you left Windows configured with the Fisher-Price interface
which includes the Welcome Screen. That is the FIRST junk I get rid
of after installing Windows XP.
- If I select a screensaver then it will appear after the wait time
specified. However there is no password prompt it just returns to
the
desktop.

Did you ever specify a non-blank password for your account? The
default password is blank. YOU have to specify a non-blank password
if you want to use one. If you don't have a password for the
Administrator account then how could Windows ever require one when
resuming from screensaver mode?
 
J

Joe M.

Sorry if I was not clear. What I see in the screen saver settings is:
- Wait (to set the minutes)
- Check box for "on resume display welcome screen"
That's all there is. If I leave the "on resume" unchecked the screen saver
will appear after the wait time but there is no password prompt when the
screen saver is activated. Pressing any key stops the screen saver and
returns to the desktop.
Thanks,
Joe
 
S

Shenan Stanley

<scroll to bottom of conversation for latest post>
Upon inactivity I would like to activate a password protected
screensaver. However my screensaver settings in the display
properties does not have a password option. I've heard that if your
user account has a password then the screen saver will also, but
this isn't the case. When my screen saver runs there's no password
prompt. Can anyone help?
You mean an option to enter the password, or an option to *enable*
password protection when the screen saver activates?There is an "on
resume" option to enable password protection. There is no input
field to specify the password as the same one gets reused that you
used to login to your Windows account. Are you saying that somehow
the dialog window shown at
http://www.askdavetaylor.com/how_do_i_stop_windows_xp_screensaver_asking_for_my_password.html
no longer shows the "on resume" password protect option (even if
grayed out) shown in the red circle in the picture?

Are you using the screen savers included in Windows or from a 3rd
party product?

Do you use auto-logging to automatically log into your Windows
account when you boot the computer?
In answer to your questions:

- There is no option to enable password protection.
- It is not grayed out, it doesn't appear at all.
- I do not use automatic logging. We have 3 user accounts and you
must log on in the welcome screen.
- These are with the Windows XP screensavers
Are you logged in under an admin-level account when you check the
screensaver settings?

Is(are) the host(s) in a domain? If so, group policy can dictate
that users cannot modify screensaver settings. That includes
preventing the users from changing the time to wait before
activating the screensaver and disabling password protection.
Group policies are recorded in the registry so it is also possible
to enforce the same behavior using a local security policy. I
don't know what is the registry setting. However, my recollection
when using a group/local policy to disable the password protect
option (usually to force it enabled) is that the option is greyed
out to show that changing it is disabled, not that it disappears
completely from that dialog.

If you pick no screensaver (i.e., "(None)"), do the Wait and "On
Resume" option appear (but greyed out)? Do they appear (whether
greyed out or not) if you pick a different screensaver?
- This is a home pc so there is no domain.
- My account is the administrator.
- The "wait" and "on resume" are visible regardless if a
screensaver i sselected or not.
- The wait for _minutes is visible. The only option to chose is
"return to Welcome screen".
- If I select a screensaver then it will appear after the wait time
specified. However there is no password prompt it just returns to
the desktop.
Sorry if I was not clear.

What I see in the screen saver settings is:
- Wait (to set the minutes)
- Check box for "on resume display welcome screen"

That's all there is. If I leave the "on resume" unchecked the
screen saver will appear after the wait time but there is no
password prompt when the screen saver is activated. Pressing any
key stops the screen saver and returns to the desktop.

For the explanation you give - yes... That's correct.
Did you mistakenly write something other than what you intended to write?


Questions for you (Yes/No):
~~~~~~~~~~~~~~~~~~~~~
1) When you turn off and turn on the power to said computer - do you
have to click on the user account name on the Welcome Screen
and enter a password (not blank, not just ENTER) to logon to
utilize the computer?

2) You select a screensaver (like "Blank" or "Windows XP") and you do see
"On Resume, display Welcome Screen"... And above you say it is
UNCHECKED. You do realize that has to be CHECKED to be active...?

Assuming you meant it WAS checked (not what you said)...
3) How long do you wait before de-activating the screensaver to see if it
returned to the logon prompt/welcome screen?

Suggestions:
~~~~~~~~~~
- Make sure the checkbox for "On Resume, display Welcome Screen"
is checked...
- I'd suggest installing TweakUI and checking what the settings are for
the "Grace Period".
- Have you seen this?
http://support.microsoft.com/kb/328000
- Checked the registry value?
http://www.pctools.com/guides/registry/detail/1189/
 
J

Joe M.

In response to your questions:
#1 - Yes, I select a user and enter a password (not blank)
#2 - If I leave it checked it goes to the welcome screen which is NOT what I
want. I just want it to go to the screensaver with a password. Unchecked the
screensaver appears without the welcome screen.
#3 - I have waited maybe 10 minutes before deactivating the screensaver.
The MS article you suggested is in reference to activating the screen saver
manually which is not the case for me. The pctools article I have also seen
but it does not apply to my problem.

Thanks,
Joe M.
 
S

Shenan Stanley

<scroll to bottom of conversation for latest post>
Upon inactivity I would like to activate a password protected
screensaver. However my screensaver settings in the display
properties does not have a password option. I've heard that if your
user account has a password then the screen saver will also, but
this isn't the case. When my screen saver runs there's no password
prompt. Can anyone help?
You mean an option to enter the password, or an option to *enable*
password protection when the screen saver activates?There is an "on
resume" option to enable password protection. There is no input
field to specify the password as the same one gets reused that you
used to login to your Windows account. Are you saying that somehow
the dialog window shown at
http://www.askdavetaylor.com/how_do_i_stop_windows_xp_screensaver_asking_for_my_password.html
no longer shows the "on resume" password protect option (even if
grayed out) shown in the red circle in the picture?

Are you using the screen savers included in Windows or from a 3rd
party product?

Do you use auto-logging to automatically log into your Windows
account when you boot the computer?
In answer to your questions:

- There is no option to enable password protection.
- It is not grayed out, it doesn't appear at all.
- I do not use automatic logging. We have 3 user accounts and you
must log on in the welcome screen.
- These are with the Windows XP screensavers
Are you logged in under an admin-level account when you check the
screensaver settings?

Is(are) the host(s) in a domain? If so, group policy can dictate
that users cannot modify screensaver settings. That includes
preventing the users from changing the time to wait before
activating the screensaver and disabling password protection.
Group policies are recorded in the registry so it is also possible
to enforce the same behavior using a local security policy. I
don't know what is the registry setting. However, my recollection
when using a group/local policy to disable the password protect
option (usually to force it enabled) is that the option is greyed
out to show that changing it is disabled, not that it disappears
completely from that dialog.

If you pick no screensaver (i.e., "(None)"), do the Wait and "On
Resume" option appear (but greyed out)? Do they appear (whether
greyed out or not) if you pick a different screensaver?
- This is a home pc so there is no domain.
- My account is the administrator.
- The "wait" and "on resume" are visible regardless if a
screensaver i sselected or not.
- The wait for _minutes is visible. The only option to chose is
"return to Welcome screen".
- If I select a screensaver then it will appear after the wait time
specified. However there is no password prompt it just returns to
the desktop.
Sorry if I was not clear.

What I see in the screen saver settings is:
- Wait (to set the minutes)
- Check box for "on resume display welcome screen"

That's all there is. If I leave the "on resume" unchecked the
screen saver will appear after the wait time but there is no
password prompt when the screen saver is activated. Pressing any
key stops the screen saver and returns to the desktop.

Shenan said:
For the explanation you give - yes... That's correct.
Did you mistakenly write something other than what you intended to
write?


Questions for you (Yes/No):
~~~~~~~~~~~~~~~~~~~~~
1) When you turn off and turn on the power to said computer - do you
have to click on the user account name on the Welcome Screen
and enter a password (not blank, not just ENTER) to logon to
utilize the computer?

2) You select a screensaver (like "Blank" or "Windows XP") and you
do see "On Resume, display Welcome Screen"... And above you say it
is UNCHECKED. You do realize that has to be CHECKED to be
active...?

Assuming you meant it WAS checked (not what you said)...
3) How long do you wait before de-activating the screensaver to see
if it returned to the logon prompt/welcome screen?

Suggestions:
~~~~~~~~~~
- Make sure the checkbox for "On Resume, display Welcome Screen"
is checked...
- I'd suggest installing TweakUI and checking what the settings are
for the "Grace Period".
- Have you seen this?
http://support.microsoft.com/kb/328000
- Checked the registry value?
http://www.pctools.com/guides/registry/detail/1189/
In response to your questions:
#1 - Yes, I select a user and enter a password (not blank)
#2 - If I leave it checked it goes to the welcome screen which is
NOT what I want. I just want it to go to the screensaver with a
password. Unchecked the screensaver appears without the welcome
screen. #3 - I have waited maybe 10 minutes before deactivating the
screensaver. The MS article you suggested is in reference to
activating the screen saver manually which is not the case for me.
The pctools article I have also seen but it does not apply to my
problem.

*sigh*
You seem to be changing everything you said.
Let's see if we can get this straight.

You first said you did not have an option to password protect your
screensaver.
You also stated originally that you did not have the password option.

Are you now saying that you set the checkbox for "On Resume - Display
Welcome Screen" as checked. You wait for the screensaver to come up. The
screensaver never appears - but just goes straight to the welcome screen...
Or the screensaver appears, but when you move the mouse/press a key - it
shows the Welcome Screen and you have to click on your username and type in
your password again to log back on? (If the latter - yes - that is 100%
correct and expected.)

What you obviously did not understand (may not now) is that the "On Resume -
Display Welcome Screen" is the same - given your chosen method of logon - as
"On Resume, Password Protect".

If you want the latter message - you will have to change the way you
logon... I aked this in my original response - which you ignored:

Control Panel --> User Accounts --> Change the way users logon
What are the settings there?

If you want the, "On Resume, Password Protect" checkbox - you need to change
to Classic Logon - in other words - you cannot use the Welcome screen if you
want the text to say "password protect" instead of "display welcome screen".

Now you are saying that when the box is checked - you get NO screensaver -
it just goes straight to the welcome screen. Sounds like something is
moving/happening after the screensaver activates if you never see the
screensaver - although that seems bizarre.

Change the way users logon (uncheck "Use the Welcome Screen") and reboot.
You better know your actual username before you reboot - because from that
point on you will have to type in your username.

START button --> RUN --> type in:

cmd /k set

--> Click OK.

In the windows that comes up, the part after "USERNAME=" is your actual
username.

Come back - let us know!

BTW - There is a possibility that what you want is not possible innately.
You may actually think you can get the Welcome screen logon and when the
screensaver appears and you move the mouse - you should get the classic
logon or just a box asking you for a password. That is *not* the way
Windows XP works (or hasn't since 2001) with the settings you say you have
(Welcome screen logon, "On Resume, Display Welcome Screen" checked, etc.)

With the classic logon - you won't ever have the welcome screen and have to
manually type in your password each time (username as well possibly -
although - it is probably set to remember the last user logged on) you turn
on the computer and when you deactivate the screensaver. You cannot *mix*
the classic/welcome screen logons and Windows XP does not have pure password
protected screensavers. It is not based off the old Windows 9x code - so it
does not have the weaker features of those OSes.

You could get a third party screensaver that might give you that feature -
but i do not know WHY you would do that.
 
Ad

Advertisements

V

VanguardLH

in message
Sorry if I was not clear. What I see in the screen saver settings
is:
- Wait (to set the minutes)
- Check box for "on resume display welcome screen"
That's all there is. If I leave the "on resume" unchecked the screen
saver
will appear after the wait time but there is no password prompt when
the
screen saver is activated. Pressing any key stops the screen saver
and

Specify a non-blank password for the account under which you login
into Windows.

Well, why aren't you checking the "on resume" option? You say that
you leave it unchecked. That means you don't want any password
protection (by returning to the Welcome Screen).
 
Ad

Advertisements

V

VanguardLH

in message
#2 - If I leave it checked it goes to the welcome screen which is
NOT what I
want. I just want it to go to the screensaver with a password.
Unchecked the
screensaver appears without the welcome screen.

The screensaver activates after the specified interval if inactivity.
When you move the mouse or hit a keyboard key, you then "resume" by
showing the Welcome Screen which then has you specify the password to
get back into your Windows session. The Welcome Screen *is* the login
screen where you enter your password. And, in your setup, the Welcome
Screen is also the resume session login screen after exiting the
screensaver.

When testing a screensaver, you need to let it run for 1 minute, or
longer; otherwise, you are inside the grace period where the
screensaver activates but you are at the computer and don't want to
lockup your computer so you move the mouse within a minute and the
screensaver disappears and you are back to your desktop.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top