No DNS servers listed in IPCONFIG /all


A

Andy C

Windows XP Home
ADSL USB modem

I've got a dial-up ADSL connection that seems to have lost its DNS
servers. In the IP configuration they are set to 'Obtain DNS server
address automatically' but once dialled-up and connected they don't
show up on an IPCONFIG /all anymore, whereas they used to. I've tried
re-creating the connection, resetting the IP winsock and checking with
the ISP that I've got everything right. Still doesn't work.

See example below:
PPP adapter MyISP:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
Physical Address. . . . . . . . . : xx-xx-45-00-00-00
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : xx.189.148.48
Subnet Mask . . . . . . . . . . . : 255.255.255.255
Default Gateway . . . . . . . . . : xx.189.148.48

As you can see: no DNS servers listed. I can still ping hosts out on
the internet, just not by name.
If I manually add an OpenDNS server (208.67.222.222) I can browse and
ping by name.

Any clues?
 
Ad

Advertisements

J

James Egan

Any clues?

The nameservers are usually assigned as part of the ppp negotiation so
perhaps a look through the logfile might show something.

To switch on ppp logging you need to edit the registry as follows

System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Tracing\PPP]
Value Name: EnableFileTracing
Data Type: REG_DWORD (DWORD Value)
Value Data: (0 = disabled, 1 = enabled)

Setting the value data to 1 will record ppp.log in the windows\tracing
directory.


Jim.
 
Ad

Advertisements

A

Andy C

....
Setting the value data to 1 will record ppp.log in the windows
\tracing
directory.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top